Skip to content

Commit

Permalink
dev-python/jinja: Bump to 3.0.3
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Nov 10, 2021
1 parent 52d5404 commit a82776c
Show file tree
Hide file tree
Showing 2 changed files with 53 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/jinja/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST jinja-2.11.3.tar.gz 258057 BLAKE2B 4735464d044718ce1e6b2663ecb1b238b38fbf0f37ed683257775fe9e853186c089b98494209e511be5aa96bf6df8f6d472be132b6184a7d9213e182099c0433 SHA512 f8e2951edf780d7b44ac74d36579c89b0a5c076b4250faf643ae7e3ff6a431fedaabed640e5efb496cda1a79a4057bf312ae652484c8d4631d521689eb0adbc1
DIST jinja-3.0.2.tar.gz 273251 BLAKE2B 69ef01fdce0be5d1df8eec01606c4fde72232aac2e089aed9a3a7e549a3ed283881c7c864aadb50d53eb5f1324781e3a89c2398e8c30e27dbed14d5917154513 SHA512 e6cf8b8e9fb3efc57806c9a17e71444f6e01f4d039c4894ee31aa4a042e63c31c9a68c85ce9400a7a840dc01ac8c46d88cdcc6ed15a28f662565b8ca9c1145b1
DIST jinja-3.0.3.tar.gz 273634 BLAKE2B 3f72840f3f895471896b918b0d3173aa7b40a077fe78a014064e66ac74c3d1ef1ae811723a84ea56d32edde23ee26ab6091bd5ce7ee4e46a9693f34d2538b491 SHA512 8a364620a4660add0593f4b252a2f20423aa3017193dffe6e8aa80710444da0cae5e6c4b77247d39f33e90185f475714fb892f6b5f01d3055a88b0f669a748be
52 changes: 52 additions & 0 deletions dev-python/jinja/jinja-3.0.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,52 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

PYTHON_COMPAT=( python3_{8..10} pypy3 )
PYTHON_REQ_USE="threads(+)"

inherit distutils-r1

DESCRIPTION="A full-featured template engine for Python"
HOMEPAGE="https://jinja.palletsprojects.com/ https://pypi.org/project/Jinja2/"
# pypi tarball is missing tests
SRC_URI="https://github.com/pallets/jinja/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris"
IUSE="examples"

RDEPEND="
>=dev-python/markupsafe-2.0.0[${PYTHON_USEDEP}]
!dev-python/jinja:compat"

distutils_enable_sphinx docs \
dev-python/sphinx-issues \
dev-python/pallets-sphinx-themes
distutils_enable_tests pytest

# XXX: handle Babel better?

src_prepare() {
# avoid unnecessary dep on extra sphinxcontrib modules
sed -i '/sphinxcontrib.log_cabinet/ d' docs/conf.py || die

distutils-r1_src_prepare
}

python_install_all() {
if use examples ; then
docinto examples
dodoc -r examples/.
fi

distutils-r1_python_install_all
}

pkg_postinst() {
if ! has_version dev-python/Babel; then
elog "For i18n support, please emerge dev-python/Babel."
fi
}

0 comments on commit a82776c

Please sign in to comment.