forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
media-plugins/gst-plugins-dash: bump to 1.12.4 for upstream bug fixes
Package-Manager: Portage-2.3.19, Repoman-2.3.6
- Loading branch information
Showing
2 changed files
with
35 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST gst-plugins-bad-1.12.3.tar.xz 4707000 BLAKE2B 1cb82e6f1c20d24a42ed0c7465e4dd8815627b0e716fe9be5d005ddd609c92a08619214a6b15059e7f537dadbc36c34d4c6ebfde1284c6a6029d2edf89bf9fa2 SHA512 6df47381de3a2f4286d047c1e7de2c76dd4312c9806636e2012717282cde0f3e5b2d0ffa910c564c8e122b19363e842b663cce1eda7ae95a05d63d1dbbd52661 | ||
DIST gst-plugins-bad-1.12.4.tar.xz 4709272 BLAKE2B a4d1fec48fdd67fc66eb5588dbee820c22b19a41dda4f5643b1ae326bfc827cd4796fc7a523fb0a9758605952377a2491f4e53ea74237ca7841659dea4ddcbc0 SHA512 a8e281aee1f1d0bb3f171fbe4242e997c661cbfd0be78da3913c0f55d68d6b7c3d34cabfcdd8c25728217ff885b86a7bedc0be34a7b14e2eb2a6c6236753231b |
34 changes: 34 additions & 0 deletions
34
media-plugins/gst-plugins-dash/gst-plugins-dash-1.12.4.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,34 @@ | ||
# Copyright 1999-2018 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
GST_ORG_MODULE=gst-plugins-bad | ||
|
||
inherit gstreamer | ||
|
||
DESCRIPTION="MPEG-DASH plugin for GStreamer" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="" | ||
|
||
RDEPEND=">=dev-libs/libxml2-2.9.1-r4[${MULTILIB_USEDEP}]" | ||
DEPEND="${RDEPEND}" | ||
|
||
src_prepare() { | ||
default | ||
|
||
# FIXME: gsturidownloader does not have a .pc | ||
# gstreamer_system_link \ | ||
# gst-libs/gst/uridownloader:gsturidownloader \ | ||
# gst-libs/gst/adaptativedemux:gstadaptivedemux | ||
|
||
local directory libs | ||
directory="gst-libs/gst/uridownloader" | ||
libs="-lgobject-2.0 -lglib-2.0 -lgstreamer-1.0 -lgstbase-1.0 -lgsturidownloader-1.0" | ||
sed -e "s:\$(top_builddir)/${directory}/.*\.la:${libs}:" \ | ||
-i ext/dash/Makefile.{am,in} || die | ||
|
||
directory="gst-libs/gst/adaptivedemux" | ||
libs="-lgobject-2.0 -lglib-2.0 -lgstreamer-1.0 -lgstbase-1.0 -lgstapp-1.0 -lgsturidownloader-1.0 -lgstadaptivedemux-1.0" | ||
sed -e "s:\$(top_builddir)/${directory}/.*\.la:${libs}:" \ | ||
-i ext/dash/Makefile.{am,in} || die | ||
} |