Skip to content

Commit

Permalink
dev-python/uncompyle6: New package, new dep for dev-python/hypothesis…
Browse files Browse the repository at this point in the history
…-3.5.*

Package-Manager: portage-2.3.1_p8
  • Loading branch information
dol-sen committed Oct 7, 2016
1 parent a4d38d7 commit a8642c7
Show file tree
Hide file tree
Showing 3 changed files with 59 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/uncompyle6/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST uncompyle6-2.8.3.tar.gz 504536 SHA256 213a5742d89d528e539121ab68b8d897a9fc60997ec30f6ec0764b6ca2d4a543 SHA512 635983a945a05f649d0f78191c59f6d1f0a7c922ad3bc8fc53396514a4cd133cdef228bac3189cd04d0c2104fb5da128f0ad8f868f6cfdd0bf3a0d52e08e773d WHIRLPOOL 93b1085e1b92e6dbfad39f27094636303d022298ee17460ea0f95d3338c6f0f1c03c6a0584d4805375c491e21fa7ca8e8b709532e6d9d1973d9a0b323734441b
20 changes: 20 additions & 0 deletions dev-python/uncompyle6/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,20 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>[email protected]</email>
<description>Primary maintainer</description>
</maintainer>
<maintainer type="project">
<email>[email protected]</email>
<name>Python</name>
</maintainer>
<upstream>
<maintainer>
<email>[email protected]</email>
<name>Rocky Bernstein</name>
</maintainer>
<remote-id type="pypi">PyQRCode</remote-id>
</upstream>
<longdescription></longdescription>
</pkgmetadata>
38 changes: 38 additions & 0 deletions dev-python/uncompyle6/uncompyle6-2.8.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,38 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6
PYTHON_COMPAT=( python2_7 python3_{4,5} pypy )

inherit distutils-r1

DESCRIPTION="Python cross-version byte-code deparser"
HOMEPAGE="https://github.com/rocky/python-uncompyle6/ https://pypi.python.org/pypi/umcompyle6"
SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"

RDEPEND=">=dev-python/xdis-2.3.0
>=dev-python/spark-parser-1.4.0"
DEPEND="${RDEPEND}
test? (
dev-python/mock[${PYTHON_USEDEP}]
dev-python/pytest[${PYTHON_USEDEP}]
dev-python/hypothesis[${PYTHON_USEDEP}]
)
"

# Tests are somewhat sketchy...
# the main repo has makefiles and commands that don't reflect the actual
# available options for the commands they are giving.
# This test does not produce errors, but also does not seem to update the
# files ok, failed,... just the # of files tested
python_test() {
PYTHONPATH="${S}/test:${BUILD_DIR}/lib" \
${EPYTHON} test/test_pyenvlib.py --verify --all || die \
"Tests failed under ${EPYTHON}"
}

0 comments on commit a8642c7

Please sign in to comment.