Skip to content

Commit

Permalink
dev-libs/leatherman: bup
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.28
  • Loading branch information
prometheanfire committed Sep 15, 2016
1 parent d06b856 commit a8e9e2e
Show file tree
Hide file tree
Showing 2 changed files with 52 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-libs/leatherman/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -7,3 +7,4 @@ DIST leatherman-0.7.4.tar.gz 389081 SHA256 96f3791ffc4f0ce780bd533b69739420b470e
DIST leatherman-0.7.5.tar.gz 389795 SHA256 a54fd92a939fbf48d57d248010ed41cf373f826855222b30ec16289be586c1ac SHA512 70f6ad91647aaa049720af02110706ea7492bd00d2f742c203f7da22bb3928c677008e035144e3cbd9caa9e0ceec4abf89ce50567eaa9eaf4550908c5c8ba7da WHIRLPOOL 04d87ee2edcdb03938a26adebd2a37118370ab11b98ec6bea541c8df4d31c654a01579f81f164bedfea648210ef55bcfc6c1804bd4835f12308f9e262eb269fb
DIST leatherman-0.8.1.tar.gz 391075 SHA256 e5cd0b9893711495abfc004403e657c9a4f3ee46486c1fc7a60b4eb6787b3f49 SHA512 c10b0a8cee580cdd2c963dc21c445084eab5c70e5cb43d6550ac3b5681aa1edb772937a4fc7c0143b7523c0508056047b87d3c9b98bc4c9c5c59d8e63dcfc9e8 WHIRLPOOL 88bb92d59b86be1480a4f10559140cad66f8fa7c94d217fe527f7f27f53550df0f30bfb6f2d93512fa6e874a311da8990b44585982031bc69c49dacbe8583d1d
DIST leatherman-0.9.0.tar.gz 392308 SHA256 8d79a998caa47047bfc52093e6a50618458b5c0aa502a6cf61f9fb7a6451c3bb SHA512 25c5edd58abad4e20d36ec7badb94aacc0f9a9e44200e710dcb3da116685396bba5b12ae806f9865e48d5d50c43a31486d8aa39fd853551ccf2c3eaa28859c8d WHIRLPOOL 492ae8971368a8c7e3527a875c8cb4a46d5a767b80b45d32b33fa2f1c66a7d2ea4825c923a6993b1147ac8e68bb111c682ef5315c13a11a68bd583b3423e6656
DIST leatherman-0.9.1.tar.gz 417376 SHA256 dc436230edd65f5244a72d290c598a3889787c917c4aa1a10f4559149408de81 SHA512 93fcb374eeac37a1e1009def0b94de8e7017764db7d18967da0409c34397e32249894de13e23509ecb37907388d7019e08e021db1d6909b1e8fe8b7b6e535c28 WHIRLPOOL 4e2c89322d349780624dff0670e353b923c159df9db20cf20272a8d7e80a899b85f949c2bbfc05e7a587ff845a5a342fc690be5dd3457d185b2d6850bf97ac47
51 changes: 51 additions & 0 deletions dev-libs/leatherman/leatherman-0.9.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,51 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
USE_RUBY="ruby21 ruby22"

inherit cmake-utils multilib ruby-ng

DESCRIPTION="A C++ toolkit"
HOMEPAGE="https://github.com/puppetlabs/leatherman"
SRC_URI="https://downloads.puppetlabs.com/facter/${P}.tar.gz"
SRC_URI="https://github.com/puppetlabs/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
S="${S}/all/${P}"

LICENSE="Apache-2.0"
SLOT="0"
IUSE="debug test"
KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"

CDEPEND="
>=sys-devel/gcc-4.8:*
>=dev-libs/boost-1.54[nls]
net-misc/curl"

RDEPEND+=" ${CDEPEND}"
DEPEND+=" test? ( ${CDEPEND} )"

src_prepare() {
sed -i 's/\-Werror\ //g' "cmake/cflags.cmake" || die
}

src_configure() {
local mycmakeargs=(
-DCMAKE_VERBOSE_MAKEFILE=ON
-DCMAKE_BUILD_TYPE=None
-DCMAKE_INSTALL_PREFIX=/usr
-DCMAKE_INSTALL_SYSCONFDIR=/etc
-DCMAKE_INSTALL_LOCALSTATEDIR=/var
)
if use debug; then
mycmakeargs+=(
-DCMAKE_BUILD_TYPE=Debug
)
fi
cmake-utils_src_configure
}

src_install() {
cmake-utils_src_install
}

0 comments on commit a8e9e2e

Please sign in to comment.