forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-emulation/containerd: temporary 0.2.2 snapshot release
Package-Manager: portage-2.2.28
- Loading branch information
Showing
2 changed files
with
43 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST containerd-0.2.0.tar.gz 635248 SHA256 1462e0c233763800b91ac2a670d82994ba1988560928e153f751fb1c0a6608c0 SHA512 381c0a21733fb79e90364649b46cbdadbc32d07245bd7a320465f6619ee5895e9552b7cc4393cb8d409295a7b867b7e461c079715cf1938e6313d4b888d81518 WHIRLPOOL d4e70a8be832227be671c13b77242a790cdf8645ff294c31d72e8cf01de2b30b9d78c691a156624adb004de42af6f133cb88b46aff37a33bc94d72bf87a0ee8a | ||
DIST containerd-0.2.2.tar.gz 635882 SHA256 a21efc7ea4bb97306ae9807caadca6782358679f38d3afd606cb599b6853bc52 SHA512 db6111984ccce01e928d46f0a22aaeed8d0eb50c2578df4e0cd5f56f43f8bdea43aad3203c2afb743ccf82908bd5961792681eafe07818a4057ca5f5f31c5396 WHIRLPOOL ce80bf79970faeacc3329cb4e365973a88539508904003da3d0f32afce9966e89bdf13a8894657e1fd983392cf2ab88b053393cbbc2018f509d9cbc57ab835cc | ||
DIST containerd-0.2.2_p20160622.tar.gz 989827 SHA256 1bab9b392ae8905edae0e339d6cdff8a0cbad84f0c4803a21920851f27f4e125 SHA512 5463c96c297f01e8f1d7c418d7acee0c279614bcf38d949b1410decddae03b41ff50cb75ebac085bb50547f38bd8154a82c8d90d9b882a3640a7b3072f050a62 WHIRLPOOL 96bfee570a2e0757973ab4d24b2c28c394782062e8e82651f641614e7414f1501cfe10d7a17b73c5212d745794ee50ddd1b1250b2eb9ee9b3c5a59a854b1efb0 |
42 changes: 42 additions & 0 deletions
42
app-emulation/containerd/containerd-0.2.2_p20160622.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,42 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=6 | ||
EGO_PN="github.com/docker/${PN}" | ||
|
||
if [[ ${PV} == *9999 ]]; then | ||
inherit golang-vcs | ||
else | ||
EGIT_COMMIT=14e7949 | ||
SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz" | ||
KEYWORDS="~amd64" | ||
inherit golang-vcs-snapshot | ||
fi | ||
|
||
DESCRIPTION="A daemon to control runC" | ||
HOMEPAGE="https://containerd.tools" | ||
|
||
LICENSE="Apache-2.0" | ||
SLOT="0" | ||
IUSE="+seccomp" | ||
|
||
DEPEND="" | ||
RDEPEND=">=app-emulation/runc-1.0.0_rc1 | ||
seccomp? ( sys-libs/libseccomp )" | ||
|
||
S=${WORKDIR}/${P}/src/${EGO_PN} | ||
|
||
src_prepare() { | ||
eapply_user | ||
} | ||
|
||
src_compile() { | ||
local options=( $(usex seccomp "seccomp") ) | ||
export GOPATH="${WORKDIR}/${P}" # ${PWD}/vendor | ||
LDFLAGS= emake GIT_COMMIT="$EGIT_COMMIT" BUILDTAGS="${options[@]}" | ||
} | ||
|
||
src_install() { | ||
dobin bin/containerd* bin/ctr | ||
} |