Skip to content

Commit

Permalink
games-engines/scummvm: Bumped to version 1.9.0
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.3
  • Loading branch information
Lars Wendler committed Dec 9, 2016
1 parent 0654cf1 commit a95e810
Show file tree
Hide file tree
Showing 2 changed files with 104 additions and 0 deletions.
1 change: 1 addition & 0 deletions games-engines/scummvm/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST scummvm-1.7.0.tar.bz2 20018016 SHA256 d9ff0e8cf911afa466d5456d28fef692a17d47ddecfd428bf2fef591237c2e66 SHA512 0133feb2df58461fb0e42b1e84cfb309bd964dad239f7ca0c7529edd4f4716895a45491e31597ec6f6d17361b0ce8f73c317399db07a1249b2ab570e4829000e WHIRLPOOL 077eb74cf46dfb15eaa2d473b627d953bc8e13bd0ae87a4fdc16282e468cf237bd9173b761cc9f89b9d6a13ce76db40aa67d5092e2e77eba2a0c6dab097b0fb4
DIST scummvm-1.8.0.tar.xz 17385064 SHA256 a85c23a2b1fcb7586a7527ecdbdf6c899a45ecbdcba28b9322057dc27914daa8 SHA512 2fb25467854d6115cf09fd40536728e2c1943c16d8bcb29ebbc3c37fa5dc750a72258e0b0dac6244e5ddcc5f2dfc69af3d7fdff83c98a92a546f8669daa8da27 WHIRLPOOL 55202291d09c86b250dc0ee24fdd3b34dd54924c4b5bb9889d6f2ef84f06db3caebc6bb36a9c1a9ccddd93cfdfaf5feac4982b4b0dc74305819af75031a68524
DIST scummvm-1.8.1.tar.xz 17807468 SHA256 935f53d7e4c460fbc22c58fee5007d4858891e4961831f53f575a3594b7f612a SHA512 e67ee332668b14432dcd675051384bd4fee2c1a0ddf44f6f8aeaf889d5027a834187e2632d18959583fa258cf03f259a54fd2d88120fa62ef7496232b4e6bdb4 WHIRLPOOL 597e6f4f21c4b80720a86d1f55518ba834d814ea9b9de365e19bdd070b0c8a81ce451d63169597bd54eb6e86876b5506a9f361d8c649c689dce304597b9390af
DIST scummvm-1.9.0.tar.xz 22020384 SHA256 2417edcb1ad51ca05a817c58aeee610bc6db5442984e8cf28e8a5fd914e8ae05 SHA512 c81248e8474ad5b354a46741ab2e40b8ddfb99e196b0c837424e9ccced285d03d5f12fc41be57034be53bdb8254a61ca0c9d9cd9a2340875d32e1bffa31699c2 WHIRLPOOL b9b09c90aa70c4a0aec2eae9fafba96d6ae2db6d0780ef3fc8bcf2d3bccba59b1b347635f85df1ce98183580132e8b8a00e8443123d13e1f20686b0fc862e2c0
103 changes: 103 additions & 0 deletions games-engines/scummvm/scummvm-1.9.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,103 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6
inherit eutils flag-o-matic gnome2-utils toolchain-funcs

DESCRIPTION="Reimplementation of the SCUMM game engine used in Lucasarts adventures"
HOMEPAGE="http://scummvm.sourceforge.net/"
SRC_URI="http://scummvm.org/frs/scummvm/${PV}/${P}.tar.xz"

LICENSE="GPL-2+ LGPL-2.1 BSD GPL-3-with-font-exception"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
IUSE="aac alsa debug flac fluidsynth jpeg mpeg2 mp3 opengl png theora truetype unsupported vorbis zlib"
RESTRICT="test" # it only looks like there's a test there #77507

RDEPEND=">=media-libs/libsdl2-2.0.0[sound,joystick,video]
zlib? ( sys-libs/zlib )
jpeg? ( virtual/jpeg:0 )
png? ( media-libs/libpng:0 )
vorbis? ( media-libs/libogg media-libs/libvorbis )
theora? ( media-libs/libtheora )
aac? ( media-libs/faad2 )
alsa? ( media-libs/alsa-lib )
mp3? ( media-libs/libmad )
mpeg2? ( media-libs/libmpeg2 )
flac? ( media-libs/flac )
opengl? ( virtual/opengl )
truetype? ( media-libs/freetype:2 )
fluidsynth? ( media-sound/fluidsynth )"
DEPEND="${RDEPEND}
app-arch/xz-utils
x86? ( dev-lang/nasm )"

S=${WORKDIR}/${P/_/}

src_prepare() {
default

# -g isn't needed for nasm here
sed -i \
-e '/NASMFLAGS/ s/-g//' \
configure || die
sed -i \
-e '/INSTALL.*doc/d' \
-e '/INSTALL.*\/pixmaps/d' \
-e 's/-s //' \
ports.mk || die
}

src_configure() {
use x86 && append-ldflags -Wl,-z,noexecstack

# NOT AN AUTOCONF SCRIPT SO DONT CALL ECONF
SDL_CONFIG="sdl2-config" \
./configure \
--backend=sdl \
--host=${CHOST} \
--enable-verbose-build \
--prefix=/usr \
--libdir="/usr/$(get_libdir)" \
--opengl-mode=$(usex opengl auto none) \
$(use_enable aac faad) \
$(use_enable alsa) \
$(use_enable debug) \
$(use_enable !debug release-mode) \
$(use_enable flac) \
$(usex fluidsynth '' --disable-fluidsynth) \
$(use_enable jpeg) \
$(use_enable mp3 mad) \
$(use_enable mpeg2) \
$(use_enable png) \
$(use_enable theora theoradec) \
$(use_enable truetype freetype2) \
$(usex unsupported --enable-all-engines '') \
$(use_enable vorbis) \
$(use_enable zlib) \
$(use_enable x86 nasm) \
${myconf} ${EXTRA_ECONF} || die
}

src_compile() {
emake AR="$(tc-getAR) cru" RANLIB=$(tc-getRANLIB)
}

src_install() {
default
doicon -s scalable icons/scummvm.svg
make_desktop_entry scummvm ScummVM scummvm "Game;AdventureGame"
}

pkg_preinst() {
gnome2_icon_savelist
}

pkg_postinst() {
gnome2_icon_cache_update
}

pkg_postrm() {
gnome2_icon_cache_update
}

0 comments on commit a95e810

Please sign in to comment.