forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
virtualbox packages: Bump to version 5.0.20
Package-Manager: portage-2.2.28 Signed-off-by: Lars Wendler <[email protected]>
- Loading branch information
Lars Wendler
committed
May 1, 2016
1 parent
0d87ab8
commit a96264c
Showing
14 changed files
with
1,356 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
36 changes: 36 additions & 0 deletions
36
app-emulation/virtualbox-additions/virtualbox-additions-5.0.20.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,36 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=6 | ||
|
||
inherit eutils | ||
|
||
MY_PN=VBoxGuestAdditions | ||
MY_PV="${PV/beta/BETA}" | ||
MY_PV="${MY_PV/rc/RC}" | ||
MY_P=${MY_PN}_${MY_PV} | ||
|
||
DESCRIPTION="CD image containing guest additions for VirtualBox" | ||
HOMEPAGE="http://www.virtualbox.org/" | ||
SRC_URI="http://download.virtualbox.org/virtualbox/${MY_PV}/${MY_P}.iso" | ||
|
||
LICENSE="GPL-2+ LGPL-2.1+ MIT SGI-B-2.0 CDDL" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="" | ||
RESTRICT="mirror" | ||
|
||
RDEPEND="!app-emulation/virtualbox-bin | ||
!=app-emulation/virtualbox-9999" | ||
|
||
S="${WORKDIR}" | ||
|
||
src_unpack() { | ||
return 0 | ||
} | ||
|
||
src_install() { | ||
insinto /usr/share/${PN/-additions} | ||
newins "${DISTDIR}"/${MY_P}.iso ${MY_PN}.iso | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Oops, something went wrong.