Skip to content

Commit

Permalink
x11-libs/libdrm: Version bump to 2.4.62
Browse files Browse the repository at this point in the history
Signed-off-by: Matt Turner <[email protected]>
  • Loading branch information
mattst88 committed Oct 16, 2018
1 parent 06b5427 commit a9708a2
Show file tree
Hide file tree
Showing 2 changed files with 77 additions and 0 deletions.
1 change: 1 addition & 0 deletions x11-libs/libdrm/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST libdrm-2.4.93.tar.bz2 826579 BLAKE2B 6b2775a6bc631001be874d1337ef9607ee8ff5b86ce5e3d8ff6c6eb58182a30e2c70592cb4eb9e88c9e046d73b510f632272c57621706afd1db416acc6ce366c SHA512 ba4221e8d6a3a9872fb6d30a0ea391e30ea0e17f249c66f067bed9c2161ed1ad8083959cb2c212834c6566c3e025f4daae31e9533d77aae19bbbbb9de6c2ab3d
DIST libdrm-2.4.94.tar.bz2 829060 BLAKE2B 99de0fb3df6ea9bb5540cf0e3bdfe182c28db9876f679030eaaed1abd873bb818586bc07e73e0499f831ccaa7ede91a5b73b2b2bf681853e14e786a4af9abd98 SHA512 1a1699d6ea70b8759b37f3863e0802a99430b58f02e62632ad451356e2463eaf6faf4b810323f7dcc85ffdcca28f674b32caa5631ebd65b83e5b86bd59a35937
DIST libdrm-2.4.95.tar.bz2 820722 BLAKE2B ee12f1b9fabc0a00f5adba33fe17000d018cfd5d7fbb4e737bceadcd8e897b846fcccdc262582c4d37508738671a0fedc1a653976214327eb998dca7d5834e01 SHA512 9bf8178a871bb059471f58f236c8362245e08877b732b2c8366d402e8066c9a74707e4ec3bf680fca12303f1319875edc98ae8e31bc9826f172798f47197e631
DIST libdrm-2.4.96.tar.bz2 829518 BLAKE2B d9a21ce31af65812c1b23968ef6c1901aea106b4cc68d76d3641a17b98423024b804bfda509862174eba98271bd7156c7f08d81bc0a520ea4a25c8e2e0bfd598 SHA512 008cb7658d953b44e11fa3cc6e00dfeb3efb59c7fdadd59f7066101aff138acbbc2f2508e9ebe0528340e39dc7693937755d1641816ddde135c10a13e7d81e3b
76 changes: 76 additions & 0 deletions x11-libs/libdrm/libdrm-2.4.96.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,76 @@
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6

EGIT_REPO_URI="https://anongit.freedesktop.org/git/mesa/drm.git"

if [[ ${PV} = 9999* ]]; then
GIT_ECLASS="git-r3"
fi

inherit ${GIT_ECLASS} meson multilib-minimal

DESCRIPTION="X.Org libdrm library"
HOMEPAGE="https://dri.freedesktop.org/"
if [[ ${PV} = 9999* ]]; then
SRC_URI=""
else
SRC_URI="https://dri.freedesktop.org/libdrm/${P}.tar.bz2"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
fi

VIDEO_CARDS="amdgpu exynos freedreno intel nouveau omap radeon tegra vc4 vivante vmware"
for card in ${VIDEO_CARDS}; do
IUSE_VIDEO_CARDS+=" video_cards_${card}"
done

IUSE="${IUSE_VIDEO_CARDS} libkms valgrind"
RESTRICT="test" # see bug #236845
LICENSE="MIT"
SLOT="0"

RDEPEND="elibc_FreeBSD? ( >=dev-libs/libpthread-stubs-0.4:=[${MULTILIB_USEDEP}] )
video_cards_intel? ( >=x11-libs/libpciaccess-0.13.1-r1:=[${MULTILIB_USEDEP}] )"
DEPEND="${RDEPEND}
valgrind? ( dev-util/valgrind )"

src_unpack() {
default
[[ $PV = 9999* ]] && git-r3_src_unpack
}

multilib_src_configure() {
local emesonargs=(
# Udev is only used by tests now.
-Dudev=false
-Dcairo-tests=false
-Damdgpu=$(usex video_cards_amdgpu true false)
-Dexynos=$(usex video_cards_exynos true false)
-Dfreedreno=$(usex video_cards_freedreno true false)
-Dintel=$(usex video_cards_intel true false)
-Dnouveau=$(usex video_cards_nouveau true false)
-Domap=$(usex video_cards_omap true false)
-Dradeon=$(usex video_cards_radeon true false)
-Dtegra=$(usex video_cards_tegra true false)
-Dvc4=$(usex video_cards_vc4 true false)
-Detnaviv=$(usex video_cards_vivante true false)
-Dvmwgfx=$(usex video_cards_vmware true false)
-Dlibkms=$(usex libkms true false)
# valgrind installs its .pc file to the pkgconfig for the primary arch
-Dvalgrind=$(usex valgrind auto false)
)
meson_src_configure
}

multilib_src_compile() {
meson_src_compile
}

multilib_src_test() {
meson_src_test
}

multilib_src_install() {
meson_src_install
}

0 comments on commit a9708a2

Please sign in to comment.