Skip to content

Commit

Permalink
dev-scheme/c-wrapper: fix for >=sys-devel/gcc-5
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.40, Repoman-2.3.9
  • Loading branch information
hattya committed Jul 11, 2018
1 parent a87a1d3 commit a978300
Show file tree
Hide file tree
Showing 2 changed files with 46 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-scheme/c-wrapper/c-wrapper-0.6.1-r1.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -20,6 +20,7 @@ DEPEND="${RDEPEND}"

PATCHES=(
"${FILESDIR}"/${PN}-closure.patch
"${FILESDIR}"/${PN}-gcc-5.patch
"${FILESDIR}"/${PN}-gentoo.patch
)
HTML_DOCS=( doc/${PN}-ref{e,j}.html )
Expand Down
45 changes: 45 additions & 0 deletions dev-scheme/c-wrapper/files/c-wrapper-gcc-5.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,45 @@
--- a/src/c-parser.c
+++ b/src/c-parser.c
@@ -1668,6 +1668,7 @@
{
static ScmObj trigger_line = SCM_FALSE;
ScmObj line_str;
+ ScmObj regexp = Scm_RegComp(SCM_STRING(SCM_MAKE_STR_IMMUTABLE("^#\\s+\\d+\\s+\"<stdin>\"")), 0);

/* skip the first line '# 1 "<stdin>"' */
Scm_ReadLineUnsafe(SCM_PORT(in));
@@ -1682,16 +1683,26 @@
}
}

- while (!SCM_EOFP(line_str = Scm_ReadLineUnsafe(SCM_PORT(in)))) {
- if (SCM_NULLP(macro_list)) {
+ line_str = SCM_NIL;
+ while (!SCM_NULLP(macro_list)) {
+ ScmObj body_str = line_str;
+ if (SCM_NULLP(body_str)
+ && SCM_EOFP(body_str = Scm_ReadLineUnsafe(SCM_PORT(in)))) {
Scm_Error("[bug] lost macro body");
- } else {
- ScmObj pos_name_args = SCM_CDAR(macro_list);
- macro_list = SCM_CDR(macro_list);
- Scm_FilenameSet(SCM_CAAR(pos_name_args));
- Scm_LineNumberSet(SCM_INT_VALUE(SCM_CDAR(pos_name_args)));
- parse_macro_body(SCM_CADR(pos_name_args), SCM_CDDR(pos_name_args), line_str);
}
+ while (!SCM_EOFP(line_str = Scm_ReadLineUnsafe(SCM_PORT(in)))
+ && SCM_REGMATCHP(Scm_RegExec(SCM_REGEXP(regexp), SCM_STRING(line_str)))) {
+ if (SCM_EOFP(line_str = Scm_ReadLineUnsafe(SCM_PORT(in)))) {
+ Scm_Error("[bug] unexpected EOF while parsing macro body");
+ }
+ body_str = Scm_StringAppend2(SCM_STRING(body_str), SCM_STRING(line_str));
+ line_str = SCM_NIL;
+ }
+ ScmObj pos_name_args = SCM_CDAR(macro_list);
+ macro_list = SCM_CDR(macro_list);
+ Scm_FilenameSet(SCM_CAAR(pos_name_args));
+ Scm_LineNumberSet(SCM_INT_VALUE(SCM_CDAR(pos_name_args)));
+ parse_macro_body(SCM_CADR(pos_name_args), SCM_CDDR(pos_name_args), body_str);
}

SCM_RETURN(SCM_UNDEFINED);

0 comments on commit a978300

Please sign in to comment.