Skip to content

Commit

Permalink
dev-util/lcov: add 1.15
Browse files Browse the repository at this point in the history
Signed-off-by: Nick Herman <[email protected]>
Closes: gentoo#17284
Signed-off-by: Joonas Niilola <[email protected]>
  • Loading branch information
gekola authored and juippis committed Sep 29, 2020
1 parent 60fb093 commit a9a2d89
Show file tree
Hide file tree
Showing 2 changed files with 42 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-util/lcov/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST lcov-1.13.tar.gz 156709 BLAKE2B d0f2635a6e6c29d29bd15d15c7f6c22ff80052b12deb4e88c77a9331d6d151aa2718ad4e4af1aa192757c1fc3189cc0d1688fc5086e5552c74078206cf27e1df SHA512 54033c0f99dbf7b332fcd70730df8672713ffc36c010809353dfd83a73fcc4f504b6a68e3b5010002d6992da5fa940a7d5f4e03dc3fe6930ab713a7b980dff9e
DIST lcov-1.14.tar.gz 177359 BLAKE2B 17069d38bf607217b8ff59f573fc02badf56afe65965d2a359a14835af57e2b6c512bff06fac3dbf4e94cd35701216edb8026d333b2baa8772d0ef551de37af1 SHA512 2d60c3a63e300dda96171c432fe304840acc76bf6275f60934d08e80765f9f85671e8b77bfed758fc45842a80156586dc0d67c42c9f215f4f163840fc5cf65bc
DIST lcov-1.15.tar.gz 190487 BLAKE2B 2d6478caae488b84c74a3f7b489013b065b3e8fb106a6e8c5f413ffe87be7f4530aade8d2b5df5b8193949d60f49d5255b4eddb0cd5f1cab6f450ba2f97426ab SHA512 dda0eadbd0ea2093f17cba039309ccda3dbcb7266d083b46bda61e02cd7f049d66de49be1e005157c3e5af910d2703ffbc9cfe7f1242bd67b9787f8508e4d052
DIST lcov_1.14-2.debian.tar.xz 25740 BLAKE2B ca1a84ed98e0cdd13aae88f0f550cac84f00b3dbf6bd764abe0c7eee7b73c0796abbf20e76cb51707d0d644bb17ee7ad283abbfaa7456dc2a3ade5e12cfbaabc SHA512 10fdb1f82be8cc9aef3b92aa7ca18f2736e5130d8b6ef9703b9444cb88f75f475e8bc48c441ed5cf7e4d11f383c226fc711e8609ea11772b01f454bb6a5bd45a
41 changes: 41 additions & 0 deletions dev-util/lcov/lcov-1.15.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,41 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/linux-test-project/lcov.git"
inherit git-r3
else
SRC_URI="https://github.com/linux-test-project/lcov/releases/download/v${PV}/${P}.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x86-linux ~x64-macos"
fi

inherit prefix

DESCRIPTION="A graphical front-end for GCC's coverage testing tool gcov"
HOMEPAGE="http://ltp.sourceforge.net/coverage/lcov.php"

LICENSE="GPL-2+"
SLOT="0"
IUSE="png"

RDEPEND="
dev-lang/perl
dev-perl/JSON
dev-perl/PerlIO-gzip
png? ( dev-perl/GD[png] )
"

src_prepare() {
default
if use prefix; then
hprefixify bin/*.{pl,sh}
fi
}

src_compile() { :; }

src_install() {
emake PREFIX="${ED}/usr" CFG_DIR="${ED}/etc" install
}

0 comments on commit a9a2d89

Please sign in to comment.