Skip to content

Commit

Permalink
dev-python/setuptools: Bump to 49.3.2
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Aug 13, 2020
1 parent 095c251 commit a9b96af
Show file tree
Hide file tree
Showing 2 changed files with 72 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/setuptools/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -5,3 +5,4 @@ DIST setuptools-49.2.0.zip 2174648 BLAKE2B 03d4d2f4df5e20a39bdf8940610e0e0ad0256
DIST setuptools-49.2.1.zip 2173295 BLAKE2B c80cb7bc0e278e38cdaa87f32684476f1e72b69171213ef6019631011d735de62149635471a87791ffb665afdef0a3b70b57b4275cc4ff6bff8cc3c488229931 SHA512 daa4096d079eef9b234c854ae404a2b0f6f3034008f4c3119b0412adc1cbbbff936c518c8e3aeadaed67426ad83bb651681d63352520910833c5b919147f0fb6
DIST setuptools-49.3.0.zip 2175616 BLAKE2B bc46992660adbf5aeafa0c3e93c9fa598c6ec61ed379fe07f97d43b77274ce27829bfaac6e706cb943e5e7a5a8e5e2b09551178c04e20af86fa8732d809753be SHA512 954b192b1d3a9deb8b8c9fb7d834d139a630d1951585f7ce9747c65b191c0bbd4747c8840b6297eb20a3755207333e9d921bca5b303ed8de757ddd28fd0b5e07
DIST setuptools-49.3.1.zip 2175721 BLAKE2B 825fd23e504f2fc4d70c55435862e1080b20ea8d1d279b0d8934c12b9d793665161c07a43770fa2ad92dec7d405b04091d752f09bc2416e7239425dfc2f7e666 SHA512 57c3e31540b89c1356cc23a59c2c158b44a55a45ebc9c087a3a977af59ea387bb38baf54fd3b14ea23033715870a86b965c1828203f3df8b6cdad19fb4ea9249
DIST setuptools-49.3.2.zip 2175821 BLAKE2B d7160869528bc50085646b7c27e153e406ee0d98e2e5bba1241ea8ca6e07248651b5d54ee2e5cf040858533c1fec6f4b6ffb77ad3f130fd12611ce6280c9adbb SHA512 4474b23a4f62fe5ac9f0b66a639be02da84c8abf22ad86f6436c02c82019f89a2ca14e8f8cbe9dd0932cfb32287a196d0a4735d709b301764bdb8b3d9da42c45
71 changes: 71 additions & 0 deletions dev-python/setuptools/setuptools-49.3.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,71 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
DISTUTILS_USE_SETUPTOOLS=no
PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
PYTHON_REQ_USE="xml(+)"

inherit distutils-r1

DESCRIPTION="Collection of extensions to Distutils"
HOMEPAGE="https://github.com/pypa/setuptools https://pypi.org/project/setuptools/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="test"
RESTRICT="!test? ( test )"

BDEPEND="
app-arch/unzip
test? (
dev-python/jaraco-envs[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
dev-python/pip[${PYTHON_USEDEP}]
>=dev-python/pytest-3.7.0[${PYTHON_USEDEP}]
dev-python/pytest-fixture-config[${PYTHON_USEDEP}]
dev-python/pytest-virtualenv[${PYTHON_USEDEP}]
dev-python/wheel[${PYTHON_USEDEP}]
)
"
PDEPEND="
>=dev-python/certifi-2016.9.26[${PYTHON_USEDEP}]"

# Force in-source build because build system modifies sources.
DISTUTILS_IN_SOURCE_BUILD=1

DOCS=( {CHANGES,README}.rst docs/{easy_install.txt,pkg_resources.txt,setuptools.txt} )

python_prepare_all() {
# disable tests requiring a network connection
rm setuptools/tests/test_packageindex.py || die

# don't run integration tests
rm setuptools/tests/test_integration.py || die

# xpass-es for me on py3
#sed -e '/xfail.*710/s:(:(six.PY2, :' \
# -i setuptools/tests/test_archive_util.py || die

# avoid pointless dep on flake8
sed -i -e 's:--flake8::' -e 's:--cov::' pytest.ini || die

# disable the code disabling non-existing coverage plugin
sed -i -e 's:cov = .*:return:' conftest.py || die

distutils-r1_python_prepare_all
}

python_test() {
distutils_install_for_testing
# test_easy_install raises a SandboxViolation due to ${HOME}/.pydistutils.cfg
# It tries to sandbox the test in a tempdir
HOME="${PWD}" pytest -vv ${PN} || die "Tests failed under ${EPYTHON}"
}

python_install() {
export DISTRIBUTE_DISABLE_VERSIONED_EASY_INSTALL_SCRIPT=1
distutils-r1_python_install
}

0 comments on commit a9b96af

Please sign in to comment.