forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Signed-off-by: Pascal Jäger <[email protected]> Closes: gentoo#32456 Signed-off-by: Arthur Zamarin <[email protected]>
- Loading branch information
Showing
2 changed files
with
48 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST boxes-2.2.0.tar.gz 230099 BLAKE2B 4adb8ddde85cb31f32e98916d5ea2a57afcaa0470f796ba296cb3b80780f158a24b2bc5e9ba923b6a3b35b8f7781cd6ddacd89abadf6f2c07549be7ffe1458f4 SHA512 534d441c34316572d0c7e89f343a3bc5bb5a8466e4d4ed703fb2d14b714f5a6b224f7b0d408525d492da4610f9c5ffd8508e16d98a0781897567fb4aeb316f39 | ||
DIST boxes-2.2.1.tar.gz 230900 BLAKE2B 65ab0c8ad52d2764279397135b072bfa6f4bf86e465cc3a4778d30c5b19ce2c0d7c5f8636173529eca92754ee16d38b46a83b067b94315b1ea82448e4b1ac0a8 SHA512 0afa115d5ec01944878ef4d8f33e2887d123b172a0589eda53a04ba671916d9ef1d8299f9df9aeac8989807f86ca1b96b1c34aed03856643a89a07586b82e3b6 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,47 @@ | ||
# Copyright 1999-2023 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=8 | ||
|
||
inherit toolchain-funcs | ||
|
||
DESCRIPTION="Draw any kind of boxes around your text" | ||
HOMEPAGE="https://boxes.thomasjensen.com/ https://github.com/ascii-boxes/boxes" | ||
SRC_URI="https://github.com/ascii-boxes/boxes/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz" | ||
|
||
LICENSE="GPL-3" | ||
SLOT="0" | ||
KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86" | ||
IUSE="test" | ||
RESTRICT="!test? ( test )" | ||
|
||
RDEPEND=" | ||
dev-libs/libpcre2[pcre32] | ||
dev-libs/libunistring:= | ||
" | ||
DEPEND="${RDEPEND}" | ||
BDEPEND=" | ||
sys-devel/bison | ||
sys-devel/flex | ||
test? ( app-editors/vim-core ) | ||
" | ||
|
||
src_prepare() { | ||
default | ||
|
||
sed \ | ||
-e 's:STRIP=true:STRIP=false:g' \ | ||
-i src/Makefile || die | ||
} | ||
|
||
src_compile() { | ||
emake CC="$(tc-getCC)" CFLAGS_ADDTL="${CFLAGS}" LDFLAGS_ADDTL="${LDFLAGS}" | ||
} | ||
|
||
src_install() { | ||
dobin out/boxes | ||
doman doc/boxes.1 | ||
insinto /usr/share | ||
newins boxes-config boxes | ||
einstalldocs | ||
} |