Skip to content

Commit

Permalink
dev-perl/Search-Xapian: use g++ as CC
Browse files Browse the repository at this point in the history
This is an ugly hack to work around a bug.

Closes: https://bugs.gentoo.org/931999
Signed-off-by: Jason A. Donenfeld <[email protected]>
  • Loading branch information
zx2c4 committed Jun 18, 2024
1 parent 2b8e21b commit aa0196a
Showing 1 changed file with 38 additions and 0 deletions.
38 changes: 38 additions & 0 deletions dev-perl/Search-Xapian/Search-Xapian-1.2.25.5-r4.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,38 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

DIST_AUTHOR=OLLY
inherit perl-module toolchain-funcs

DESCRIPTION="Perl XS frontend to the Xapian C++ search library"

SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
IUSE="examples test"
RESTRICT="!test? ( test )"

RDEPEND=">=dev-libs/xapian-1.4:0=[inmemory(+)]
!dev-libs/xapian-bindings[perl]"
DEPEND="${RDEPEND}
virtual/perl-ExtUtils-MakeMaker
test? ( dev-perl/Devel-Leak )
"

DIST_TEST=do
# parallel fails sometimes...

src_configure() {
myconf="CXX=$(tc-getCXX) CXXFLAGS=${CXXFLAGS} CC=$(tc-getCXX)"
perl-module_src_configure
}

src_install() {
perl-module_src_install

use examples && {
docinto examples
dodoc "${S}"/examples/*
}
}

0 comments on commit aa0196a

Please sign in to comment.