Skip to content

Commit

Permalink
dev-python/jaraco-itertools: bump to 1.8, add doc
Browse files Browse the repository at this point in the history
Also bump to EAPI=6 and remove a now useless check before running tests.

Package-Manager: portage-2.3.0
  • Loading branch information
sbraz authored and gktrk committed Sep 3, 2016
1 parent 5df1a7c commit aa25097
Show file tree
Hide file tree
Showing 3 changed files with 55 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/jaraco-itertools/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST jaraco.itertools-1.7.1.tar.gz 10224 SHA256 bf5c7bf22c930a0c5942e0850166b10c77bbb6286117ac2c619c78c86db97d7b SHA512 e149de3368137db4379d02858be0cbb3b6dc1e81cc06eb0f53064a55c8e25fb09b2b4387035dda29928bdf54e22d28c9d9744dfbd82a6cf4e4c90b5d42b31dfb WHIRLPOOL 7377baca4411fe8acaccf4cca763d5c47aebd62acb51e4380e0565c4b72785d439e8cee51887aa4ccde9fd0bf90ab4d824cb6878b4b7436552d120d8f5e5ea50
DIST jaraco.itertools-1.8.tar.gz 11416 SHA256 d9eb457c0ce1ae3fa5ad3cdbdb0d43d8332ec4c2323d9595629a844d9c1be812 SHA512 fd07f5120863ffffc03b248d4de9fcb206d4638cbdc6e85fb0944500918793b1314ab80a0a5400e6095739d220dd3edc55fa43b74f441c764022362ae5801732 WHIRLPOOL db3ccd96d9e89a272487b8a3ca8eb900282070122d14746aff5f268e37fa5e815d7fd6473101a421f9d7245bcd25ad1d07f25e5b0d153828ce30ad6895f21887
53 changes: 53 additions & 0 deletions dev-python/jaraco-itertools/jaraco-itertools-1.8.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,53 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

PYTHON_COMPAT=( python{2_7,3_4,3_5} )

inherit distutils-r1

MY_PN="${PN/-/.}"
DESCRIPTION="Additional functions used by other projects by developer jaraco"
HOMEPAGE="https://github.com/jaraco/jaraco.itertools"
SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc test"

RDEPEND="
dev-python/six[${PYTHON_USEDEP}]
dev-python/inflect[${PYTHON_USEDEP}]
dev-python/more-itertools[${PYTHON_USEDEP}]
"
DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
>=dev-python/setuptools_scm-1.9[${PYTHON_USEDEP}]
doc? (
dev-python/sphinx[${PYTHON_USEDEP}]
dev-python/rst-linker[${PYTHON_USEDEP}]
)
test? (
${RDEPEND}
>=dev-python/pytest-2.8[${PYTHON_USEDEP}]
dev-python/pytest-runner[${PYTHON_USEDEP}]
)
"

S="${WORKDIR}/${MY_PN}-${PV}"

python_compile_all() {
use doc && esetup.py build_sphinx
}

python_test() {
PYTHONPATH=. py.test || die "tests failed with ${EPYTHON}"
}

python_install_all() {
use doc && local HTML_DOCS=( "${BUILD_DIR}"/sphinx/html/. )
distutils-r1_python_install_all
}
1 change: 1 addition & 0 deletions dev-python/jaraco-itertools/metadata.xml
Original file line number Diff line number Diff line change
Expand Up @@ -13,5 +13,6 @@
<upstream>
<remote-id type="pypi">jaraco.itertools</remote-id>
<remote-id type="github">jaraco/jaraco.itertools</remote-id>
<bugs-to>https://github.com/jaraco/jaraco.itertools/issues</bugs-to>
</upstream>
</pkgmetadata>

0 comments on commit aa25097

Please sign in to comment.