Skip to content

Commit

Permalink
www-plugins/lightspark: add upstream patch to fix ffmpeg-free build
Browse files Browse the repository at this point in the history
Bug: https://bugs.gentoo.org/show_bug.cgi?id=607492

Package-Manager: Portage-2.3.6, Repoman-2.3.1
  • Loading branch information
chithanh committed Jul 20, 2017
1 parent 6088ec1 commit aa27638
Show file tree
Hide file tree
Showing 2 changed files with 33 additions and 0 deletions.
31 changes: 31 additions & 0 deletions www-plugins/lightspark/files/lightspark-0.8.0-ffmpeg-free.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,31 @@
From 22a85a13a5c3ded942ef59522ad399eb5d9a58d9 Mon Sep 17 00:00:00 2001
From: Mikhail Vorobyov <[email protected]>
Date: Tue, 18 Jul 2017 23:46:37 +0300
Subject: [PATCH] Add NullVideoDecoder::switchCodec

Add VideoDecoder::switchCodec implementation to NullVideoDecoder to fix
ffmpeg-free build.
---
src/backends/decoder.h | 2 ++
1 file changed, 2 insertions(+)

diff --git a/src/backends/decoder.h b/src/backends/decoder.h
index 069543d0..f53288bd 100644
--- a/src/backends/decoder.h
+++ b/src/backends/decoder.h
@@ -140,6 +140,7 @@ class NullVideoDecoder: public VideoDecoder
public:
NullVideoDecoder() {status=VALID;}
~NullVideoDecoder() { while(fenceCount); }
+ void switchCodec(LS_VIDEO_CODEC codecId, uint8_t* initdata, uint32_t datalen, double frameRateHint){};
bool decodeData(uint8_t* data, uint32_t datalen, uint32_t time){return false;}
bool discardFrame(){return false;}
void skipUntil(uint32_t time){}
@@ -305,6 +306,7 @@ class NullAudioDecoder: public AudioDecoder
sampleRate=44100;
channelCount=2;
}
+ void switchCodec(LS_AUDIO_CODEC codecId, uint8_t* initdata, uint32_t datalen){};
uint32_t decodeData(uint8_t* data, int32_t datalen, uint32_t time){return 0;}
};

2 changes: 2 additions & 0 deletions www-plugins/lightspark/lightspark-0.8.0.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -51,6 +51,8 @@ DEPEND="${RDEPEND}

S=${WORKDIR}/${P/_rc*/}

PATCHES=( "${FILESDIR}"/${P}-ffmpeg-free.patch )

pkg_pretend() {
if [[ ${MERGE_TYPE} != binary ]]; then
if tc-is-gcc && [[ $(gcc-major-version) == 4 && $(gcc-minor-version) -lt 6 || $(gcc-major-version) -lt 4 ]] ; then
Expand Down

0 comments on commit aa27638

Please sign in to comment.