Skip to content

Commit

Permalink
dev-libs/icu-layoutex: Bump to version 67.1
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Lars Wendler <[email protected]>
  • Loading branch information
Lars Wendler committed Apr 29, 2020
1 parent 26c7072 commit aa51f1e
Show file tree
Hide file tree
Showing 2 changed files with 110 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-libs/icu-layoutex/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST icu4c-65_1-src.tgz 24267934 BLAKE2B 3c62781201c02a2b1027c9b6db4586f8ccdfb339c0765301a381242d5218f3503a1cdbdc1dc9a1a23ffa657096adc4bf7f0b7fe702461f14beba293a7e82e02c SHA512 8f1ef33e1f4abc9a8ee870331c59f01b473d6da1251a19ce403f822f3e3871096f0791855d39c8f20c612fc49cda2c62c06864aa32ddab2dbd186d2b21ce9139
DIST icu4c-66_1-src.tgz 24361305 BLAKE2B db26e9380305601f8429366e2813ce3ccae11f34adde513d72a1ae09281a2078ce5eb7410bc788c717167018b4c2042fc83217fac22f34e26b94ee4621a6b4ec SHA512 78d87bce65a7bdf7e9a19bda13e353c60846816ff34025f829d1ff15f9ac49aa6061eb192173742be0eca105684ce0e39e95656147afe848520bf60274c8d246
DIST icu4c-67_1-src.tgz 24518055 BLAKE2B f8a263b5c3e5e8ffea88a3bb766cb265aac026b5f9b2f45a1f06076f99f9f0dc3a4512487652d774ccfc8dc65f8f4c40a974e0aa2aa4381ee0c9885f6b871779 SHA512 4779f1ce1ca7976f6fad6768853ea8c540da54d11509e3b6cfd864a04b5f2db1c3d4b546387f91ad02fb90804525bc37d2543173f0d705d6ca11dc6f2b7640a8
109 changes: 109 additions & 0 deletions dev-libs/icu-layoutex/icu-layoutex-67.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,109 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit autotools flag-o-matic multilib-minimal toolchain-funcs

DESCRIPTION="External layout part of International Components for Unicode"
HOMEPAGE="http://www.icu-project.org/"
SRC_URI="https://github.com/unicode-org/icu/releases/download/release-${PV//./-}/icu4c-${PV//./_}-src.tgz"

LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
IUSE="debug static-libs"

BDEPEND="
virtual/pkgconfig[${MULTILIB_USEDEP}]
"
DEPEND="
~dev-libs/icu-${PV}[${MULTILIB_USEDEP}]
dev-libs/icu-le-hb[${MULTILIB_USEDEP}]
"
RDEPEND="${DEPEND}"

S="${WORKDIR}/${PN/-layoutex}/source"

PATCHES=(
"${FILESDIR}/${PN}-65.1-remove-bashisms.patch"
)

src_prepare() {
# apply patches
default

# Disable renaming as it is stupid thing to do
sed -i \
-e "s/#define U_DISABLE_RENAMING 0/#define U_DISABLE_RENAMING 1/" \
common/unicode/uconfig.h || die

# Fix linking of icudata
sed -i \
-e "s:LDFLAGSICUDT=-nodefaultlibs -nostdlib:LDFLAGSICUDT=:" \
config/mh-linux || die

eautoreconf
}

src_configure() {
# Use C++14
append-cxxflags -std=c++14

if tc-is-cross-compiler; then
mkdir "${WORKDIR}"/host || die
pushd "${WORKDIR}"/host >/dev/null || die

CFLAGS="" CXXFLAGS="" ASFLAGS="" LDFLAGS="" \
CC="$(tc-getBUILD_CC)" CXX="$(tc-getBUILD_CXX)" AR="$(tc-getBUILD_AR)" \
RANLIB="$(tc-getBUILD_RANLIB)" LD="$(tc-getBUILD_LD)" \
"${S}"/configure --disable-renaming --disable-debug \
--disable-samples --enable-static || die
emake

popd >/dev/null || die
fi

multilib-minimal_src_configure
}

multilib_src_configure() {
local myeconfargs=(
--disable-renaming
--disable-samples
--enable-layoutex
$(use_enable debug)
$(use_enable static-libs static)
)

tc-is-cross-compiler && myeconfargs+=(
--with-cross-build="${WORKDIR}"/host
)

# icu tries to use clang by default
tc-export CC CXX

ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
}

multilib_src_test() {
# INTLTEST_OPTS: intltest options
# -e: Exhaustive testing
# -l: Reporting of memory leaks
# -v: Increased verbosity
# IOTEST_OPTS: iotest options
# -e: Exhaustive testing
# -v: Increased verbosity
# CINTLTST_OPTS: cintltst options
# -e: Exhaustive testing
# -v: Increased verbosity
pushd layoutex &>/dev/null || die
emake -j1 VERBOSE="1" check
popd &>/dev/null || die
}

multilib_src_install() {
pushd layoutex &>/dev/null || die
default
popd &>/dev/null || die
}

0 comments on commit aa51f1e

Please sign in to comment.