forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
gnome-extra/gnome-shell-extensions: Version bump
Package-Manager: portage-2.2.24
- Loading branch information
Showing
2 changed files
with
80 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST gnome-shell-extensions-3.14.4.tar.xz 229176 SHA256 05a1d5ecf3ebbf8215b46d91da25f9f6e66e917e79a59d609dd8b65cadf976e0 SHA512 17d041571eaa4717e301ea2c08d54ef7316ed11894d7c93b77314d08cb804665419c40a1225f3f0beb7286bac53f2c4831c3e3d924c8bac0c46e69b2d14749b5 WHIRLPOOL f51ec9bdc8b90f420808f94aea2219c3ae640a0c9f59c4b766e7a305e6f03aa81ebe088071d70f88458dce16f79e9cbbf0924223a773d2174d0c9c08aab52de6 | ||
DIST gnome-shell-extensions-3.16.1.tar.xz 229704 SHA256 88cd3d2df1f0419066a7f01f28ee4fc8f8c4b361dbf44a93067166c8a796a741 SHA512 86e5394cece75f5feb5c79346957f728d107c6c5c3472c7b3c4b34c533a98f981fcc47f10b9b2565c529ef70da83e749287de5940bc8b020148d18c31343813f WHIRLPOOL d739de0750b8ecb4ed3c00f4635864118664e7838da669338f773b29aba069f9782a6dffb734602644906cab41fe6691c50b624257ec0f99c4ee03973a989a5e | ||
DIST gnome-shell-extensions-3.16.2.tar.xz 231292 SHA256 0dca1677ec9401dd7c1a7261164b7f4cc94d52207637cf9e8e350bb9f6d0e9bf SHA512 f7f2bd9fe0ea2e9e14b7163c30fcf2cd93698f43de6ebc4daf3a655293db438c24d12972ceda2bf95def5ed15891c9f347c8bca404357e1e0ad131ab00cf50dd WHIRLPOOL 216d35ec3a200e9c3ed67ff0912b844394b12e764a1170beaf21162feeec7b7bb4cc1ddfe9efcd3ddff9bd4fc4224ff408bdeaf262b700323507fff08fa47a31 | ||
DIST gnome-shell-extensions-3.18.2.tar.xz 233440 SHA256 cc514ffc896ed8c04853a89cb8e97058f9d5518313becf7c92aea5210b8adf61 SHA512 c24438495f8d79d21684b9c2d0d1eb753ed8d9ca99da34d6eb07007fe599aedfb1e0c54f55bddb9a76aa4eebfe7ee9017fdf4bcd97394a64eb68c68257ba7a2d WHIRLPOOL 544a70e24060c9601d465df53ce12ca0a0dadad95b351a59b38d3192628861b83f073aceb2ca1b6b669ca4f803aa6cc9dd5bab8988413cad05a381e783d4916c |
79 changes: 79 additions & 0 deletions
79
gnome-extra/gnome-shell-extensions/gnome-shell-extensions-3.18.2.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,79 @@ | ||
# Copyright 1999-2015 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI="5" | ||
GCONF_DEBUG="no" | ||
|
||
inherit gnome2 readme.gentoo | ||
|
||
DESCRIPTION="JavaScript extensions for GNOME Shell" | ||
HOMEPAGE="https://wiki.gnome.org/Projects/GnomeShell/Extensions" | ||
|
||
LICENSE="GPL-2" | ||
SLOT="0" | ||
IUSE="examples" | ||
KEYWORDS="~amd64 ~x86" | ||
|
||
COMMON_DEPEND=" | ||
>=dev-libs/glib-2.26:2 | ||
>=gnome-base/libgtop-2.28.3[introspection] | ||
>=app-eselect/eselect-gnome-shell-extensions-20111211 | ||
" | ||
RDEPEND="${COMMON_DEPEND} | ||
>=dev-libs/gjs-1.29 | ||
dev-libs/gobject-introspection:= | ||
dev-libs/atk[introspection] | ||
gnome-base/gnome-menus:3[introspection] | ||
>=gnome-base/gnome-shell-3.14.2 | ||
media-libs/clutter:1.0[introspection] | ||
net-libs/telepathy-glib[introspection] | ||
x11-libs/gdk-pixbuf:2[introspection] | ||
x11-libs/gtk+:3[introspection] | ||
x11-libs/pango[introspection] | ||
x11-themes/gnome-icon-theme-symbolic | ||
" | ||
DEPEND="${COMMON_DEPEND} | ||
>=dev-util/intltool-0.50 | ||
sys-devel/gettext | ||
virtual/pkgconfig | ||
" | ||
# eautoreconf needs gnome-base/gnome-common | ||
|
||
DISABLE_AUTOFORMATTING="yes" | ||
DOC_CONTENTS="Installed extensions installed are initially disabled by default. | ||
To change the system default and enable some extensions, you can use | ||
# eselect gnome-shell-extensions | ||
Alternatively, to enable/disable extensions on a per-user basis, | ||
you can use the https://extensions.gnome.org/ web interface, the | ||
gnome-extra/gnome-tweak-tool GUI, or modify the org.gnome.shell | ||
enabled-extensions gsettings key from the command line or a script." | ||
|
||
src_configure() { | ||
gnome2_src_configure --enable-extensions=all | ||
} | ||
|
||
src_install() { | ||
gnome2_src_install | ||
|
||
local example="[email protected]" | ||
if use examples; then | ||
mv "${ED}usr/share/gnome-shell/extensions/${example}" \ | ||
"${ED}usr/share/doc/${PF}/" || die | ||
else | ||
rm -r "${ED}usr/share/gnome-shell/extensions/${example}" || die | ||
fi | ||
|
||
readme.gentoo_create_doc | ||
} | ||
|
||
pkg_postinst() { | ||
gnome2_pkg_postinst | ||
|
||
ebegin "Updating list of installed extensions" | ||
eselect gnome-shell-extensions update | ||
eend $? | ||
|
||
readme.gentoo_print_elog | ||
} |