forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-util/debootstrap: Version 1.0.103.
Package-Manager: Portage-2.3.40, Repoman-2.3.9
- Loading branch information
Jeroen Roovers
committed
Jun 26, 2018
1 parent
de42ee9
commit aaab64f
Showing
2 changed files
with
49 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,4 +1,5 @@ | ||
DIST debootstrap_1.0.101.tar.gz 73074 BLAKE2B 293cd1016af3bb65229cc1fdf1a26a500eea099badd4d94db22d0013b878e6e054d38d2cadf7ddf87f32f1bea0c37a91718b6b20f0bee782c4e99a376ccdbe04 SHA512 692db9d6dcaa7e440e37b4c90e00c56933235f7462ebdfb640588c6cb1c08f7197997066529d2a03f1f3e857c390a693832c625a4de23dba1dd08801adfcfc9a | ||
DIST debootstrap_1.0.102.tar.gz 72977 BLAKE2B e5253a1317f586855cb33b56458ba7fec18d9ea330c999ad5d48830cc39311ad9a66b1f4fe7b8ce6bf0a7d0ccca50c00ebc07eb0aaf49ad9680ada46a66e863a SHA512 2ffb2f7d1ee19ea34c5d5f5a6951d6d5b4a298cea1438302cc0cc20cffeb1affa5774d7f77e332c5eb3f45698c9a10232415c89ad0aa34abec533768ea4a2dc2 | ||
DIST debootstrap_1.0.103.tar.gz 73167 BLAKE2B 063e27c1d58826bb7fec7879a5876df33b0da27cdbbdce3aa5ffecbcb70dba2814817e644725a132100cc7c7d182576bb2ba813f96bb4b289d06622d073da9d3 SHA512 4b43db32c46e5b69db9885494bc1f91197a40311c05196bf1c6e17d0a1f0519dbf61c8f5731c8627a708b8dfc8f3ba78e822a21879a5caf0d70046e3b7e60aa2 | ||
DIST debootstrap_1.0.89.tar.gz 69020 BLAKE2B 9175d0936b6c9a28a29ee1b24bd835c41aaf807bc24a029201aaa45d07789206ee06e38b0a70c1e507ab448a3ec9c0fded2838bfb868334270b5159b34cbe9eb SHA512 3f230ce3eff6359353d106c806ce395861fb47fc1416eb0b498af7ce12a45ce7572b18284633d6d4d07b73a4a203e03bc205df3eae0db6f637237d25d0a69b1a | ||
DIST devices.tar.gz 47835 BLAKE2B 03bfe097fda12a7a0aa19d3308c0d44382ad945defea05a63b17a72e4051ef94f0e60e75bde35baeace81da59d9f04126f6e463163609475b9c0fdf518f533ef SHA512 994ec8d72e3d52d2d872f7ff0da2336e4cbd3a5fa73bb6cdb9e06f5e7f5b8c69cea639c738fdba1186f382d6dcf62e7746fface664bfbd744aac24b16f034432 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,48 @@ | ||
# Copyright 1999-2018 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
inherit eutils | ||
|
||
DESCRIPTION="Debian/Ubuntu bootstrap scripts" | ||
HOMEPAGE="https://packages.qa.debian.org/d/debootstrap.html" | ||
SRC_URI="mirror://debian/pool/main/d/${PN}/${PN}_${PV}.tar.gz | ||
mirror://gentoo/devices.tar.gz" | ||
|
||
LICENSE="MIT" | ||
SLOT="0" | ||
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux" | ||
|
||
RDEPEND=" | ||
app-arch/dpkg | ||
net-misc/wget | ||
sys-devel/binutils | ||
" | ||
DOCS=( TODO debian/changelog ) | ||
|
||
src_unpack() { | ||
unpack ${PN}_${PV}.tar.gz | ||
cp "${DISTDIR}"/devices.tar.gz "${S}" | ||
} | ||
|
||
src_compile() { | ||
return | ||
} | ||
|
||
src_install() { | ||
default | ||
doman debootstrap.8 | ||
} | ||
|
||
pkg_postinst() { | ||
if ! has_version ${CATEGORY}/${PN} && ! has_version app-crypt/gnupg; then | ||
elog "To check Release files against a keyring (--keyring=K), please" | ||
elog "install app-crypt/gnupg" | ||
fi | ||
|
||
if ! has_version app-crypt/debian-archive-keyring || ! has_version app-crypt/ubuntu-keyring; then | ||
elog "To check Release files from Debian or Ubuntu, please install" | ||
elog " app-crypt/debian-archive-keyring or" | ||
elog " app-crypt/ubuntu-keyring as required" | ||
fi | ||
} |