Skip to content

Commit

Permalink
x11-misc/menulibre: Version 2.1.4.
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.19, Repoman-2.3.6
  • Loading branch information
Jeroen Roovers committed Jan 20, 2018
1 parent bd8ad60 commit ab2f1ca
Show file tree
Hide file tree
Showing 2 changed files with 69 additions and 0 deletions.
1 change: 1 addition & 0 deletions x11-misc/menulibre/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST menulibre-2.1.3.tar.gz 231336 BLAKE2B f15f962b41071f40cebdaa3fbab082932f1acad30026b89bb2b4672a860b4f7cc3caa668eadee48195a091783b6a8d5558ca44ed05034640247cad02394d3b93 SHA512 0a9040bcb311fe993238e5d1fc459db2400466c538c729ecd5bf2ff20cf9c7300ef2543c56ae4ef7cfa44cd66768ee9a9001ab997fd2507d8d74a246b2029c7a
DIST menulibre-2.1.4.tar.gz 414546 BLAKE2B 4c6420e6559415dd4be6aee37af43f820f85bb5d98ce4c3b475d977c1511d4ad30f1fb3db8aff94569a3dc0afa4d75887bed8247cd8d48c673bcb106cfa11b52 SHA512 48322d7187d77a63253ee5d8d269b473e36bab4d02f1442b8e4c66070d372e3eba4247b923932688640092e16d51ea41bef42571694980099c279a3526b9e56a
68 changes: 68 additions & 0 deletions x11-misc/menulibre/menulibre-2.1.4.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,68 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=5

PYTHON_COMPAT=( python3_{4,5,6} )
PYTHON_REQ_USE="xml"
DISTUTILS_IN_SOURCE_BUILD=1
inherit distutils-r1 eutils gnome2-utils versionator

DESCRIPTION="Advanced freedesktop.org compliant menu editor"
HOMEPAGE="https://bluesabre.org/projects/menulibre/"
SRC_URI="https://launchpad.net/${PN}/$(get_version_component_range 1-2)/${PV}/+download/${P}.tar.gz"

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"

DEPEND="
dev-python/python-distutils-extra[${PYTHON_USEDEP}]
"
RDEPEND="
dev-libs/gobject-introspection
dev-python/psutil[${PYTHON_USEDEP}]
dev-python/pygobject:3[${PYTHON_USEDEP}]
dev-python/pyxdg[${PYTHON_USEDEP}]
gnome-base/gnome-menus[introspection]
x11-libs/gdk-pixbuf[X,introspection]
x11-libs/gtk+:3[X,introspection]
x11-libs/gtksourceview:3.0[introspection]
x11-themes/hicolor-icon-theme
"

python_prepare_all() {
# too many categories
sed -i \
-e 's/X-GNOME-Settings-Panel;X-GNOME-PersonalSettings;DesktopSettings;X-XFCE;//' \
menulibre.desktop.in || die

local i
# fix incorrect behavior when LINGUAS is set to an empty string
# https://bugs.launchpad.net/python-distutils-extra/+bug/1133594
if [[ -n "${LINGUAS+x}" ]] ; then # if LINGUAS is set
for i in $(cd "${S}"/po ; for p in *.po ; do echo ${p%.po} ; done) ; do # for every supported language
if ! has ${i} ${LINGUAS} ; then # if language is disabled
rm po/${i}.po || die
fi
done
fi
distutils-r1_python_prepare_all
}
python_install_all() {
distutils-r1_python_install_all
}
pkg_preinst() {
gnome2_icon_savelist
}
pkg_postinst() {
gnome2_icon_cache_update
}
pkg_postrm() {
gnome2_icon_cache_update
}

0 comments on commit ab2f1ca

Please sign in to comment.