forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
kde-misc/kio-gdrive: 1.2.0 version bump
Package-Manager: Portage-2.3.5, Repoman-2.3.1
- Loading branch information
Showing
4 changed files
with
68 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST kio-gdrive-1.0.5.tar.xz 23148 SHA256 ada2327a3cbb02a9e9941190c240e50a1a484f5e3f56a1fe596b1445458c014f SHA512 d35c5d6bda967ec93b29ea29323b46a6f37d5478ffa6b719f4fd13e480d7785746e81bec9155b2c80db9d192aece867d67b3f96bc855453dda0098bfc8375798 WHIRLPOOL da5d14310ae54dabb1a1a7dfffdea118036a50ebbe74440422d3915c3461a43b4e874f5c70441ab4e69787b193412b2a3d7a7039dd6108fdec43731c7a1394b5 | ||
DIST kio-gdrive-1.1.0.tar.xz 23924 SHA256 90162c9e82f885d6198046f2e25e579d05e813fbab37757b9b8f5fbe1b0e6972 SHA512 a58e56a5fff16776c1e6d948b2d1c776eb6097bf686e2865a52ae22eb21e9c05a0e7c0daf6e19077c5876e351b75ad31ad8e75e5e1c3a58190bc8b224daee42a WHIRLPOOL c5c97f77d54d94f4fabc1f31feb8acb06c0cd76c885f5ade690c68f72e2e50ab897f4e1797cc4cf72e9500f5159a7aa053f6f80803c2058276ee980c5f91446c | ||
DIST kio-gdrive-1.1.1.tar.xz 24096 SHA256 c840151e844f9c135ff575771c09ac78bd9c939b853af72b568c76aa1db540ea SHA512 9377167a8f12731b27adc816790f50b73685dbfccf416e4ca927f08d52a85adb2cc6d769c111fc66fd24fe9646217321d7392946dbc6f05c9eb8a3e6aeb929ba WHIRLPOOL 2096961eb41738a319cc8e9589a0c6b14df6c55a365344c8dd484ed2b329aae2f19db12c7e9c8f8ef0417241406ea81a607cb03008d53207f2c84705482941fd | ||
DIST kio-gdrive-1.2.0.tar.xz 33780 SHA256 c3b0eb54efc92daa636c8eb81113bf8f196cd2e3af0ba8c37660bfa3a7dd9274 SHA512 244d4eb3ec17451400b8e68eb554f5bf8708c797085dc8606be095d1c39f367e9f5c8633d68834cfdbd25032e1726372d3fead131610d3ae9daf25f555924d29 WHIRLPOOL 2e66b8706604e1ea1aed1af817f18fb4f901ff2fa7b52fd28ee6807b1e309b9362fd10d4fd0bbd2dd3b75c91bc00fa0ca18a0e94be3391dc2f12bd838eeab388 |
21 changes: 21 additions & 0 deletions
21
kde-misc/kio-gdrive/files/kio-gdrive-1.2.0-tests-optional.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,21 @@ | ||
commit e9ddacb58dcf011bc2a877c11b026cab94031e65 | ||
Author: Andreas Sturmlechner <[email protected]> | ||
Date: Sat May 27 15:58:32 2017 +0200 | ||
|
||
If tests are optional, autotests subdir must be conditional | ||
|
||
diff --git a/CMakeLists.txt b/CMakeLists.txt | ||
index 0c1b691..a2a771c 100644 | ||
--- a/CMakeLists.txt | ||
+++ b/CMakeLists.txt | ||
@@ -61,7 +61,9 @@ add_definitions(-DQT_NO_URL_CAST_FROM_STRING) | ||
add_definitions(-DQT_STRICT_ITERATORS) | ||
add_definitions(-DTRANSLATION_DOMAIN=\"kio5_gdrive\") | ||
|
||
-add_subdirectory(autotests) | ||
+if(BUILD_TESTING) | ||
+ add_subdirectory(autotests) | ||
+endif() | ||
add_subdirectory(desktop) | ||
add_subdirectory(doc) | ||
add_subdirectory(src) |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,45 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
|
||
KDE_APPS_MINIMAL="17.04.0" | ||
KDE_HANDBOOK="true" | ||
KDE_TEST="optional" | ||
inherit kde5 | ||
|
||
DESCRIPTION="KIO Slave for Google Drive service" | ||
HOMEPAGE="https://phabricator.kde.org/project/profile/72/" | ||
|
||
if [[ ${KDE_BUILD_TYPE} != live ]] ; then | ||
SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.xz" | ||
KEYWORDS="~amd64" | ||
fi | ||
|
||
IUSE="+kaccounts" | ||
|
||
RDEPEND=" | ||
$(add_frameworks_dep kcoreaddons) | ||
$(add_frameworks_dep ki18n) | ||
$(add_frameworks_dep kio) | ||
$(add_frameworks_dep knotifications) | ||
$(add_kdeapps_dep libkgapi) | ||
$(add_qt_dep qtwidgets) | ||
kaccounts? ( $(add_kdeapps_dep kaccounts-integration) ) | ||
!kaccounts? ( dev-libs/qtkeychain:=[qt5] ) | ||
" | ||
DEPEND="${RDEPEND} | ||
$(add_qt_dep qtgui) | ||
$(add_qt_dep qtnetwork) | ||
" | ||
|
||
DOCS=( README.md ) | ||
|
||
PATCHES=( "${FILESDIR}/${P}-tests-optional.patch" ) | ||
|
||
src_configure() { | ||
local mycmakeargs=( | ||
$(cmake-utils_use_find_package kaccounts KAccounts) | ||
) | ||
kde5_src_configure | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters