Skip to content

Commit

Permalink
dev-python/node-semver: Add python3_6
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.5, Repoman-2.3.2
  • Loading branch information
mrueg committed May 17, 2017
1 parent 702209c commit ab37c18
Showing 1 changed file with 15 additions and 3 deletions.
18 changes: 15 additions & 3 deletions dev-python/node-semver/node-semver-0.1.1.ebuild
Original file line number Diff line number Diff line change
@@ -1,9 +1,9 @@
# Copyright 1999-2016 Gentoo Foundation
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

PYTHON_COMPAT=( python2_7 python3_{4,5} pypy pypy3 )
PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )

inherit distutils-r1

Expand All @@ -17,4 +17,16 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
IUSE=""
IUSE="test"

DEPEND="test? ( dev-python/pytest[${PYTHON_USEDEP}] )"

python_prepare_all() {
# https://github.com/podhmo/python-semver/issues/4
sed -i -e "/github.com/d" semver/tests/test_negative_range.py || die
distutils-r1_python_prepare_all
}

python_test() {
py.test || die
}

0 comments on commit ab37c18

Please sign in to comment.