Skip to content

Commit

Permalink
app-crypt/pesign: Supply cross-compiling programs
Browse files Browse the repository at this point in the history
(with minor style changes from vdupras)

Closes: https://bugs.gentoo.org/621804
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Signed-off-by: Virgil Dupras <[email protected]>
  • Loading branch information
dm0- authored and Virgil Dupras committed Sep 29, 2018
1 parent 5365836 commit ab3ba62
Showing 1 changed file with 9 additions and 3 deletions.
12 changes: 9 additions & 3 deletions app-crypt/pesign/pesign-0.112.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2017 Gentoo Foundation
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6
Expand Down Expand Up @@ -35,7 +35,13 @@ PATCHES=(
)

src_compile() {
emake CC="$(tc-getCC)"
emake AR="$(tc-is-gcc && echo "$(tc-getCC)-ar" || tc-getAR)" \
AS="$(tc-getAS)" \
CC="$(tc-getCC)" \
LD="$(tc-getLD)" \
OBJCOPY="$(tc-getOBJCOPY)" \
PKG_CONFIG="$(tc-getPKG_CONFIG)" \
RANLIB="$(tc-getRANLIB)"
}

src_install() {
Expand All @@ -44,5 +50,5 @@ src_install() {

# remove some files that don't make sense for Gentoo installs
rm -rf "${ED%/}/etc/" "${ED%/}/var/" \
"${ED%/}/usr/share/doc/${PF}/COPYING" || die
"${ED%/}/usr/share/doc/${PF}/COPYING" || die
}

0 comments on commit ab3ba62

Please sign in to comment.