Skip to content

Commit

Permalink
app-text/llpp: snapshot version p20191016
Browse files Browse the repository at this point in the history
llpp v31 doesn't build against >=mupdf-1.17 and v32 against ocaml<4.10

Signed-off-by: Jouni Kosonen <[email protected]>
Closes: gentoo#16797
Signed-off-by: Sam James <[email protected]>
  • Loading branch information
jok-ts authored and thesamesam committed Sep 2, 2020
1 parent 0c66b15 commit ab7362c
Show file tree
Hide file tree
Showing 2 changed files with 74 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-text/llpp/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST llpp-30.tar.gz 165821 BLAKE2B 755648f9f7e0e0740dd9647559c085ab1626edfceb91d8df4aa783610f32499d744f24a2e0ac0d6f13e747695e8829112e59bcf0fc78c7ef5f4b2427c759353d SHA512 1dfcf273bdabfb3c7b38366bac60659555b943f459cb3fd6e656df1a33c0f84e6745d62522c5498df0bd6182bda13973144724054588c07145018bb3e758d893
DIST llpp-30_p20190316.tar.gz 169517 BLAKE2B 56dbb4fc1f46e654f15986edf870bec22c3d26c694915db88125d99b8f0460c70ac3bd48c82f45f32939f5a09753a4ec6f2e6d544397a0d6ba242640c363917d SHA512 c736b94595eab1fd45e6fb6aa89a988e0c3ec1f4c7c88f8655d17a88c9ff62c6b7db4396a3934690861b5e61af595baa6736b92c585ad68c51677f3e577bd713
DIST llpp-31.tar.gz 169199 BLAKE2B 3f60db741fb94bf1b4753f5443705e68f062a68212fd3d0d8062f54b3b71002dc0ee3ba3040f9be028a40d8e96de11c8c53966196e631458f65d863f90f7226f SHA512 d9e213078899ece4a92291199bc2ea962c40a185b9908a7db241a773f57c64e08b004a8433984b86cc4b59088f97991b2ee8ee94e75d71536ce378dd32316e57
DIST llpp-31_p20191016.tar.gz 169480 BLAKE2B af8f01d156863b642ad1c062b4b1a00a744955fdc1e7446b7a5023e6d03b58af77c699140b54d337c0eeacf65fba7a06ccfd6baa6ab9e1920bd7fd0fcfa90d97 SHA512 6fdd2621aec9f026e175c52957c77293a105adc81e42dad33f24631d5d2ae6775978834e84e1cab73cc8d1246af684384f9057a0f613438a19eaf7b607f92ddf
73 changes: 73 additions & 0 deletions app-text/llpp/llpp-31_p20191016.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,73 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit toolchain-funcs xdg-utils

DESCRIPTION="Graphical PDF viewer which aims to superficially resemble less(1)"
HOMEPAGE="https://github.com/moosotc/llpp"
MY_COMMIT="25c10de38cbfe0874d377e7599108e6b2a8a92ff"
SRC_URI="https://github.com/moosotc/llpp/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"

LICENSE="public-domain"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="+ocamlopt static-libs"

RDEPEND=">=app-text/mupdf-1.17.0:0=[static-libs?]
app-arch/bzip2[static-libs?]
media-libs/fontconfig:1.0[static-libs?]
media-libs/freetype:2[static-libs?]
media-libs/jbig2dec:=[static-libs?]
media-libs/openjpeg:2[static-libs?]
sys-libs/zlib[static-libs?]
virtual/jpeg:0[static-libs?]
x11-libs/libX11[static-libs?]
x11-libs/libXau[static-libs?]
x11-libs/libXdmcp[static-libs?]
x11-misc/xsel"
DEPEND="${RDEPEND}
dev-ml/lablgl[glut,ocamlopt?]"
BDEPEND="
>=dev-lang/ocaml-4.09[ocamlopt?]
app-text/asciidoc
virtual/pkgconfig"

RESTRICT="!ocamlopt? ( strip )"

PATCHES=( "${FILESDIR}"/${PN}-30-keysym.patch )

S="${WORKDIR}"/"${PN}"-"${MY_COMMIT}"

src_prepare() {
default

# use custom makefile from archlinux with minor changes
cp "${FILESDIR}"/Makefile "${S}" || die

# re-add desktop file removed upstream
cp "${FILESDIR}"/llpp.desktop "${S}"/misc || die

# remove empty interface definition
rm "${S}"/main.mli || die
}

src_compile() {
emake -j1 VERSION=${PV} CC="$(tc-getCC)" LIBDIR="/usr/$(get_libdir)"
}

src_install() {
emake DESTDIR="${D}" PREFIX="/usr" install
dodoc README Thanks
}

pkg_postinst() {
xdg_desktop_database_update
xdg_mimeinfo_database_update
}

pkg_postrm() {
xdg_desktop_database_update
xdg_mimeinfo_database_update
}

0 comments on commit ab7362c

Please sign in to comment.