Skip to content

Commit

Permalink
dev-perl/X11-XCB: Bump to version 0.180.0
Browse files Browse the repository at this point in the history
- EAPI7
- Ensure CFLAGS passed to make/compiler

Upstream:
- use Newxz to zero-allocate size hints

Closes: https://bugs.gentoo.org/744115
Package-Manager: Portage-3.0.8, Repoman-3.0.1
Signed-off-by: Kent Fredric <[email protected]>
  • Loading branch information
kentfredric committed Oct 5, 2020
1 parent fa839f2 commit aba8c27
Show file tree
Hide file tree
Showing 2 changed files with 57 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-perl/X11-XCB/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST X11-XCB-0.17.tar.gz 90833 BLAKE2B 7de56a99abb27373f0473e4d98c177d3db4f4811bdee358e79a85db26345e59f3dfa0998e10678fce1585ddbf1f58796f75d2adc198ec6d23ae521720b3d93ae SHA512 8a5457afdb3b32fd6d425a27dee1a6afbbded222cf71a9d7201ed2c0db0b0b7c803ae3e69a897c510b9b07b79e880efe0cf062ea025d2d3ff7ee16d364c568bc
DIST X11-XCB-0.18.tar.gz 90478 BLAKE2B f5f3c74c1afdcee75bfab29733180b7d76aeb1be7a5fcdffc9acc1a15f9b842b12e88d826f5ce182b4e3ad5d36e9b44a0169341fae5ac265270462efbad0e60a SHA512 eeecd8fbf080a6ca2f28b8fe4b64c97339f27b27c9c70d1a8e7c0f56af193243295aa1fc65039d24c81396126befc27ca114ca4cd1641139a788c46fe600f3ba
56 changes: 56 additions & 0 deletions dev-perl/X11-XCB/X11-XCB-0.180.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,56 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

DIST_AUTHOR=MSTPLBG
DIST_VERSION=0.18
inherit perl-module virtualx

DESCRIPTION="Perl bindings for libxcb"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
IUSE="test"
RESTRICT="!test? ( test )"

RDEPEND="
dev-perl/Data-Dump
dev-perl/Mouse
dev-perl/MouseX-NativeTraits
dev-perl/Try-Tiny
dev-perl/XML-Descent
dev-perl/XML-Simple
>=virtual/perl-XSLoader-0.20.0
>=x11-libs/libxcb-1.2
x11-libs/xcb-util
x11-libs/xcb-util-wm
"
DEPEND="
>=x11-libs/libxcb-1.2
x11-libs/xcb-util
x11-libs/xcb-util-wm
x11-base/xcb-proto
"
BDEPEND="${RDEPEND}
x11-base/xcb-proto
>=virtual/perl-Devel-PPPort-3.190.0
dev-perl/ExtUtils-Depends
>=virtual/perl-ExtUtils-MakeMaker-6.590.0
>=virtual/perl-ExtUtils-ParseXS-3.180.0
dev-perl/ExtUtils-PkgConfig
dev-perl/XS-Object-Magic
test? (
dev-perl/Test-Deep
dev-perl/Test-Exception
virtual/perl-Test-Simple
)
"
src_compile() {
mymake=(
"OPTIMIZE=${CFLAGS}"
)
MAKEOPTS="-j1" perl-module_src_compile
}
src_test() {
virtx perl-module_src_test
}

0 comments on commit aba8c27

Please sign in to comment.