forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-admin/bitwarden-desktop-bin: version bump 1.26.5
Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Michael Palimaka <[email protected]>
- Loading branch information
Michael Palimaka
committed
Jun 4, 2021
1 parent
50b2f76
commit abac9dd
Showing
2 changed files
with
82 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST Bitwarden-1.25.1-amd64.deb 58573904 BLAKE2B 109bec39c1a385127b00222752f6eac906cdea19df790dfede0f8dd6e2febdf35958b2b420737cf2dbfdd9648a85b93810ad1f8e2d6a222dcd07437d9333e7d7 SHA512 b20c5c3890a98f6990f7e7f1274027aba3011a416781b6fd76b6c37959ebf787cdb129dd16fe9b4601b5cbc39018dadc36efe680391c04ed0a4c763d221a3cbd | ||
DIST Bitwarden-1.26.4-amd64.deb 58223196 BLAKE2B 38726d9feb35f15130e81a479d74e5c80d344656d46dd9b9e82a7deab9d83b21b3d0a30dc2e8fc9a371b72f2dabe06234c955077fd16163f8e8ad551b49e98c6 SHA512 b0de7ed7b00b5308a2137b2632150bd288a7383a13295814c6c6af1a85f911a6790ad162f67af07844f8fca80044b95f58a37e6ab762429d061f3c9af3616e11 | ||
DIST Bitwarden-1.26.5-amd64.deb 58215042 BLAKE2B 216e5042e925bc12a9feb1c038cacddc05b6c4aad8b76413ec50771cbfdab399c64e8388277d571708094e6b14b7d89b3c20ffd3d23d4010340b9d94068560cc SHA512 c2506a9f64d47138e6ce53bb7211e2562f9bb9847f4b48b059dd504eec312f6852571aaa550830f54488c0d67d02c0eb67bcac049a688098d1b8a55492b008f7 |
81 changes: 81 additions & 0 deletions
81
app-admin/bitwarden-desktop-bin/bitwarden-desktop-bin-1.26.5.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,81 @@ | ||
# Copyright 1999-2021 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
inherit unpacker xdg-utils | ||
|
||
MY_PN="Bitwarden" | ||
DESCRIPTION="Bitwarden password manager desktop client" | ||
HOMEPAGE="https://bitwarden.com/" | ||
SRC_URI="https://github.com/bitwarden/desktop/releases/download/v${PV}/Bitwarden-${PV}-amd64.deb" | ||
|
||
LICENSE="GPL-3" | ||
SLOT="0" | ||
KEYWORDS="~amd64" | ||
IUSE="" | ||
|
||
RDEPEND=" | ||
app-accessibility/at-spi2-atk:2 | ||
app-accessibility/at-spi2-core:2 | ||
app-crypt/libsecret | ||
dev-libs/atk | ||
dev-libs/expat | ||
dev-libs/glib | ||
dev-libs/nspr | ||
dev-libs/nss | ||
media-libs/alsa-lib | ||
media-libs/mesa | ||
net-print/cups | ||
sys-apps/dbus | ||
sys-apps/util-linux | ||
x11-libs/cairo | ||
x11-libs/gdk-pixbuf:2 | ||
x11-libs/gtk+:3 | ||
x11-libs/libdrm | ||
x11-libs/libX11 | ||
x11-libs/libxcb | ||
x11-libs/libXcomposite | ||
x11-libs/libXcursor | ||
x11-libs/libXdamage | ||
x11-libs/libXext | ||
x11-libs/libXfixes | ||
x11-libs/libXi | ||
x11-libs/libxkbcommon | ||
x11-libs/libXrandr | ||
x11-libs/libXrender | ||
x11-libs/libXScrnSaver | ||
x11-libs/libXtst | ||
x11-libs/pango | ||
" | ||
|
||
S="${WORKDIR}" | ||
|
||
QA_PREBUILT=" | ||
opt/Bitwarden/*.so | ||
opt/Bitwarden/bitwarden | ||
opt/Bitwarden/chrome-sandbox | ||
" | ||
|
||
src_install() { | ||
insinto /opt | ||
doins -r opt/${MY_PN} | ||
fperms 755 /opt/Bitwarden/bitwarden | ||
fperms 4755 /opt/Bitwarden/chrome-sandbox | ||
|
||
insinto /usr/share/applications | ||
doins usr/share/applications/bitwarden.desktop | ||
|
||
insinto /usr/share/icons | ||
doins -r usr/share/icons/hicolor | ||
} | ||
|
||
pkg_postinst() { | ||
xdg_desktop_database_update | ||
xdg_icon_cache_update | ||
} | ||
|
||
pkg_postrm() { | ||
xdg_desktop_database_update | ||
xdg_icon_cache_update | ||
} |