Skip to content

Commit

Permalink
app-admin/drush: version bump the 6.x series.
Browse files Browse the repository at this point in the history
A version bump to v7.1.0 was requested in bug #564260. Unfortunately,
the 7.x and 8.x series require Composer, and we cannot package them.
This however alerted me to a new v6.6.0 release -- the subject
of this commit.

Gentoo-Bug: 564260

Package-Manager: portage-2.2.20.1
  • Loading branch information
orlitzky committed Oct 27, 2015
1 parent 9208505 commit abb3853
Show file tree
Hide file tree
Showing 2 changed files with 65 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-admin/drush/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST drush-5.8.tar.gz 409642 SHA256 15dd85f04c49b4a896b02dd6960d3140f3ae680bab3eea5d3aba27be0481e480 SHA512 85f7572aece8590d23164dc938e00b740718a5b9bf20ca866083f9e8ce2025ec07f57e06234bf50bfe2351f407f5bad21789103c1e04d18d2fd202fa735637e6 WHIRLPOOL 68f4a8ca09fc61c36de3d6cc6e3aeaab2021b677ba9d732a65f4d5a9940ebbee3cd63dc84f165e119770168547b1997aff6c23497dc50dbe548df348c296188c
DIST drush-6.5.0.tar.gz 509643 SHA256 0e6bfb8a4bd75846dbca25f6d3e3130a706546f6a62edadce2eb00099750e2a7 SHA512 4afd348c025b9303386131687205af4219a77e6c822518b079a3f0475cbd7ed03647797d613300c7a281e2354f0d855435222fe1afe13447153cdbd6a4393add WHIRLPOOL 1f2a1a725e1c0f89cac90a1338e1541e587c7834560fd23d1a44341696be320e65cf93508d4841f02ca9b30ac62f3fed7de772e00f4eaeea64f287cf19682fcc
DIST drush-6.6.0.tar.gz 511330 SHA256 67f7a1f08238c8c3f61d4e93f8c7c83508f392086c9931865fd1022981e8f698 SHA512 d7d361628406dd0f0fc5b07e7a318abd04ca7ac63da9d3fa705b0a64b531394f6e45e944dbd1c2e7eaec6643a92792b9b8558aea6ebb5311ce7acd32aa438a21 WHIRLPOOL ff0f2b1f20cc7a5767513be78b6f7ce1d09fb8929089ac918c4982e57f7c5c4f174c5dfd75235dafde57e65b90717844d4d9dfa199871e5c65bc4deda19b6b8c
64 changes: 64 additions & 0 deletions app-admin/drush/drush-6.6.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,64 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

inherit bash-completion-r1 eutils

DESCRIPTION="Command line shell and scripting interface for Drupal"
HOMEPAGE="https://github.com/drush-ops/${PN}"
SRC_URI="https://github.com/drush-ops/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""

DEPEND=""
RDEPEND="dev-lang/php[cli,ctype,json,simplexml]
dev-php/PEAR-Console_Table"

src_prepare() {
# Fix the bash completion script, check the patch for Gentoo/upstream
# bug numbers.
epatch "${FILESDIR}/update-bash-completion-script-for-2.1.patch"

# dodoc compresses all of the documentation, so we fix the filenames
# in a few places.

# First, the README location in bootstrap.inc.
sed -i -e \
"s!/share/doc/drush!/share/doc/${PF}!" \
-e "s!README\.md!\0.bz2!g" \
includes/bootstrap.inc || die

# Next, the list of documentation in docs.drush.inc. Note that
# html files don't get compressed.
sed -i \
-e "s!\.bashrc'!.bashrc.bz2'!" \
-e "s!\.inc'!.inc.bz2'!" \
-e "s!\.ini'!.ini.bz2'!" \
-e "s!\.md'!.md.bz2'!" \
-e "s!\.php'!.php.bz2'!" \
-e "s!\.script'!.script.bz2'!" \
-e "s!\.txt'!.txt.bz2'!" \
commands/core/docs.drush.inc || die
}

src_install() {
# Always install the examples; they're referenced within the source
# code and too difficult to exorcise.
dodoc -r README.md docs examples

insinto /usr/share/drush
doins -r classes commands includes lib misc
doins drush_logo-black.png drush.info drush.php

exeinto /usr/share/drush
doexe drush
dosym /usr/share/drush/drush /usr/bin/drush

keepdir /etc/drush
newbashcomp drush.complete.sh drush
}

0 comments on commit abb3853

Please sign in to comment.