Skip to content

Commit

Permalink
dev-python/APScheduler: Enable py3.9
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed May 23, 2021
1 parent 67ed3e8 commit abd33c7
Showing 1 changed file with 5 additions and 10 deletions.
15 changes: 5 additions & 10 deletions dev-python/APScheduler/APScheduler-3.6.3.ebuild
Original file line number Diff line number Diff line change
@@ -1,10 +1,10 @@
# Copyright 1999-2020 Gentoo Authors
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python3_{7..8} )
DISTUTILS_USE_SETUPTOOLS=rdepend
PYTHON_COMPAT=( python3_{7..9} )

inherit distutils-r1

Expand All @@ -15,18 +15,17 @@ SRC_URI="mirror://pypi/A/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"
RESTRICT="!test? ( test )"

RDEPEND="dev-python/pytz[${PYTHON_USEDEP}]
>=dev-python/six-1.4.0[${PYTHON_USEDEP}]
>=dev-python/tzlocal-1.2[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
BDEPEND="
test? (
dev-python/pytest[${PYTHON_USEDEP}]
www-servers/tornado[${PYTHON_USEDEP}]
)"

distutils_enable_tests pytest

# Tests that are known to fail (some may be triggered by network-sandbox).
test_failures=(
test_add_class_method_job
Expand Down Expand Up @@ -64,7 +63,3 @@ python_prepare_all() {

distutils-r1_python_prepare_all
}

python_test() {
py.test || die "Testing failed with ${EPYTHON}"
}

0 comments on commit abd33c7

Please sign in to comment.