Skip to content

Commit

Permalink
media-fonts/noto: Version bump
Browse files Browse the repository at this point in the history
Also add an optional extra USE flag allowing people to drop some fonts to
reduce disk space usage (#678432)

Closes: https://bugs.gentoo.org/687094
Bug: https://bugs.gentoo.org/678432
Package-Manager: Portage-2.3.67, Repoman-2.3.13
Signed-off-by: Pacho Ramos <[email protected]>
  • Loading branch information
pacho2 committed Jun 2, 2019
1 parent 2999756 commit abfc589
Show file tree
Hide file tree
Showing 3 changed files with 47 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-fonts/noto/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST noto-20170403.tar.xz 11083152 BLAKE2B 8281cc19a100d1cbf7f57fba9cba077bb0005f7296f58d48247bef6c804b53597ff359dfab7b7d851e42c0294c757f311979b98dc9f1c22e2d3f3fabe4db77e7 SHA512 f8f1414b5b6f793e86ef3cc6a6320c4545f079b337c7672cb8cccc3c50d21d353d81557da4a555cdb6524c79be3e4c167f7d5aac102c38d64926f3b1887ca7f3
DIST noto-20181024.tar.gz 726721580 BLAKE2B d19d32d98419395df1bb3ca360bd67a50487d499aa3ea1612355b2f0fef09fe8236583fedc6d528668048ccbeee7139df704fc8e125c5eec7215708838aa09f4 SHA512 5df8266fab59a9ad5e6de6971c69d2761864c29e8d0e79e16a44177327b73527a37a9d148b63c862bfb5f7507793aab5c4319603f3b8b80e18eb9f203d7a7334
DIST noto-20190524.tar.gz 740252290 BLAKE2B e169ee60c9a83c13656ebd5dbce32aad183bbebc057035c69723788725a1c14a016c37bea7ccf30fc9d776e421515c2fa03f929b5f7bf95d9e3abb1abbeccbbf SHA512 668f7d015da420b3c32f8c0313037bab731bd915875f476beb47e6c3e8d33a30cd608d2f351194607afbf28f8f3efc1eb5f8470c03fd88a83df33b478fa78147
3 changes: 3 additions & 0 deletions media-fonts/noto/metadata.xml
Original file line number Diff line number Diff line change
Expand Up @@ -13,4 +13,7 @@
<email>[email protected]</email>
<name>Pacho Ramos</name>
</maintainer>
<use>
<flag name="extra">Install full upstream font set</flag>
</use>
</pkgmetadata>
43 changes: 43 additions & 0 deletions media-fonts/noto/noto-20190524.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,43 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6
inherit font

DESCRIPTION="Google's font family that aims to support all the world's languages"
HOMEPAGE="https://www.google.com/get/noto/ https://github.com/googlei18n/noto-fonts"

COMMIT="34e98229863e627d0f841e124a8657d5d0348b04"
SRC_URI="https://github.com/googlei18n/noto-fonts/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"

LICENSE="OFL-1.1"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~sparc ~x86"
# Extra allows to optionally reduce disk usage even returning to tofu
# issue as described in https://www.google.com/get/noto/
IUSE="cjk +extra"

RDEPEND="cjk? ( media-fonts/noto-cjk )"
DEPEND=""

RESTRICT="binchecks strip"

S="${WORKDIR}/${PN}-fonts-${COMMIT}"

FONT_SUFFIX="ttf"
FONT_CONF=(
# From ArchLinux
"${FILESDIR}/66-noto-serif.conf"
"${FILESDIR}/66-noto-mono.conf"
"${FILESDIR}/66-noto-sans.conf"
)

src_install() {
# Don't install in separate subdirs
FONT_S="${S}/unhinted/" font_src_install
FONT_S="${S}/hinted/" font_src_install

# Allow to drop some fonts optionally for people that want to save
# disk space. Following ArchLinux options.
use extra || rm -rf "${ED}"/usr/share/fonts/noto/Noto*{Condensed,SemiBold,Extra}*.ttf
}

0 comments on commit abfc589

Please sign in to comment.