Skip to content

Commit

Permalink
app-mobilephone/wammu: Version bump
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.6, Repoman-2.3.2
  • Loading branch information
pacho2 committed Jul 15, 2017
1 parent 6e6186d commit ac1bad5
Show file tree
Hide file tree
Showing 2 changed files with 66 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-mobilephone/wammu/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST wammu-0.40.tar.bz2 687062 SHA256 cffd4fc6cc7b9433b3f589d51671a5ac5e188abbf676ebe0ce94011933fdb2ff SHA512 2ed5d5cdd63b3731808c5fa8cc36caf394c4ccf714eb4ef39a25f1e7967d8ccf8b69db5aeff37ff0d1bbf7cefec51fe070a5f0b90d0cb8271f1a3d243eaf06fd WHIRLPOOL b05dac88593c5ae3c01f63984824690991a347e4efff2bf3595b1088d9903843e018690845391ab48f62ab7d17f11d0b3a801103a1c408822b1c9afdd88f7150
DIST wammu-0.43.tar.xz 563832 SHA256 1595d120c7e18674538663d6471ce8fd5b975baf9682ab594f6303b1cf520796 SHA512 c8f0aad8d8fc2c852638a77b45d48ba3c512a1e1cf8f8dc54b99a614f7338f366494ef88d786143defd77e55ab9597d9c705569c4e0fceb856f29a05b9c6a843 WHIRLPOOL 63f1c3f7c347ffab592d2ef4a386dbf1ae42e4d1d92c945ad21a14be25b449a73380021c896205eda5288f41bec492e292e464ec82c4a81a5419060b4340874d
65 changes: 65 additions & 0 deletions app-mobilephone/wammu/wammu-0.43.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,65 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
PYTHON_COMPAT=( python2_7 )

inherit distutils-r1

DESCRIPTION="Front-end for gammu to access mobile phones easily"
HOMEPAGE="http://www.wammu.eu/"
SRC_URI="http://dl.cihar.com/wammu/v0/${P}.tar.xz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="bluetooth gnome"

RDEPEND="
>=app-mobilephone/gammu-1.36
dev-python/python-gammu
>=dev-python/wxpython-2.8:*[${PYTHON_USEDEP}]
bluetooth? (
dev-python/pybluez[${PYTHON_USEDEP}]
gnome? ( net-wireless/gnome-bluetooth )
)
"
DEPEND="${RDEPEND}"

# Supported languages and translated documentation
# Be sure all languages are prefixed with a single space!
MY_AVAILABLE_LINGUAS=" af ar bg bn ca cs da de el en_GB es et fi fr gl he hu id it ko nl pl pt_BR ro ru sk sv sw tr uk zh_CN zh_TW"
IUSE="${IUSE} ${MY_AVAILABLE_LINGUAS// / linguas_}"

# Required to source locale content out of the box
DISTUTILS_IN_SOURCE_BUILD=1

src_prepare() {
local lang support_linguas=no
for lang in ${MY_AVAILABLE_LINGUAS} ; do
if use linguas_${lang} ; then
support_linguas=yes
break
fi
done
# install all languages when all selected LINGUAS aren't supported
if [ "${support_linguas}" = "yes" ]; then
for lang in ${MY_AVAILABLE_LINGUAS} ; do
if ! use linguas_${lang} ; then
rm -r locale/${lang} || die
fi
done
fi

distutils-r1_src_prepare
}

src_compile() {
# SKIPWXCHECK: else 'import wx' results in
# Xlib: connection to ":0.0" refused by server
SKIPWXCHECK=yes distutils-r1_src_compile
}

src_install() {
SKIPWXCHECK=yes distutils-r1_src_install
}

0 comments on commit ac1bad5

Please sign in to comment.