Skip to content

Commit

Permalink
dev-python/clang-python: Add split ebuild for clang Python bindings
Browse files Browse the repository at this point in the history
  • Loading branch information
mgorny committed Feb 15, 2017
1 parent 0e9129c commit ac1ff58
Show file tree
Hide file tree
Showing 5 changed files with 85 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/clang-python/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST cfe-4.0.0rc1.src.tar.xz 10896792 SHA256 e1bf51a2df20b4b5eee59e443b4791c59fd1b60d637cd0706326edb25494c945 SHA512 51a4eae186c64fce71221d443364a1ecde3660d0ef8c5c066a154ac9fbe2de557a0b33c72d7eeefc2c992482ed8da823e66acc162e1961e96452c92638b4ede7 WHIRLPOOL 98dd37c07018d22c77bdfe2f4e521af5e46936731bce98575e28e402b8bdfae4e2af0c278e888d1a244c73bee9e0cfc00ec4d03bcc398354fbe7cd8722ecc717
37 changes: 37 additions & 0 deletions dev-python/clang-python/clang-python-4.0.0_rc1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,37 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

PYTHON_COMPAT=( python2_7 )
inherit python-r1

DESCRIPTION="Python bindings for sys-devel/clang"
HOMEPAGE="http://llvm.org/"
SRC_URI="http://www.llvm.org/pre-releases/${PV/_//}/cfe-${PV/_/}.src.tar.xz"

LICENSE="UoI-NCSA"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~x86"
IUSE="test"

# The module is opening libclang.so directly, and doing some blasphemy
# on top of it.
RDEPEND="
>=sys-devel/clang-${PV}
!sys-devel/llvm:0[clang(-),python(-)]
!sys-devel/clang:0[python(-)]
${PYTHON_DEPS}"
DEPEND="${RDEPEND}
test? ( dev-python/nose[${PYTHON_USEDEP}] )"

S=${WORKDIR}/cfe-${PV/_/}.src/bindings/python

src_test() {
python_foreach_impl nosetests -v
}

src_install() {
python_foreach_impl python_domodule clang
}
39 changes: 39 additions & 0 deletions dev-python/clang-python/clang-python-9999.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,39 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

PYTHON_COMPAT=( python2_7 )
inherit git-r3 python-r1

DESCRIPTION="Python bindings for sys-devel/clang"
HOMEPAGE="http://llvm.org/"
SRC_URI=""
EGIT_REPO_URI="http://llvm.org/git/clang.git
https://github.com/llvm-mirror/clang.git"

LICENSE="UoI-NCSA"
SLOT="0"
KEYWORDS=""
IUSE="test"

# The module is opening libclang.so directly, and doing some blasphemy
# on top of it.
RDEPEND="
>=sys-devel/clang-${PV}
!sys-devel/llvm:0[clang(-),python(-)]
!sys-devel/clang:0[python(-)]
${PYTHON_DEPS}"
DEPEND="${RDEPEND}
test? ( dev-python/nose[${PYTHON_USEDEP}] )"

S=${WORKDIR}/${P}/bindings/python

src_test() {
python_foreach_impl nosetests -v
}

src_install() {
python_foreach_impl python_domodule clang
}
7 changes: 7 additions & 0 deletions dev-python/clang-python/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,7 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>[email protected]</email>
</maintainer>
</pkgmetadata>
1 change: 1 addition & 0 deletions profiles/package.mask
Original file line number Diff line number Diff line change
Expand Up @@ -254,6 +254,7 @@ x11-drivers/xf86-video-v4l
# important revdeps. Also revdeps that require 4.0.
=app-vim/llvm-vim-4.0.0*
=dev-ml/llvm-ocaml-4.0.0*
=dev-python/clang-python-4.0.0*
=dev-python/lit-4.0.0*
=dev-util/lldb-4.0.0*
=sys-devel/clang-4.0.0*
Expand Down

0 comments on commit ac1ff58

Please sign in to comment.