Skip to content

Commit

Permalink
app-alternatives/bzip2: Add an ebuild for bzip2 symlinks
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
Signed-off-by: Sam James <[email protected]>
  • Loading branch information
mgorny authored and thesamesam committed Dec 1, 2022
1 parent e157412 commit ac69d44
Show file tree
Hide file tree
Showing 3 changed files with 78 additions and 0 deletions.
51 changes: 51 additions & 0 deletions app-alternatives/bzip2/bzip2-0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,51 @@
# Copyright 2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

DESCRIPTION="bzip2 symlink"
HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Base/Alternatives"
SRC_URI=""
S=${WORKDIR}

LICENSE="CC0-1.0"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
IUSE="lbzip2 pbzip2 +reference split-usr"
REQUIRED_USE="^^ ( lbzip2 pbzip2 reference )"

RDEPEND="
lbzip2? ( app-arch/lbzip2[-symlink(-)] )
pbzip2? ( app-arch/pbzip2[-symlink(-)] )
reference? ( >=app-arch/bzip2-1.0.8-r4 )
!<app-arch/bzip2-1.0.8-r4
!app-arch/lbzip2[symlink(-)]
!app-arch/pbzip2[symlink(-)]
"

src_install() {
local usr_prefix=
use split-usr && usr_prefix=../usr/bin/

if use lbzip2; then
dosym "${usr_prefix}lbzip2" /bin/bzip2
newman - bzip2.1 <<<".so lbzip2.1"
newman - bunzip2.1 <<<".so lbzip2.1"
newman - bzcat.1 <<<".so lbzip2.1"
elif use pbzip2; then
dosym "${usr_prefix}pbzip2" /bin/bzip2
newman - bzip2.1 <<<".so pbzip2.1"
newman - bunzip2.1 <<<".so pbzip2.1"
newman - bzcat.1 <<<".so pbzip2.1"
elif use reference; then
dosym bzip2-reference /bin/bzip2
newman - bzip2.1 <<<".so bzip2-reference.1"
newman - bunzip2.1 <<<".so bzip2-reference.1"
newman - bzcat.1 <<<".so bzip2-reference.1"
else
die "Invalid USE flag combination (broken REQUIRED_USE?)"
fi

dosym bzip2 /bin/bunzip2
dosym bzip2 /bin/bzcat
}
23 changes: 23 additions & 0 deletions app-alternatives/bzip2/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,23 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>[email protected]</email>
<name>Gentoo Base System</name>
</maintainer>
<maintainer type="person">
<email>[email protected]</email>
<name>Michał Górny</name>
</maintainer>
<use>
<flag name="lbzip2">
Symlink to <pkg>app-arch/lbzip2</pkg>.
</flag>
<flag name="pbzip2">
Symlink to <pkg>app-arch/pbzip2</pkg>.
</flag>
<flag name="reference">
Symlink to <pkg>app-arch/bzip2</pkg>.
</flag>
</use>
</pkgmetadata>
4 changes: 4 additions & 0 deletions profiles/arch/riscv/package.use.mask
Original file line number Diff line number Diff line change
@@ -1,6 +1,10 @@
# Copyright 2019-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

# Michał Górny <[email protected]> (2022-11-30)
# Mask unkeyworded providers.
app-alternatives/bzip2 pbzip2

# Yixun Lan <[email protected]> (2022-11-24)
# depend on dev-libs/libpcre2[jit] which not supported yet, bug #879511
www-servers/varnish jit
Expand Down

0 comments on commit ac69d44

Please sign in to comment.