Skip to content

Commit

Permalink
net-libs/http-parser: Version 2.8.1.
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.28, Repoman-2.3.9
  • Loading branch information
Jeroen Roovers committed Apr 11, 2018
1 parent c8b7cd9 commit acb36ba
Show file tree
Hide file tree
Showing 2 changed files with 36 additions and 0 deletions.
1 change: 1 addition & 0 deletions net-libs/http-parser/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST http-parser-2.6.2.tar.gz 48292 BLAKE2B 054ffa66960bad29a31e1a697a035447eb551fb85ed2af3786664f161d8d5a62aad8142ce859b7f1af85489b703b188d09980bf82b56cb190c21ecbe9c3a2f5c SHA512 e19e5377b3eb7f149c428196826fb878564fdfa3716ff6df5a3845c51586aee0582e252e09d1f8ebad1163b3e66632ff0c6e78f6acb2f0da20d7a06e734406c1
DIST http-parser-2.7.1.tar.gz 48578 BLAKE2B dcf67172b4b975543ca3b51bfce2b03f2b9b2dcc8c774322dfe41dd53a942f70f8f69cf69221ba76da249b22d6bee0aab6e6d887ea0a5e0f7350fa21c4091efb SHA512 c0fe86455db1a563a5c668f118dfa9a27b9a637ee1c0e2f2f18a5b816352436ed90435ea978e3f3d85b037d3c630234e47d609dc3b7086b898286c4e54d9f031
DIST http-parser-2.8.0.tar.gz 50575 BLAKE2B 0ea1973b452b62915ad2a92be95e09281c1aa2f152ff4a67580e99ab113b44544f98b2e33fa1fadb259144975f15dc69c8b0ecc9de59e603dbd0e0a0785b7976 SHA512 57252a29b75f91452fd9bf2d3805bf1ddd95c32aee864cbe47dc676861512b9db95a7b3a4e1b999d5c046ab0d50809e7f184994c24ad48fe97cc2bcc27d9eb7b
DIST http-parser-2.8.1.tar.gz 50731 BLAKE2B 1c4f3f61550f7f8e86d7b47e3986754a108dc979c6232d87ac418f9f8295b88ee43c4a5af150460f707e6ade01f5d435801f980ccbff93369ee0a9dc2eb60656 SHA512 6f52f543d979f39688ccefae236527a8183929b3d30f5370570107b01cf89d0338b448249a81102b78d31615d2e8f6e7c708f8961f55ece08e7d3a40e5ad0883
35 changes: 35 additions & 0 deletions net-libs/http-parser/http-parser-2.8.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,35 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit toolchain-funcs multilib-minimal

DESCRIPTION="Http request/response parser for C"
HOMEPAGE="https://github.com/nodejs/http-parser"
SRC_URI="https://github.com/nodejs/http-parser/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="MIT"
SLOT="0/2.8.0"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x64-macos ~x64-solaris"
IUSE="static-libs"

src_prepare() {
default
tc-export CC AR
multilib_copy_sources
}

multilib_src_compile() {
emake PREFIX="${EPREFIX}/usr" LIBDIR="${EPREFIX}/usr/$(get_libdir)" CFLAGS_FAST="${CFLAGS}" library
use static-libs && emake CFLAGS_FAST="${CFLAGS}" package
}

multilib_src_test() {
emake CFLAGS_DEBUG="${CFLAGS}" CFLAGS_FAST="${CFLAGS}" test
}

multilib_src_install() {
emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" LIBDIR="${EPREFIX}/usr/$(get_libdir)" install
use static-libs && dolib.a libhttp_parser.a
}

0 comments on commit acb36ba

Please sign in to comment.