forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-util/pycharm-professional: version bump to 2017.3.3
Closes: https://bugs.gentoo.org/642948
- Loading branch information
Showing
2 changed files
with
58 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST pycharm-professional-2017.3.1.tar.gz 355985604 BLAKE2B 9a1739972ce6d7a68f6f49554f62f20be3804fab24ceb7b0561ff0c4882f943e8373d38c3245030841ec3345b13dbf22a5fade66a07fae382a4dd5c29597c3cf SHA512 23d4a85714cca1763a987780eb20f5519a07ef1997e85c09b8ea57674bf6666f3ccedcd8c4d558813c44de397a4d8331e2fa9a357e056d4f3eea6b2b32195a62 | ||
DIST pycharm-professional-2017.3.3.tar.gz 356063034 BLAKE2B afe45081582983c05590602ed10b66ee687bd3ef4995bb0ae0404dddefe795ff8e93af2ac384ffa37600f2eebc882fa1bc6de8b6831341957ea69bda4e4632c3 SHA512 1e6d9fc1de13ecea5f4a2cf5bd9f2d7116a40802c24cf21ac731183d4b20aab480e34e039f1ca2fa36b4d873c85204febea975392d73da5a32f239037c7bd59e | ||
DIST pycharm-professional-2017.3.tar.gz 358504339 BLAKE2B 4ac1eb3feed289326a0122e3e4f869d7be740db1fd8d1c5f5c80400a8d8aa2daa444d4fa279c33865aecec4af4a28999e10b100714a44aa1d772d7f598ac05f4 SHA512 b7a085eda5d3e4ca8a918009f80cd7d90a281f2e522718211b4813f199a9c3a8f38f9742600336c09db479691c789d852ddc1d99e9ee2b11876e85728ae51b44 |
57 changes: 57 additions & 0 deletions
57
dev-util/pycharm-professional/pycharm-professional-2017.3.3.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,57 @@ | ||
# Copyright 1999-2018 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
|
||
inherit gnome2-utils readme.gentoo-r1 xdg | ||
|
||
DESCRIPTION="Intelligent Python IDE with unique code assistance and analysis" | ||
HOMEPAGE="http://www.jetbrains.com/pycharm/" | ||
SRC_URI="http://download.jetbrains.com/python/${P}.tar.gz" | ||
|
||
LICENSE="PyCharm_Academic PyCharm_Classroom PyCharm PyCharm_OpenSource PyCharm_Preview" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
|
||
RDEPEND=">=virtual/jre-1.8 | ||
dev-python/pip" | ||
|
||
RESTRICT="mirror strip" | ||
|
||
QA_PREBUILT="opt/${PN}/bin/fsnotifier | ||
opt/${PN}/bin/fsnotifier64 | ||
opt/${PN}/bin/fsnotifier-arm | ||
opt/${PN}/bin/libyjpagent-linux.so | ||
opt/${PN}/bin/libyjpagent-linux64.so" | ||
|
||
MY_PN=${PN/-professional/} | ||
S="${WORKDIR}/${MY_PN}-${PV}" | ||
|
||
src_prepare() { | ||
default | ||
|
||
rm -rf jre || die | ||
} | ||
|
||
src_install() { | ||
insinto /opt/${PN} | ||
doins -r * | ||
|
||
fperms a+x /opt/${PN}/bin/{pycharm.sh,fsnotifier{,64},inspect.sh} | ||
|
||
dosym ../../opt/${PN}/bin/pycharm.sh /usr/bin/${PN} | ||
newicon bin/${MY_PN}.png ${PN}.png | ||
make_desktop_entry ${PN} ${PN} ${PN} | ||
|
||
readme.gentoo_create_doc | ||
} | ||
|
||
pkg_postinst() { | ||
xdg_pkg_postinst | ||
gnome2_icon_cache_update | ||
} | ||
|
||
pkg_postrm() { | ||
xdg_pkg_postrm | ||
gnome2_icon_cache_update | ||
} |