forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Package-Manager: portage-2.2.24
- Loading branch information
Michael Sterrett
committed
Jan 4, 2016
1 parent
2d4446f
commit acc8e62
Showing
3 changed files
with
243 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST SDL2-2.0.3.tar.gz 3871267 SHA256 a5a69a6abf80bcce713fa873607735fe712f44276a7f048d60a61bb2f6b3c90c SHA512 b6d2485154fbc07ab86a4305485e116d35fac25a97033b9e1c65ee0eb8251a18209cb1de3a914d9c0ddc53aa1ffac66c865b111d218e79eb5a10ed00dfec7540 WHIRLPOOL d88658953cb668b8d4167b799b4a2e9b90a426fddd0cdddb4914420063e5768c609c2b4a954b50c14cbc5728894646db6bad0e5244ef6a563d4e2ec3da26298b | ||
DIST SDL2-2.0.4.tar.gz 4136230 SHA256 da55e540bf6331824153805d58b590a29c39d2d506c6d02fa409aedeab21174b SHA512 dd0a95878639856c0f4b8a579ace8071379ab64519fa139b22d3ed857a0f0db87a75bc8480c7207e02fbffd1fdbd448e3c0b882c451675b0e2f1a945af02e1d6 WHIRLPOOL 2203061d32d51552e5bcfaa9752de5cb3173c0c733698894de177f9a0c1bad73706633e2d232f9b893e4c3736a93aff00ae94eb044b19a05a1cdd7a4c030b574 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,89 @@ | ||
--- SDL2-2.0.4.orig/configure.in | ||
+++ SDL2-2.0.4/configure.in | ||
@@ -3114,7 +3114,7 @@ | ||
if test -f /lib/w32api/libuuid.a; then | ||
LIBUUID=/lib/w32api/libuuid.a | ||
else | ||
- LIBUUID=-luuid | ||
+ LIBUUID=-Wl,-luuid | ||
fi | ||
EXTRA_LDFLAGS="$EXTRA_LDFLAGS -luser32 -lgdi32 -lwinmm -limm32 -lole32 -loleaut32 -lshell32 -lversion $LIBUUID -static-libgcc" | ||
# The Windows platform requires special setup | ||
@@ -3464,23 +3464,23 @@ | ||
|
||
VERSION_OBJECTS=`echo $VERSION_SOURCES` | ||
VERSION_DEPENDS=`echo $VERSION_SOURCES` | ||
-VERSION_OBJECTS=`echo "$VERSION_OBJECTS" | sed 's,[[^ ]]*/\([[^ ]]*\)\.rc,$(objects)/\1.o,g'` | ||
+VERSION_OBJECTS=`echo "$VERSION_OBJECTS" | sed 's,[[^ ]]*/\([[^ ]]*\)\.rc,$(objects)/\1.lo,g'` | ||
VERSION_DEPENDS=`echo "$VERSION_DEPENDS" | sed "s,\\([[^ ]]*\\)/\\([[^ ]]*\\)\\.rc,\\\\ | ||
-\\$(objects)/\\2.o: \\1/\\2.rc\\\\ | ||
- \\$(WINDRES) \\$< \\$@,g"` | ||
+\\$(objects)/\\2.lo: \\1/\\2.rc\\\\ | ||
+ \\$(LIBTOOL) --mode=compile --tag=RC \\$(WINDRES) -i \\$< -o \\$@,g"` | ||
|
||
SDLMAIN_OBJECTS=`echo $SDLMAIN_SOURCES` | ||
SDLMAIN_DEPENDS=`echo $SDLMAIN_SOURCES` | ||
-SDLMAIN_OBJECTS=`echo "$SDLMAIN_OBJECTS" | sed 's,[[^ ]]*/\([[^ ]]*\)\.c,$(objects)/\1.o,g'` | ||
+SDLMAIN_OBJECTS=`echo "$SDLMAIN_OBJECTS" | sed 's,[[^ ]]*/\([[^ ]]*\)\.c,$(objects)/\1.lo,g'` | ||
SDLMAIN_DEPENDS=`echo "$SDLMAIN_DEPENDS" | sed "s,\\([[^ ]]*\\)/\\([[^ ]]*\\)\\.c,\\\\ | ||
-\\$(objects)/\\2.o: \\1/\\2.c\\\\ | ||
+\\$(objects)/\\2.lo: \\1/\\2.c\\\\ | ||
\\$(RUN_CMD_CC)\\$(LIBTOOL) --tag=CC --mode=compile \\$(CC) \\$(CFLAGS) \\$(EXTRA_CFLAGS) $DEPENDENCY_TRACKING_OPTIONS -c \\$< -o \\$@,g"` | ||
|
||
SDLTEST_OBJECTS=`echo $SDLTEST_SOURCES` | ||
SDLTEST_DEPENDS=`echo $SDLTEST_SOURCES` | ||
-SDLTEST_OBJECTS=`echo "$SDLTEST_OBJECTS" | sed 's,[[^ ]]*/\([[^ ]]*\)\.c,$(objects)/\1.o,g'` | ||
+SDLTEST_OBJECTS=`echo "$SDLTEST_OBJECTS" | sed 's,[[^ ]]*/\([[^ ]]*\)\.c,$(objects)/\1.lo,g'` | ||
SDLTEST_DEPENDS=`echo "$SDLTEST_DEPENDS" | sed "s,\\([[^ ]]*\\)/\\([[^ ]]*\\)\\.c,\\\\ | ||
-\\$(objects)/\\2.o: \\1/\\2.c\\\\ | ||
+\\$(objects)/\\2.lo: \\1/\\2.c\\\\ | ||
\\$(RUN_CMD_CC)\\$(LIBTOOL) --tag=CC --mode=compile \\$(CC) \\$(CFLAGS) \\$(EXTRA_CFLAGS) $DEPENDENCY_TRACKING_OPTIONS -c \\$< -o \\$@,g"` | ||
|
||
# Set runtime shared library paths as needed | ||
--- SDL2-2.0.4.orig/Makefile.in | ||
+++ SDL2-2.0.4/Makefile.in | ||
@@ -33,10 +33,10 @@ | ||
OBJECTS = @OBJECTS@ | ||
VERSION_OBJECTS = @VERSION_OBJECTS@ | ||
|
||
-SDLMAIN_TARGET = libSDL2main.a | ||
+SDLMAIN_TARGET = libSDL2main.la | ||
SDLMAIN_OBJECTS = @SDLMAIN_OBJECTS@ | ||
|
||
-SDLTEST_TARGET = libSDL2_test.a | ||
+SDLTEST_TARGET = libSDL2_test.la | ||
SDLTEST_OBJECTS = @SDLTEST_OBJECTS@ | ||
|
||
SRC_DIST = *.txt acinclude Android.mk autogen.sh android-project build-scripts cmake cmake_uninstall.cmake.in configure configure.in debian docs include Makefile.* sdl2-config.cmake.in sdl2-config.in sdl2.m4 sdl2.pc.in SDL2.spec.in src test VisualC.html VisualC VisualC-WinRT Xcode Xcode-iOS | ||
@@ -138,15 +138,13 @@ | ||
.PHONY: all update-revision install install-bin install-hdrs install-lib install-data uninstall uninstall-bin uninstall-hdrs uninstall-lib uninstall-data clean distclean dist $(OBJECTS:.lo=.d) | ||
|
||
$(objects)/$(TARGET): $(OBJECTS) $(VERSION_OBJECTS) | ||
- $(RUN_CMD_LTLINK)$(LIBTOOL) --tag=CC --mode=link $(CC) -o $@ $(OBJECTS) $(VERSION_OBJECTS) $(LDFLAGS) $(EXTRA_LDFLAGS) $(LT_LDFLAGS) | ||
+ $(RUN_CMD_LTLINK)$(LIBTOOL) --tag=CC --mode=link $(CC) $(CFLAGS) -o $@ $^ $(LDFLAGS) $(EXTRA_LDFLAGS) $(LT_LDFLAGS) | ||
|
||
$(objects)/$(SDLMAIN_TARGET): $(SDLMAIN_OBJECTS) | ||
- $(RUN_CMD_AR)$(AR) cru $@ $(SDLMAIN_OBJECTS) | ||
- $(RUN_CMD_RANLIB)$(RANLIB) $@ | ||
+ $(RUN_CMD_LTLINK)$(LIBTOOL) --tag=CC --mode=link $(CC) $(CFLAGS) -o $@ $^ $(LDFLAGS) $(EXTRA_LDFLAGS) $(LT_LDFLAGS) -all-static | ||
|
||
$(objects)/$(SDLTEST_TARGET): $(SDLTEST_OBJECTS) | ||
- $(RUN_CMD_AR)$(AR) cru $@ $(SDLTEST_OBJECTS) | ||
- $(RUN_CMD_RANLIB)$(RANLIB) $@ | ||
+ $(RUN_CMD_LTLINK)$(LIBTOOL) --tag=CC --mode=link $(CC) $(CFLAGS) -o $@ $^ $(LDFLAGS) $(EXTRA_LDFLAGS) $(LT_LDFLAGS) -all-static | ||
|
||
install: all install-bin install-hdrs install-lib install-data | ||
install-bin: | ||
@@ -167,10 +165,8 @@ | ||
install-lib: $(objects) $(objects)/$(TARGET) $(objects)/$(SDLMAIN_TARGET) $(objects)/$(SDLTEST_TARGET) | ||
$(SHELL) $(auxdir)/mkinstalldirs $(DESTDIR)$(libdir) | ||
$(LIBTOOL) --mode=install $(INSTALL) $(objects)/$(TARGET) $(DESTDIR)$(libdir)/$(TARGET) | ||
- $(INSTALL) -m 644 $(objects)/$(SDLMAIN_TARGET) $(DESTDIR)$(libdir)/$(SDLMAIN_TARGET) | ||
- $(RANLIB) $(DESTDIR)$(libdir)/$(SDLMAIN_TARGET) | ||
- $(INSTALL) -m 644 $(objects)/$(SDLTEST_TARGET) $(DESTDIR)$(libdir)/$(SDLTEST_TARGET) | ||
- $(RANLIB) $(DESTDIR)$(libdir)/$(SDLTEST_TARGET) | ||
+ $(LIBTOOL) --mode=install $(INSTALL) -m 644 $(objects)/$(SDLMAIN_TARGET) $(DESTDIR)$(libdir)/$(SDLMAIN_TARGET) | ||
+ $(LIBTOOL) --mode=install $(INSTALL) -m 644 $(objects)/$(SDLTEST_TARGET) $(DESTDIR)$(libdir)/$(SDLTEST_TARGET) | ||
install-data: | ||
$(SHELL) $(auxdir)/mkinstalldirs $(DESTDIR)$(datadir)/aclocal | ||
$(INSTALL) -m 644 $(srcdir)/sdl2.m4 $(DESTDIR)$(datadir)/aclocal/sdl2.m4 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,153 @@ | ||
# Copyright 1999-2015 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
# TODO: convert FusionSound #484250 | ||
|
||
EAPI=5 | ||
inherit autotools flag-o-matic toolchain-funcs eutils multilib-minimal | ||
|
||
MY_P=SDL2-${PV} | ||
DESCRIPTION="Simple Direct Media Layer" | ||
HOMEPAGE="http://www.libsdl.org" | ||
SRC_URI="http://www.libsdl.org/release/${MY_P}.tar.gz" | ||
|
||
LICENSE="ZLIB" | ||
SLOT="0" | ||
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc64 ~x86" | ||
|
||
IUSE="cpu_flags_x86_3dnow alsa altivec custom-cflags dbus fusionsound gles haptic +joystick cpu_flags_x86_mmx nas opengl oss pulseaudio +sound cpu_flags_x86_sse cpu_flags_x86_sse2 static-libs +threads tslib udev +video wayland X xinerama xscreensaver" | ||
REQUIRED_USE=" | ||
alsa? ( sound ) | ||
fusionsound? ( sound ) | ||
gles? ( video ) | ||
nas? ( sound ) | ||
opengl? ( video ) | ||
pulseaudio? ( sound ) | ||
xinerama? ( X ) | ||
xscreensaver? ( X )" | ||
|
||
RDEPEND=" | ||
alsa? ( >=media-libs/alsa-lib-1.0.27.2[${MULTILIB_USEDEP}] ) | ||
dbus? ( >=sys-apps/dbus-1.6.18-r1[${MULTILIB_USEDEP}] ) | ||
fusionsound? ( || ( >=media-libs/FusionSound-1.1.1 >=dev-libs/DirectFB-1.7.1[fusionsound] ) ) | ||
gles? ( >=media-libs/mesa-9.1.6[${MULTILIB_USEDEP},gles2] ) | ||
nas? ( >=media-libs/nas-1.9.4[${MULTILIB_USEDEP}] ) | ||
opengl? ( | ||
>=virtual/opengl-7.0-r1[${MULTILIB_USEDEP}] | ||
>=virtual/glu-9.0-r1[${MULTILIB_USEDEP}] | ||
) | ||
pulseaudio? ( >=media-sound/pulseaudio-2.1-r1[${MULTILIB_USEDEP}] ) | ||
tslib? ( >=x11-libs/tslib-1.0-r3[${MULTILIB_USEDEP}] ) | ||
udev? ( >=virtual/libudev-208:=[${MULTILIB_USEDEP}] ) | ||
wayland? ( | ||
>=dev-libs/wayland-1.0.6[${MULTILIB_USEDEP}] | ||
>=media-libs/mesa-9.1.6[${MULTILIB_USEDEP},wayland] | ||
>=x11-libs/libxkbcommon-0.2.0[${MULTILIB_USEDEP}] | ||
) | ||
X? ( | ||
>=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}] | ||
>=x11-libs/libXcursor-1.1.14[${MULTILIB_USEDEP}] | ||
>=x11-libs/libXext-1.3.2[${MULTILIB_USEDEP}] | ||
>=x11-libs/libXi-1.7.2[${MULTILIB_USEDEP}] | ||
>=x11-libs/libXrandr-1.4.2[${MULTILIB_USEDEP}] | ||
>=x11-libs/libXt-1.1.4[${MULTILIB_USEDEP}] | ||
>=x11-libs/libXxf86vm-1.1.3[${MULTILIB_USEDEP}] | ||
xinerama? ( >=x11-libs/libXinerama-1.1.3[${MULTILIB_USEDEP}] ) | ||
xscreensaver? ( >=x11-libs/libXScrnSaver-1.2.2-r1[${MULTILIB_USEDEP}] ) | ||
)" | ||
DEPEND="${RDEPEND} | ||
X? ( | ||
>=x11-proto/xextproto-7.2.1-r1[${MULTILIB_USEDEP}] | ||
>=x11-proto/xproto-7.0.24[${MULTILIB_USEDEP}] | ||
) | ||
virtual/pkgconfig" | ||
|
||
S=${WORKDIR}/${MY_P} | ||
|
||
src_prepare() { | ||
# https://bugzilla.libsdl.org/show_bug.cgi?id=1431 | ||
epatch "${FILESDIR}"/${P}-static-libs.patch | ||
sed -i -e 's/configure.in/configure.ac/' Makefile.in || die | ||
mv configure.{in,ac} || die | ||
AT_M4DIR="/usr/share/aclocal acinclude" eautoreconf | ||
} | ||
|
||
multilib_src_configure() { | ||
use custom-cflags || strip-flags | ||
|
||
# sorted by `./configure --help` | ||
ECONF_SOURCE="${S}" econf \ | ||
$(use_enable static-libs static) \ | ||
--enable-atomic \ | ||
$(use_enable sound audio) \ | ||
$(use_enable video) \ | ||
--enable-render \ | ||
--enable-events \ | ||
$(use_enable joystick) \ | ||
$(use_enable haptic) \ | ||
--enable-power \ | ||
--enable-filesystem \ | ||
$(use_enable threads) \ | ||
--enable-timers \ | ||
--enable-file \ | ||
--disable-loadso \ | ||
--enable-cpuinfo \ | ||
--enable-assembly \ | ||
$(use_enable cpu_flags_x86_sse ssemath) \ | ||
$(use_enable cpu_flags_x86_mmx mmx) \ | ||
$(use_enable cpu_flags_x86_3dnow 3dnow) \ | ||
$(use_enable cpu_flags_x86_sse sse) \ | ||
$(use_enable cpu_flags_x86_sse2 sse2) \ | ||
$(use_enable altivec) \ | ||
$(use_enable oss) \ | ||
$(use_enable alsa) \ | ||
--disable-alsa-shared \ | ||
--disable-esd \ | ||
$(use_enable pulseaudio) \ | ||
--disable-pulseaudio-shared \ | ||
--disable-arts \ | ||
$(use_enable nas) \ | ||
--disable-nas-shared \ | ||
--disable-sndio \ | ||
--disable-sndio-shared \ | ||
$(use_enable sound diskaudio) \ | ||
$(use_enable sound dummyaudio) \ | ||
$(use_enable wayland video-wayland) \ | ||
--disable-wayland-shared \ | ||
--disable-video-mir \ | ||
$(use_enable X video-x11) \ | ||
--disable-x11-shared \ | ||
$(use_enable X video-x11-xcursor) \ | ||
$(use_enable X video-x11-xdbe) \ | ||
$(use_enable xinerama video-x11-xinerama) \ | ||
$(use_enable X video-x11-xinput) \ | ||
$(use_enable X video-x11-xrandr) \ | ||
$(use_enable xscreensaver video-x11-scrnsaver) \ | ||
$(use_enable X video-x11-xshape) \ | ||
$(use_enable X video-x11-vm) \ | ||
--disable-video-cocoa \ | ||
--disable-video-directfb \ | ||
$(multilib_native_use_enable fusionsound) \ | ||
--disable-fusionsound-shared \ | ||
$(use_enable video video-dummy) \ | ||
$(use_enable opengl video-opengl) \ | ||
$(use_enable gles video-opengles) \ | ||
$(use_enable udev libudev) \ | ||
$(use_enable dbus) \ | ||
--disable-ibus \ | ||
$(use_enable tslib input-tslib) \ | ||
--disable-directx \ | ||
--disable-rpath \ | ||
--disable-render-d3d \ | ||
$(use_with X x) | ||
} | ||
|
||
multilib_src_install() { | ||
emake DESTDIR="${D}" install | ||
} | ||
|
||
multilib_src_install_all() { | ||
prune_libtool_files | ||
dodoc {BUGS,CREDITS,README,README-SDL,TODO,WhatsNew}.txt docs/README*.md | ||
} |