Skip to content

Commit

Permalink
app-admin/haskell-updater: bump up to 1.3.1
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.19, Repoman-2.3.6
  • Loading branch information
Sergei Trofimovich committed Dec 23, 2017
1 parent f1fcbab commit acdbea7
Show file tree
Hide file tree
Showing 2 changed files with 48 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-admin/haskell-updater/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST haskell-updater-1.2.10.tar.gz 26586 BLAKE2B adc46f85118fa55e530aa079ef2df0663b178b15311f4f2ff6474db75aacf1277238a27a2bb98841fc1fe50b556d7f01a677861b3ce9559fe809a02db401ef8d SHA512 c0a72ae77362e5ed4ea0e244449175454119b1284756adeb43534bf58b661f3cabb88e08bd5903d415a9f95a6de309753dedf974ddd853b300fd215250e0ad7c
DIST haskell-updater-1.2.12.tar.gz 26708 BLAKE2B d0b040cb3b6211b3c5c60f8cfa3dbccbf9cb15d246b21609a21aac746a8a034e284fe0b99891b5035980252a7aa8b376ad943f32882dc29e16226d95583cb053 SHA512 f3a993cb556919bf2e57fdaca7eea9146abc59096e779cbffb69a5c29fc5f6ef889c8ccf4d8331dbd9279919ea91bb05a16d83ad70085d5ef5a44d61120fe7e7
DIST haskell-updater-1.2.9.tar.gz 26675 BLAKE2B a3d11cdcee886a07d87cd2888a9deea1d963b7234b4a10a6b78e9467fae4e9382c92f14a6ba0593f86bf9422ab2cb4bec823de96f34b463590ae18429c118edb SHA512 d19b6154d5ef4da176638c237082586688e2ac73a41c075fc3e51979b86b9e48ca5a9bfe6c870d468d66d95c1464456feed8afc388aea282aa7aad5a35f5e0da
DIST haskell-updater-1.3.1.tar.gz 26573 BLAKE2B 68e5357e8f24b9b372dba4feac76595cbf35602d9d9094d616497c9d0040177b5f1def5833770041b693220717f3a4976877e0608858d5d8d4dddd26620c71e5 SHA512 39c36c4a8997806bb4d64625bc9ed72334a68e57f8c32f75d0c3704ab52b3b68605444c89480e5186c04bb275b3608ea9544366ebc5a00e010cc5fb4ae8296df
47 changes: 47 additions & 0 deletions app-admin/haskell-updater/haskell-updater-1.3.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,47 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

CABAL_FEATURES="bin nocabaldep"
inherit eutils haskell-cabal

DESCRIPTION="Rebuild Haskell dependencies in Gentoo"
HOMEPAGE="http://haskell.org/haskellwiki/Gentoo#haskell-updater"
SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
IUSE=""

DEPEND=">=dev-lang/ghc-6.12.1"

# Need a lower version for portage to get --keep-going
RDEPEND="|| ( >=sys-apps/portage-2.1.6
sys-apps/pkgcore
sys-apps/paludis )"

src_prepare() {
default

if use prefix; then
sed -i -e "s,/var/db/pkg,${EPREFIX}&,g" \
"${S}/Distribution/Gentoo/Packages.hs" || die

sed -i -e 's,"/","'"${EPREFIX}"'/",g' \
"${S}/Distribution/Gentoo/GHC.hs" || die
fi
}

src_configure() {
cabal_src_configure \
--bindir="${EPREFIX}/usr/sbin" \
--constraint="Cabal == $(cabal-version)"
}

src_install() {
cabal_src_install

dodoc TODO
}

0 comments on commit acdbea7

Please sign in to comment.