Skip to content

Commit

Permalink
dev-util/rizin: add 0.2.0
Browse files Browse the repository at this point in the history
Signed-off-by: John Helmert III <[email protected]>
  • Loading branch information
ajakk committed Apr 8, 2021
1 parent b70d9c2 commit ad165dd
Show file tree
Hide file tree
Showing 2 changed files with 64 additions and 0 deletions.
2 changes: 2 additions & 0 deletions dev-util/rizin/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,4 @@
DIST rizin-src-0.1.2.tar.xz 5559560 BLAKE2B a9182ae49782c57c3c4d4028203cfb1aef5b743096f4749a0ba65fa80ee421a23c3eb8a4f413f06f51c909c763a9bb06cb058cd334b3f4b0711ff72ee93c0df6 SHA512 f52987af5d1cd9f88a699610dfbb8118b23c5ce205c530a7b0c7481b06ee95a8e4d0d66297ca34c18e0b9366c963ea3244f37d66a7fda0ec6ffaa084f2ae7568
DIST rizin-src-v0.2.0.tar.xz 51438288 BLAKE2B 2db80b74cb1f40387e8d173fea19418d0a95be6a93acd5fb39da2fd51a0db6d77b20a7e8c551c461ce10ec2a39aa51958c238cd8dad7a357cd886804e87efa93 SHA512 d9522423110553e4b0ac80bfce6edd4b642a1df74e76b77ab23a7b13a37a37a3858ad294e14742a349265ed509345fb0277b910de6814eee3b970a6b9b344d12
DIST rizin-testbins-a80fd0d56d538d07a05ef01e29c8cb430a4f9d72.tar.gz 119214206 BLAKE2B 33916d466d77aaa0aeb6b221529a570a2bd2ad07b59b45967d75a84e3efbbc8ca3b8fff9cd88d61598b4e785ead2f8bc58eb7c1cb31007c27e497d80f36e4d2d SHA512 9b01a63ff281ac19b427e715d669e6080c4afdfd777ae762c30537c59bd2cdc2865adc1b34ccb61430b172e54995375b48bb35fd88f098b6a9839e9f3669fde4
DIST rizin-testbins-b7d6c0ec57eb1c14e970b8301f36cbac997ee695.tar.gz 116758002 BLAKE2B f30412c8b749de7e71e71b472ce1237091e71fac15d08e6ab5a3bcd9b87fbf75e347427cb588d18b62376040061f90b9b78016db689e46e5b32d3fd2aac6f1bf SHA512 94aca148dc2aaede66c63253717b3ee5f34b46dc8a634d7a3916786c97075c6eb9ee98af25c2af2778a601ade7cfb1d41ed3b11de36ddb74abc5f4eabef74ef3
62 changes: 62 additions & 0 deletions dev-util/rizin/rizin-0.2.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,62 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

# This is the commit that the CI for the release commit used
BINS_COMMIT="a80fd0d56d538d07a05ef01e29c8cb430a4f9d72"

inherit meson

DESCRIPTION="reverse engineering framework for binary analysis"
HOMEPAGE="https://rizin.re/"

SRC_URI="https://github.com/rizinorg/rizin/releases/download/v${PV}/rizin-src-v${PV}.tar.xz
test? ( https://github.com/rizinorg/rizin-testbins/archive/${BINS_COMMIT}.tar.gz -> rizin-testbins-${BINS_COMMIT}.tar.gz )"
KEYWORDS="~amd64 ~x86"

LICENSE="Apache-2.0 BSD LGPL-3 MIT"
SLOT="0"
IUSE="test"
RESTRICT="!test? ( test )"

RDEPEND="
sys-apps/file
app-arch/lz4:0=
dev-libs/capstone:0=
dev-libs/libuv:0=
dev-libs/libzip:0=
dev-libs/openssl:0=
dev-libs/tree-sitter
dev-libs/xxhash
sys-libs/zlib:0=
"
DEPEND="${RDEPEND}"

S="${WORKDIR}/${PN}-v${PV}"

src_prepare() {
default

if use test; then
mv "${WORKDIR}/rizin-testbins-${BINS_COMMIT}" "${S}/test/bins" || die
fi
}

src_configure() {
local emesonargs=(
-Dcli=enabled
-Duse_sys_capstone=enabled
-Duse_sys_magic=enabled
-Duse_sys_zip=enabled
-Duse_sys_zlib=enabled
-Duse_sys_lz4=enabled
-Duse_sys_xxhash=enabled
-Duse_sys_openssl=enabled
-Duse_sys_tree_sitter=enabled

$(meson_use test enable_tests)
$(meson_use test enable_rz_test)
)
meson_src_configure
}

0 comments on commit ad165dd

Please sign in to comment.