Skip to content

Commit

Permalink
dev-ruby/rdiscount: add 2.2.0.2
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.103, Repoman-2.3.23
Signed-off-by: Hans de Graaff <[email protected]>
  • Loading branch information
graaff committed Aug 10, 2020
1 parent c543521 commit ad329b9
Show file tree
Hide file tree
Showing 2 changed files with 48 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ruby/rdiscount/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST rdiscount-2.2.0.1.gem 68096 BLAKE2B 71ea7010116739e8c61aab91c2cc4a86cf679b4ae10221135c0bad854822a9a81969e927ef898c0ebf753811205ad98258c4e7c4b16f9e18a81bb01137a79fc9 SHA512 81a477782b9829ac5e68ab390ef00b7f470bb4bd84e86ce28dd9abbb71aab6fd17b67416078dd7d4e0fc7e0c8eb78250b7a71a2f24d2bd236e861cb445f9feb6
DIST rdiscount-2.2.0.2.gem 68096 BLAKE2B 91f67643103a46f3fc95f80191a85ce4c89bba6a83f7ed5542cc9ec1671628c6ac0543b206d87e2ffc469dc83139e5669ee7eb6713eba4116db19c071a15f402 SHA512 97a0fabb77238173f101298e4b4b6d4728b9e15cb7d3f14e7d1d978c44ab92dd89c2e02d0c15c0fa70a836eb54abca06b0027e26e5d87540bfe145c8527be3f7
47 changes: 47 additions & 0 deletions dev-ruby/rdiscount/rdiscount-2.2.0.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,47 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

USE_RUBY="ruby25 ruby26 ruby27"

RUBY_FAKEGEM_TASK_TEST="test:unit"

RUBY_FAKEGEM_TASK_DOC="doc man"
RUBY_FAKEGEM_EXTRADOC="README.markdown"

inherit multilib ruby-fakegem

DESCRIPTION="Implementation of John Gruber's Markdown"
HOMEPAGE="https://github.com/rtomayko/rdiscount"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
IUSE=""

all_ruby_prepare() {
# Hanna is broken for us and therefore we don't have it in portage.
sed -i -e 's/hanna/rdoc/' Rakefile || die

# Remove rule that will force a rebuild when running tests.
sed -i -e "/task 'test:unit' => \[:build\]/d" Rakefile || die

# Provide RUBY variable no longer provided by rake.
sed -i -e "1 iRUBY=${RUBY}" Rakefile || die
}

each_ruby_configure() {
${RUBY} -Cext extconf.rb || die
}

each_ruby_compile() {
emake V=1 -Cext
cp ext/*$(get_modname) lib/ || die
}

all_ruby_install() {
all_fakegem_install

doman man/rdiscount.1
}

0 comments on commit ad329b9

Please sign in to comment.