Skip to content

Commit

Permalink
dev-scheme/guile: fixes for bug #590528,#590660
Browse files Browse the repository at this point in the history
- Added patch for built_includes by upstream Andy Wingo
- Symlink path changed

Package-Manager: portage-2.2.28
  • Loading branch information
Amynka committed Aug 7, 2016
1 parent 35ad4d2 commit ad481ad
Show file tree
Hide file tree
Showing 2 changed files with 43 additions and 1 deletion.
41 changes: 41 additions & 0 deletions dev-scheme/guile/files/guile-2.0.12-build-includes.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,41 @@
From edd6d6e2805894e21afe51276d1af65d5395180d Mon Sep 17 00:00:00 2001
From: Andy Wingo <[email protected]>
Date: Sun, 07 Aug 2016 10:23:50 +0000
Subject: Snarfing .x depends on built headers

* libguile/Makefile.am (BUILT_INCLUDES): New variable.
(BUILT_SOURCES): Put .i and other generated .h to BUILT_INCLUDES.
(.c.x, .c.doc): Depend on BUILT_INCLUDES. Fixes
https://bugs.gentoo.org/show_bug.cgi?id=590528.
---
diff --git a/libguile/Makefile.am b/libguile/Makefile.am
index cd85604..4c54744 100644
--- a/libguile/Makefile.am
+++ b/libguile/Makefile.am
@@ -430,9 +430,9 @@ DOT_I_FILES = vm-i-system.i vm-i-scheme.i vm-i-loader.i
.c.i:
$(AM_V_GEN)$(GREP) '^VM_DEFINE' $< > $@

-BUILT_SOURCES = cpp-E.c cpp-SIG.c libpath.h \
- scmconfig.h \
- $(DOT_I_FILES) $(DOT_X_FILES) $(EXTRA_DOT_X_FILES)
+BUILT_INCLUDES = $(DOT_I_FILES) scmconfig.h
+BUILT_SOURCES = cpp-E.c cpp-SIG.c libpath.h $(BUILT_INCLUDES) \
+ $(DOT_X_FILES) $(EXTRA_DOT_X_FILES)

# Force the generation of `guile-procedures.texi' because the top-level
# Makefile expects it to be built.
@@ -730,9 +730,9 @@ snarfcppopts = $(DEFS) $(AM_CPPFLAGS) $(CPPFLAGS) $(CFLAGS)

SUFFIXES = .x .doc

-.c.x:
+.c.x: $(BUILT_INCLUDES)
$(AM_V_SNARF)$(GUILE_SNARF) -o $@ $< $(snarfcppopts)
-.c.doc:
+.c.doc: $(BUILT_INCLUDES)
$(AM_V_SNARF)./guile-snarf-docs -o $@ $< -- $(snarfcppopts)

$(DOT_X_FILES) $(EXTRA_DOT_X_FILES): scmconfig.h snarf.h guile-snarf.in version.h
--
cgit v0.9.0.2
3 changes: 2 additions & 1 deletion dev-scheme/guile/guile-2.0.12.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -30,6 +30,7 @@ DEPEND="${RDEPEND}
SLOT="12"
MAJOR="2.0"

PATCHES=( "${FILESDIR}/${P}-build-includes.patch" ) #bug 590528 patched by upstream
DOCS=( GUILE-VERSION HACKING README )

src_configure() {
Expand Down Expand Up @@ -67,7 +68,7 @@ src_install() {
keepdir /usr/share/guile/site

# Dark magic necessary for some deps
dosym /usr/$(get_libdir)/libguile-2.0.so /usr/$(get_libdir)/libguile.so
dosym libguile-2.0.so /usr/$(get_libdir)/libguile.so
}

pkg_postinst() {
Expand Down

0 comments on commit ad481ad

Please sign in to comment.