Skip to content

Commit

Permalink
app-emulation/cri-tools: 1.18.0 bump
Browse files Browse the repository at this point in the history
Signed-off-by: William Hubbs <[email protected]>
  • Loading branch information
williamh committed Apr 1, 2020
1 parent 99f4e65 commit ad7119e
Show file tree
Hide file tree
Showing 2 changed files with 33 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-emulation/cri-tools/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST cri-tools-1.14.0.tar.gz 3647742 BLAKE2B 1a308c87e7be05dd71cf11d79c841a837156529d398f1475323ff9585f9080cd0356a007f8b8c505a02943ff479a7c26869f35288d178ac8187ca6766032c488 SHA512 c8978e4380ebb2dd59ce533ade94486ae1e4091fda7acd8cf5cce662034a1d34a1851c43bf766a723c5ba71c15972733a2e80c6e82fb1c27e5a1dfc2e85476bf
DIST cri-tools-1.15.0.tar.gz 3672568 BLAKE2B d4e9a0b2ca43efdb61c7626de518801a124fb61991f1df6a7eac106f7516ab59effa70038db7c4cbfddaf1c345c648f359c86d298dae08abb34f4b801b82b2a1 SHA512 43115fad485c2c6603e724f3529371133bcea6de069dc58d36e7880f558fa1696244b6129fe3a96fd669b27a3d9bd07bda1219e89afa348e36a85087992adf7f
DIST cri-tools-1.16.1.tar.gz 6915584 BLAKE2B eb2bc397b3bbeadb64d4d13610189f18bbf49ff93be1b1f3edf504305ed1a2ca8e271d3c041f5af01117f6c7403671a29df30d7aaab270cdb7ab84ac921fa914 SHA512 df15e6f3c4fe697070547d804bfa6755f780b3f0562f06312f39d3ee8756931bbec7c07482e2ef73413d85c1e9ca58064a769a15b04b3832da17044d180e8b4c
DIST cri-tools-1.18.0.tar.gz 5295512 BLAKE2B 9dda4a401b858e98aa60521d3268d8f6ff6a2c1bd2c219a0e5e9e5360fba58d41e97258c636da26ee57bbfc3286798c74107c7de92d3e3398bdf53b7d9078e94 SHA512 849b496e6d19eec29e0e56f0b37c094649311b80514f319b0c68c6519e3ddd48e1973c3d288144db998826676416644ec705b7ea0916c21898b40928ea800af1
32 changes: 32 additions & 0 deletions app-emulation/cri-tools/cri-tools-1.18.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,32 @@
# Copyright 2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
inherit bash-completion-r1 go-module
MY_PV="v${PV/_beta/-beta.}"

DESCRIPTION="CLI and validation tools for Kubelet Container Runtime (CRI)"
HOMEPAGE="https://github.com/kubernetes-sigs/cri-tools"
SRC_URI="https://github.com/kubernetes-sigs/cri-tools/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"

LICENSE="Apache-2.0 BSD BSD-2 CC-BY-SA-4.0 ISC MIT MPL-2.0"
SLOT="0"
KEYWORDS="~amd64"

RESTRICT+=" test"

src_compile() {
emake VERSION="${MY_PV}"
_output/crictl completion bash > ${PN}.bash || die
_output/crictl completion zsh > ${PN}.zsh || die
}

src_install() {
dobin _output/crictl

newbashcomp ${PN}.bash ${PN}
insinto /usr/share/zsh/site-functions
newins ${PN}.zsh _${PN}

dodoc -r docs {README,RELEASE,CHANGELOG,CONTRIBUTING}.md
}

0 comments on commit ad7119e

Please sign in to comment.