Skip to content

Commit

Permalink
sys-process/criu: version bump 2.10
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.3, Repoman-2.3.1
  • Loading branch information
dlan17 committed Jan 19, 2017
1 parent aeb5bb4 commit ada359c
Show file tree
Hide file tree
Showing 2 changed files with 97 additions and 0 deletions.
1 change: 1 addition & 0 deletions sys-process/criu/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST criu-2.10.tar.bz2 640205 SHA256 05359b9def8abfc5967911325791a93468ce889f0f489949f925b371c143260d SHA512 6e59ff8a97297583b9f7d31492f0ac59e217fe6372253584db7f9409a4d890104feb9caac663b17d036c39eb79621be6000a7d5e814b65ce5d151e0a053d324b WHIRLPOOL 6d9dbd92941122256041dfe9f8d3c42e125808845904135631758a8474f10488c29f7881ecf56e05c6b8ba2baf7c4749eb3e17e1f9b510f37ded58741fcf2753
DIST criu-2.5.tar.bz2 605226 SHA256 d2a9ffec0b659c3d3a71e1d473e95e36b208b2563f136ce8f471ff9600fcc51a SHA512 ccf942005ff3b2a567726ddb8aa44048c130f1adf6e2cbdf48e919043c84a4e1c03ad0ec34b44263e5764bea62807a2cc0fa1135b929ad3166fb9486c2880570 WHIRLPOOL 9896fe45d4516a73e6b7c403a044d25902ed4a9000b0a0a053ff9d52c053adfb58c8ce0225b9841bc7e2f38de6a8e4fc6d3073d878ea5b09b81cc89cba91de62
DIST criu-2.6.tar.bz2 614488 SHA256 b85b50296175b1751fa2b26936cbcf5041d08a9fb49c32cb0f2b590e82dea322 SHA512 37c5a207803213e4a98c2ea1b8f781f6bee2d7fb3c004fae4db5c56c64f61ff3177ad3fb314d1225cab4723e05900f55fc4ab466c11e7c9f9a4921634bbf90c5 WHIRLPOOL 5443c16af70b383d935318a9c15f9359d4f69de272533c0f713a2015718dec6f64cad59173664458a0fffc224a8f47b3c846d8cb66ce813f59ba6c32177effa4
DIST criu-2.7.tar.bz2 618653 SHA256 c9aae64a4d2a6e881225ec14a00527aef228171a11227034b6322c126c2ece04 SHA512 fb80c3d48116489775e23231e93e6385614b57bd3710a2650c540090c3f2464d3a337a43c2d1f6e6a3d1360ca09adaa76cb6298f411add5fba998f3c3a323ed9 WHIRLPOOL 01c5d190691839e1123bc48da6c9add76bab0b6fdb87e840555b92833a9d8605c895fe9f0e6595c7d289d02955ae05b3933fa92a50b73d5b755f304321c4ec8a
Expand Down
96 changes: 96 additions & 0 deletions sys-process/criu/criu-2.10.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,96 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

PYTHON_COMPAT=( python2_7 )

inherit eutils toolchain-funcs linux-info flag-o-matic python-r1 python-utils-r1

DESCRIPTION="utility to checkpoint/restore a process tree"
HOMEPAGE="http://criu.org/"
SRC_URI="http://download.openvz.org/criu/${P}.tar.bz2"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64"
IUSE="python setproctitle"

RDEPEND="dev-libs/protobuf-c
dev-libs/libnl:3
net-libs/libnet:1.1
sys-libs/libcap
python? ( ${PYTHON_DEPS} )
setproctitle? ( dev-libs/libbsd )"
DEPEND="${RDEPEND}
app-text/asciidoc
app-text/xmlto"
RDEPEND="${RDEPEND}
python? (
dev-libs/protobuf[python,${PYTHON_USEDEP}]
dev-python/ipaddr[${PYTHON_USEDEP}]
)"

CONFIG_CHECK="~CHECKPOINT_RESTORE ~NAMESPACES ~PID_NS ~FHANDLE ~EVENTFD ~EPOLL ~INOTIFY_USER
~IA32_EMULATION ~UNIX_DIAG ~INET_DIAG ~INET_UDP_DIAG ~PACKET_DIAG ~NETLINK_DIAG"

RESTRICT="test"

PATCHES=(
"${FILESDIR}"/2.2/${PN}-2.2-flags.patch
"${FILESDIR}"/2.3/${PN}-2.3-no-git.patch
"${FILESDIR}"/${PN}-2.8-automagic-libbsd.patch
"${FILESDIR}"/2.0/${PN}-2.0-sysroot.patch
"${FILESDIR}"/2.3/${PN}-2.3-aarch64.patch
)

criu_arch() {
# criu infers the arch from $(uname -m). We never want this to happen.
case ${ARCH} in
amd64) echo "x86";;
arm64) echo "aarch64";;
*) echo "${ARCH}";;
esac
}

src_compile() {
RAW_LDFLAGS="$(raw-ldflags)" emake \
CC="$(tc-getCC)" \
LD="$(tc-getLD)" \
OBJCOPY="$(tc-getOBJCOPY)" \
LIBDIR="${EPREFIX}/usr/$(get_libdir)" \
ARCH="$(criu_arch)" \
V=1 WERROR=0 DEBUG=0 \
SETPROCTITLE=$(usex setproctitle) \
PYCRIU=$(usex python) \
all docs
}

src_test() {
# root privileges are required to dump all necessary info
if [[ ${EUID} -eq 0 ]] ; then
emake -j1 CC="$(tc-getCC)" ARCH="$(criu_arch)" V=1 WERROR=0 test
fi
}

install_crit() {
"${PYTHON:-python}" ../scripts/crit-setup.py install --root="${D}" --prefix="${EPREFIX}/usr/"
}

src_install() {
emake \
ARCH="$(criu_arch)" \
PREFIX="${EPREFIX}"/usr \
LOGROTATEDIR="${EPREFIX}"/etc/logrotate.d \
DESTDIR="${D}" \
LIBDIR="${EPREFIX}/usr/$(get_libdir)" \
install

dodoc CREDITS README.md

if use python ; then
cd lib
python_foreach_impl install_crit
fi
}

0 comments on commit ada359c

Please sign in to comment.