Skip to content

Commit

Permalink
app-emulation/ski: tweak for binutils-2.34
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.86, Repoman-2.3.20
Signed-off-by: Sergei Trofimovich <[email protected]>
  • Loading branch information
Sergei Trofimovich committed Feb 1, 2020
1 parent 5e79139 commit adaca90
Show file tree
Hide file tree
Showing 2 changed files with 26 additions and 0 deletions.
22 changes: 22 additions & 0 deletions app-emulation/ski/files/ski-1.3.2-binutils-2.34.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,22 @@
diff --git a/src/linux/dwarf-linux.c b/src/linux/dwarf-linux.c
index 73be0e6..c4051a3 100644
--- a/src/linux/dwarf-linux.c
+++ b/src/linux/dwarf-linux.c
@@ -116,14 +116,14 @@ find_in_section (bfd * bfd, asection * sect, PTR obj)
/*
* we're looking at loadable code only
*/
- if ((bfd_get_section_flags (bfd, sect) & (SEC_CODE | SEC_ALLOC)) == 0)
+ if ((bfd_section_flags (sect) & (SEC_CODE | SEC_ALLOC)) == 0)
return;

/*
* check if address belongs to this section
*/
- vma = bfd_get_section_vma (bfd, sect);
- size = bfd_section_size (bfd, sect);
+ vma = bfd_section_vma (sect);
+ size = bfd_section_size (sect);

offset = info->address - vma;
if (offset >= size)
4 changes: 4 additions & 0 deletions app-emulation/ski/ski-1.3.2-r3.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -44,6 +44,10 @@ PATCHES=(
src_prepare() {
default

if has_version ">=sys-libs/binutils-libs-2.34"; then
eapply "${FILESDIR}"/${PN}-1.3.2-binutils-2.34.patch
fi

rm -rf libltdl src/ltdl.[ch] macros/ltdl.m4

AT_M4DIR="macros" eautoreconf
Expand Down

0 comments on commit adaca90

Please sign in to comment.