Skip to content

Commit

Permalink
dev-python/jq: Initial import
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.18, Repoman-3.0.3
Signed-off-by: Zac Medico <[email protected]>
  • Loading branch information
zmedico committed Apr 24, 2021
1 parent dd069eb commit adb3aa1
Show file tree
Hide file tree
Showing 3 changed files with 45 additions and 0 deletions.
3 changes: 3 additions & 0 deletions dev-python/jq/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1,3 @@
DIST jq-1.1.2.tar.gz 70638 BLAKE2B c22db8ebfbe74382c3b4ccda1a13c1758e5aa195c0c9f3192f1220f8948fe4747d3f83b7448089b96a9fa3a2f4167cf50b43901beabf468abb786f2a29b3b984 SHA512 5046bd61135e7547c345f2e89ee2af2f64bd370ee39e301b62c8fd9d299590305e0f9f7f6e0307f59fc6b7eb05659df82eb5bd0a162985e615eaa8d79bef58e2
DIST jq-1.6.tar.gz 1750584 BLAKE2B c9be1314e9d027247de63492ee362e996ef85faf45a47ee421cad95ebde9188bff8d3fc7db64e717ab922e1052f3b1c1500f5589fc5b2199ab66effb000e442d SHA512 5da71f53c325257f1f546a2520fe47828b495c953270df25ea0e37741463fdda72f0ba4d5b05b25114ec30f27a559344c2b024bacabf610759f4e3e9efadb480
DIST onig-6.9.4.tar.gz 908702 BLAKE2B e6e9939f284569408ba01b8551960bc939bbfdca425f8470499f5bb83ead7b6b09898f6f6a09d5d8c26d74d5416f6e5e9e2f00fbe7aa9eb820edb8aa4a3050cc SHA512 ed8f42f6893966c0ee3c168b4fdbcb04b2286ad69ecab43a754c1dbc8fc4656e01319991d776d7144b6a3f90d050781b321432278d83c74c9565c2743851c85b
30 changes: 30 additions & 0 deletions dev-python/jq/jq-1.1.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,30 @@
# Copyright 2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python3_{7..9} )

inherit distutils-r1

DESCRIPTION="Python bindings for jq"
HOMEPAGE="https://github.com/mwilliamson/jq.py"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
https://github.com/stedolan/jq/releases/download/jq-1.6/jq-1.6.tar.gz
https://github.com/kkos/oniguruma/releases/download/v6.9.4/onig-6.9.4.tar.gz"

LICENSE="BSD-2"
SLOT="0"
KEYWORDS="~amd64"
IUSE=""

BDEPEND="dev-python/cython[${PYTHON_USEDEP}]"

python_prepare_all() {
sed -e 's|import requests|#\0|' \
-e 's|urlretrieve(source_url, tarball_path)|shutil.copyfile(source_url, tarball_path)|' \
-e "s|source_url=.*kkos/oniguruma.*|source_url=\"${DISTDIR}/onig-6.9.4.tar.gz\",|" \
-e "s|source_url=.*stedolan/jq.*|source_url=\"${DISTDIR}/jq-1.6.tar.gz\",|" \
-i setup.py || die
distutils-r1_python_prepare_all
}
12 changes: 12 additions & 0 deletions dev-python/jq/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,12 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>[email protected]</email>
<name>Zac Medico</name>
</maintainer>
<upstream>
<remote-id type="github">mwilliamson/jq.py</remote-id>
<remote-id type="pypi">jq</remote-id>
</upstream>
</pkgmetadata>

0 comments on commit adb3aa1

Please sign in to comment.