Skip to content

Commit

Permalink
app-arch/engrampa: Version bump to 1.14.1
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.0
  • Loading branch information
NP-Hardass authored and mudler committed Nov 21, 2016
1 parent 525511c commit adc6522
Show file tree
Hide file tree
Showing 2 changed files with 77 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-arch/engrampa/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST engrampa-1.10.2.tar.xz 1378888 SHA256 964bf6fd8463b378e3bdd7713e86eca9dd65f1a6d99e10bb59cb2185084f986b SHA512 86772801d80584c4020fce63cde11478a914372598f3c41774f4248817a05e37eb72842cd2f88be81c22969452f33806738d94a872ffe4ca8743fe8a9c115e1d WHIRLPOOL db2824550840296b636ea48ac987e004184d9cc41c669f0f2c30b67da8ebd6e991d5e27a55a5691c004cce4df26fb101318420d67f20015af55b6f5521525891
DIST engrampa-1.12.0.tar.xz 1380144 SHA256 4f1f8b0829000f6bb2d8a53a8da098dc5b177638c6d8e5b3fb52402a4541759c SHA512 8c694b1f1baab099316f6e5d5ec67ae95171df3a988aee11b0527ae797717e7b3e57fa1ec53cb78e9aa397b1758f768736231ad1bd91c1bb8b2ba2f8f755cfec WHIRLPOOL b1132440b2d02fd2bfa9c903794113cf7d36eb7e67b4dc3222635dc7c33c459a87885ce1ec7bcdc623db8c75a6d33015ade6faaf3cfa8fd85fc85631d87366da
DIST engrampa-1.14.1.tar.xz 1417444 SHA256 43d882e772c53d13856f02e44454927e3bab4c5d77094057572be6972e0310d8 SHA512 fea510d95fe483f676f66490706aa919b6a62bc20af9e22893304235ce0a38ff006c66494d548a3207dc4cd241cb785abe77652693d1b600e4ca6c8a0a60d763 WHIRLPOOL 6793b07c57d91ce73c102fc59b4e18141532f895814b4879547b10db4dec24029185d944cce5f34e8a880e9da2a2e229dfc44cf3d6d95ae264b2207ddcbedb8c
76 changes: 76 additions & 0 deletions app-arch/engrampa/engrampa-1.14.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,76 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

MATE_LA_PUNT="yes"

inherit mate

if [[ ${PV} != 9999 ]]; then
KEYWORDS="~amd64 ~arm ~x86"
fi

DESCRIPTION="Engrampa archive manager for MATE"
LICENSE="GPL-2"
SLOT="0"

IUSE="caja gtk3 magic packagekit"

COMMON_DEPEND="
>=dev-libs/glib-2.32.0:2
>=dev-libs/json-glib-0.14:0
x11-libs/gdk-pixbuf:2
x11-libs/pango:0
virtual/libintl:0
caja? ( >=mate-base/caja-1.8[gtk3(-)=] )
!gtk3? ( >=x11-libs/gtk+-2.24.0:2 )
gtk3? ( >=x11-libs/gtk+-3.0:3 )
magic? ( sys-apps/file )
packagekit? ( app-admin/packagekit-base )
!!app-arch/mate-file-archiver"

RDEPEND="${COMMON_DEPEND}"

DEPEND="${COMMON_DEPEND}
>=dev-util/intltool-0.50.1:*
dev-util/itstool:0
sys-devel/gettext:*
virtual/pkgconfig:*"

PATCHES=( "${FILESDIR}/${PN}-1.10.2-p7zip-15.14-compat.patch" )

src_configure() {
mate_src_configure \
--disable-run-in-place \
--disable-deprecations \
--with-gtk=$(usex gtk3 3.0 2.0) \
$(use_enable caja caja-actions) \
$(use_enable magic) \
$(use_enable packagekit)
}

pkg_postinst() {
mate_pkg_postinst

elog ""
elog "${PN} is a frontend for several archiving utilities. If you want a"
elog "particular achive format supported install the relevant package."
elog
elog "For example:"
elog " 7-zip : emerge app-arch/p7zip"
elog " ace : emerge app-arch/unace"
elog " arj : emerge app-arch/arj"
elog " cpio : emerge app-arch/cpio"
elog " deb : emerge app-arch/dpkg"
elog " iso : emerge app-cdr/cdrtools"
elog " jar,zip : emerge app-arch/zip or emerge app-arch/unzip"
elog " lha : emerge app-arch/lha"
elog " lzma : emerge app-arch/xz-utils"
elog " lzop : emerge app-arch/lzop"
elog " rar : emerge app-arch/unrar"
elog " rpm : emerge app-arch/rpm"
elog " unstuff : emerge app-arch/stuffit"
elog " zoo : emerge app-arch/zoo"
}

0 comments on commit adc6522

Please sign in to comment.