forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-ada/ada_language_server: Language Server for Ada/SPARK
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Alfredo Tupone <[email protected]>
- Loading branch information
Showing
3 changed files
with
67 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1 @@ | ||
DIST ada_language_server-22.0.0.tar.gz 791594 BLAKE2B 9effdf8376e00fe838be7b53c5756dc0d325e36eae780642d79483d6fcead9019cab41e228fe2313d6f31e06895e2d41feef194cb24ac50f02d6dd066774b642 SHA512 ef4bdf41315aad09750e85521657aefaaee419739aac4dec6e182691b8b5282face19481a113e710f7c4b21f6e6f51296d1872aaf5c1c3ab19b6774d142c021c |
56 changes: 56 additions & 0 deletions
56
dev-ada/ada_language_server/ada_language_server-22.0.0.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,56 @@ | ||
# Copyright 2021 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
ADA_COMPAT=( gnat_202{0,1} ) | ||
inherit ada multiprocessing | ||
|
||
DESCRIPTION="an implementation of the Microsoft Language Server Protocol for Ada/SPARK" | ||
HOMEPAGE="https://github.com/AdaCore/ada_language_server" | ||
SRC_URI="https://github.com/AdaCore/${PN}/archive/refs/tags/v${PV}.tar.gz | ||
-> ${P}.tar.gz" | ||
IUSE="test" | ||
RESTRICT="!test? ( test )" | ||
|
||
LICENSE="GPL-3" | ||
SLOT="0" | ||
KEYWORDS="~amd64" | ||
|
||
RDEPEND="${ADA_DEPS} | ||
dev-ada/ada_libfswatch[${ADA_USEDEP}] | ||
dev-ada/gnatcoll-core[${ADA_USEDEP},shared] | ||
dev-ada/libadalang[${ADA_USEDEP}] | ||
dev-ada/libadalang-tools[${ADA_USEDEP},shared] | ||
dev-ada/spawn[${ADA_USEDEP},shared] | ||
dev-ada/VSS[${ADA_USEDEP}]" | ||
DEPEND="${RDEPEND}" | ||
BDEPEND="dev-ada/gprbuild[${ADA_USEDEP}] | ||
test? ( dev-ada/e3-testsuite )" | ||
|
||
REQUIRED_USE="${ADA_REQUIRED_USE}" | ||
|
||
src_compile() { | ||
gprbuild -v -j$(makeopts_jobs) -P gnat/tester.gpr -p \ | ||
-XLIBRARY_TYPE=relocatable \ | ||
-cargs:Ada ${ADAFLAGS} || die | ||
gprbuild -v -j$(makeopts_jobs) -c -u -P gnat/lsp_server.gpr -p \ | ||
-XLIBRARY_TYPE=relocatable s-memory.adb \ | ||
-cargs:Ada ${ADAFLAGS} || die | ||
gprbuild -v -j$(makeopts_jobs) -P gnat/lsp_server.gpr -p \ | ||
-XLIBRARY_TYPE=relocatable -XVERSION= \ | ||
-cargs:Ada ${ADAFLAGS} || die | ||
gprbuild -v -j$(makeopts_jobs) -P gnat/codec_test.gpr -p \ | ||
-XLIBRARY_TYPE=relocatable \ | ||
-cargs:Ada ${ADAFLAGS} || die | ||
gprbuild -v -j$(makeopts_jobs) -P gnat/lsp_client.gpr -p \ | ||
-XLIBRARY_TYPE=relocatable \ | ||
-cargs:Ada ${ADAFLAGS} || die | ||
mkdir -p integration/vscode/ada/linux | ||
cp -f .obj/server/ada_language_server integration/vscode/ada/linux || die | ||
} | ||
|
||
src_install() { | ||
emake install DESTDIR="${D}"/usr | ||
einstalldocs | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,10 @@ | ||
<?xml version="1.0" encoding="UTF-8"?> | ||
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd"> | ||
<pkgmetadata> | ||
<maintainer type="project"> | ||
<email>[email protected]</email> | ||
</maintainer> | ||
<upstream> | ||
<remote-id type="github">adacore/ada_language_server</remote-id> | ||
</upstream> | ||
</pkgmetadata> |