Skip to content

Commit

Permalink
dev-libs/rlog: Port to EAPI 6
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.19, Repoman-2.3.6
  • Loading branch information
SoapGentoo committed Dec 31, 2017
1 parent 395bfd3 commit ae1c756
Show file tree
Hide file tree
Showing 3 changed files with 76 additions and 8 deletions.
4 changes: 2 additions & 2 deletions dev-libs/rlog/files/rlog-1.3.7-gcc-4.3.patch
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
--- rlog/RLogChannel.cpp
+++ rlog/RLogChannel.cpp
--- a/rlog/RLogChannel.cpp
+++ b/rlog/RLogChannel.cpp
@@ -20,6 +20,7 @@
#include "RLogChannel.h"
#include "rlog.h"
Expand Down
59 changes: 59 additions & 0 deletions dev-libs/rlog/files/rlog-1.4-fix-build-system.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,59 @@
--- a/docs/Makefile.am
+++ b/docs/Makefile.am
@@ -1,15 +1,13 @@

SOURCES = index.dox channel.dox component.dox

-docdir = $(datadir)/doc
-pkgdocdir = $(docdir)/$(PACKAGE)
#pkghtmldir = $(pkgdocdir)/html


# have both html and html/index.html to force build of index.html if necessary
EXTRA_DIST = latex/refman.pdf html html/index.html $(SOURCES)

-pkgdoc_DATA = \
+pdf_DATA = \
latex/refman.pdf

#pkghtml_DATA = \
@@ -17,22 +15,21 @@

if BUILD_DOCS
latex/refman.pdf: html/index.html
- -cd latex && make
+ $(MAKE) -C latex

html/index.html: ../Doxyfile $(SOURCES)
- -rm -rf html
- -cd .. && @DOXYGEN@ Doxyfile
+ rm -rf html && $(DOXYGEN) Doxyfile

clean-local:
- -rm -rf html
- -rm -rf latex
+ rm -rf html
+ rm -rf latex
endif

all-local: html/index.html

-install-data-local: all-local
- -echo installing to ${DESTDIR}${pkgdocdir}/html
- /bin/sh ../mkinstalldirs ${DESTDIR}${pkgdocdir}/html
- install html/* ${DESTDIR}${pkgdocdir}/html
+install-data-hook: all-local
+ -echo installing to $(DESTDIR)$(htmldir)
+ /bin/sh ../mkinstalldirs $(DESTDIR)$(htmldir)
+ install html/* $(DESTDIR)$(htmldir)


--- a/Makefile.am
+++ b/Makefile.am
@@ -10,6 +10,3 @@
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = librlog.pc

-documentation:
- cd docs && make
-
21 changes: 15 additions & 6 deletions dev-libs/rlog/rlog-1.4.ebuild
Original file line number Diff line number Diff line change
@@ -1,8 +1,9 @@
# Copyright 1999-2014 Gentoo Foundation
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=2
inherit eutils
EAPI=6

inherit autotools

DESCRIPTION="A C++ logging library"
HOMEPAGE="http://www.arg0.net/rlog"
Expand All @@ -13,11 +14,19 @@ SLOT="0"
KEYWORDS="amd64 ~arm ~ppc sparc x86"
IUSE=""

PATCHES=(
"${FILESDIR}"/${PN}-1.3.7-gcc-4.3.patch
"${FILESDIR}"/${PN}-1.4-fix-build-system.patch
)

src_prepare() {
epatch "${FILESDIR}"/${PN}-1.3.7-gcc-4.3.patch
default
eautoreconf
}

src_install() {
emake DESTDIR="${D}" pkgdocdir="/usr/share/doc/${PF}" install || die
dodoc AUTHORS ChangeLog README
default

# package installs .pc files
find "${D}" -name '*.la' -delete || die
}

0 comments on commit ae1c756

Please sign in to comment.