Skip to content

Commit

Permalink
dev-db/mongodb: bump to 3.4.9
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.10, Repoman-2.3.3
Closes: gentoo#5763
  • Loading branch information
hydrapolic authored and ultrabug committed Oct 13, 2017
1 parent 0230064 commit ae267a2
Show file tree
Hide file tree
Showing 2 changed files with 195 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-db/mongodb/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -9,3 +9,4 @@ DIST mongodb-src-r3.4.3.tar.gz 39832718 SHA256 889d49312ed072130936cfa3281123a0e
DIST mongodb-src-r3.4.4.tar.gz 39867133 SHA256 09e962bf3428474b9790bbd464cb6176817f9da6121c30e096240dbb4d51c9f6 SHA512 dbae89b49c363e7258021cd31385e4449bfdfdfd5adfcb1683e4431372731e58ec33bf8f7576d2d52659a52461bd6a32fbc67d5c6e36d52184ec1aabb345d940 WHIRLPOOL 5ad9f80c7f0f597982a32f95365df961fcd80ffa7c04183f9cb4952a52262a27ab09fee4d0115405c5197b6d3848ede56c9a4e5012ec1c358ea8c752164405c2
DIST mongodb-src-r3.4.6.tar.gz 39922209 SHA256 8170360f6dfede9c19c131f3d76831e952b3f1494925aa7e2a3a2f95b58ad901 SHA512 68da2f385a5e1d636f1699b13818e125af2b7f13c6ff74d5f6dc8f9e04025f9baaa23acfd386118d90ac0eb8b9b7dfbf5b00f1db580a1ea1fe2309361f46eae4 WHIRLPOOL 71b9f42a192b41c797763a02eb8b318488edbd7ffaa149497d3dea5c446c43ff078d24e48971ce4644d54767bcb848e1acaca3e17be9e8c50bbdd349e0d05fab
DIST mongodb-src-r3.4.7.tar.gz 39936247 SHA256 9272e7663c7915e09ad2609e28c58437d760d54a9552c711ea735cd8e1784ec0 SHA512 30f4d0dbd487d148531d7073881cd55db3fef3dcfd199e260e1a51858c5a2c28dfe904d1273b89b27b2fbcde23c3a301a3fa24766489ad6eb2daa25da31d3182 WHIRLPOOL 0ecaa271f9fbe634404aca2d13b0bb0ef47847656fc2825f5ff220655bc213df96170ec6009efc033c5e0a50baf7afd400c240dcaecdaf03fc356138121dd928
DIST mongodb-src-r3.4.9.tar.gz 39943857 SHA256 2fd0f47a5f9175e71d3d381e81a1b6a2500c9c414dd6ae0940ad6194a0e85549 SHA512 b6803c91e9cda8e6963359386d2014d03f68151f64d580d5baacc3c66b2adabc62ee5c2cf203b9aee7d11942934afc6f9e17364d2f3aafd238ba88d13c77f26d WHIRLPOOL 4360610c2223b7feef748f982ef3eed352ade080b48a935747056489e127759fe953dc6f1067d369b43e536fa1448c8d034f03eb1ad4dcd9ec064fd1f9491dba
194 changes: 194 additions & 0 deletions dev-db/mongodb/mongodb-3.4.9.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,194 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )

SCONS_MIN_VERSION="2.3.0"
CHECKREQS_DISK_BUILD="2400M"
CHECKREQS_DISK_USR="512M"
CHECKREQS_MEMORY="1024M"

inherit eutils flag-o-matic multilib multiprocessing pax-utils python-any-r1 scons-utils systemd toolchain-funcs user versionator check-reqs

MY_P=${PN}-src-r${PV/_rc/-rc}

DESCRIPTION="A high-performance, open source, schema-free document-oriented database"
HOMEPAGE="http://www.mongodb.org"
SRC_URI="https://fastdl.mongodb.org/src/${MY_P}.tar.gz"

LICENSE="AGPL-3 Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="debug kerberos libressl mms-agent ssl test +tools"

RDEPEND=">=app-arch/snappy-1.1.3
>=dev-cpp/yaml-cpp-0.5.3
>=dev-libs/boost-1.60[threads(+)]
>=dev-libs/libpcre-8.39[cxx]
dev-libs/snowball-stemmer
net-libs/libpcap
>=sys-libs/zlib-1.2.8
mms-agent? ( app-admin/mms-agent )
ssl? (
!libressl? ( >=dev-libs/openssl-1.0.1g:0= )
libressl? ( dev-libs/libressl:0= )
)"
DEPEND="${RDEPEND}
>=sys-devel/gcc-5.3.0:*
sys-libs/ncurses
sys-libs/readline
debug? ( dev-util/valgrind )
kerberos? ( dev-libs/cyrus-sasl[kerberos] )
test? (
dev-python/pymongo
dev-python/pyyaml
)"
PDEPEND="tools? ( >=app-admin/mongo-tools-${PV} )"

PATCHES=(
"${FILESDIR}/${PN}-3.2.10-boost-1.62.patch"
"${FILESDIR}/${PN}-3.4.0-fix-scons.patch"
"${FILESDIR}/${PN}-3.4.4-Replace-string-with-explicit-std-string.patch"
"${FILESDIR}/${PN}-3.4.6-sysmacros-include.patch"
"${FILESDIR}/${PN}-3.4.7-no-boost-check.patch"
)

S=${WORKDIR}/${MY_P}

pkg_pretend() {
if [[ ${REPLACING_VERSIONS} < 3.0 ]]; then
ewarn "To upgrade from a version earlier than the 3.0-series, you must"
ewarn "successively upgrade major releases until you have upgraded"
ewarn "to 3.2-series. Then upgrade to 3.4 series."
fi
}

pkg_setup() {
enewgroup mongodb
enewuser mongodb -1 -1 /var/lib/${PN} mongodb

# Maintainer notes
#
# --use-system-tcmalloc is strongly NOT recommended:
# https://www.mongodb.org/about/contributors/tutorial/build-mongodb-from-source/

scons_opts=(
CC="$(tc-getCC)"
CXX="$(tc-getCXX)"

--disable-warnings-as-errors
--use-system-boost
--use-system-pcre
--use-system-snappy
--use-system-stemmer
--use-system-yaml
--use-system-zlib
)

# wiredtiger not supported on 32bit platforms #572166
use x86 && scons_opts+=( --wiredtiger=off )

if use debug; then
scons_opts+=( --dbg=on )
fi

if use prefix; then
scons_opts+=(
--cpppath="${EPREFIX}/usr/include"
--libpath="${EPREFIX}/usr/$(get_libdir)"
)
fi

if use kerberos; then
scons_opts+=( --use-sasl-client )
fi

if use ssl; then
scons_opts+=( --ssl )
fi

python-any-r1_pkg_setup
}

src_compile() {
# respect mongoDB upstream's basic recommendations
# see bug #536688 and #526114
if ! use debug; then
filter-flags '-m*'
filter-flags '-O?'
fi
escons "${scons_opts[@]}" core tools
}

src_install() {
escons "${scons_opts[@]}" --nostrip install --prefix="${ED}"/usr

local x
for x in /var/{lib,log}/${PN}; do
keepdir "${x}"
fowners mongodb:mongodb "${x}"
done

doman debian/mongo*.1
dodoc README docs/building.md

newinitd "${FILESDIR}/${PN}.initd-r2" ${PN}
newconfd "${FILESDIR}/${PN}.confd-r2" ${PN}
newinitd "${FILESDIR}/${PN/db/s}.initd-r2" ${PN/db/s}
newconfd "${FILESDIR}/${PN/db/s}.confd-r2" ${PN/db/s}

insinto /etc
newins "${FILESDIR}/${PN}.conf-r3" ${PN}.conf
newins "${FILESDIR}/${PN/db/s}.conf-r2" ${PN/db/s}.conf

systemd_dounit "${FILESDIR}/${PN}.service"

insinto /etc/logrotate.d/
newins "${FILESDIR}/${PN}.logrotate" ${PN}

# see bug #526114
pax-mark emr "${ED}"/usr/bin/{mongo,mongod,mongos}
}

pkg_preinst() {
# wrt bug #461466
if [[ "$(get_libdir)" == "lib64" ]]; then
rmdir "${ED}"/usr/lib/ &>/dev/null
fi
}

src_test() {
# this one test fails
rm jstests/core/jsHeapLimit.js || die

"${EPYTHON}" ./buildscripts/resmoke.py --dbpathPrefix=test --suites core --jobs=$(makeopts_jobs) || die "Tests failed"
}

pkg_postinst() {
local v
for v in ${REPLACING_VERSIONS}; do
if ! version_is_at_least 3.0 ${v}; then
ewarn "!! IMPORTANT !!"
ewarn " "
ewarn "${PN} configuration files have changed !"
ewarn " "
ewarn "Make sure you migrate from /etc/conf.d/${PN} to the new YAML standard in /etc/${PN}.conf"
ewarn " http://docs.mongodb.org/manual/reference/configuration-options/"
ewarn " "
ewarn "Make sure you also follow the upgrading process :"
ewarn " http://docs.mongodb.org/master/release-notes/3.0-upgrade/"
ewarn " "
ewarn "MongoDB 3.0 introduces the WiredTiger storage engine."
ewarn "WiredTiger is incompatible with MMAPv1 and you need to dump/reload your data if you want to use it."
ewarn "Once you have your data dumped, you need to set storage.engine: wiredTiger in /etc/${PN}.conf"
ewarn " http://docs.mongodb.org/master/release-notes/3.0-upgrade/#change-storage-engine-to-wiredtiger"
break
fi
done

ewarn "Make sure to read the release notes and follow the upgrade process:"
ewarn " https://docs.mongodb.org/manual/release-notes/3.4/"
ewarn " https://docs.mongodb.com/manual/release-notes/3.4/#upgrade-procedures"
}

0 comments on commit ae267a2

Please sign in to comment.