Skip to content

Commit

Permalink
dev-lang/zig: version bump to 0.8.0
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.20, Repoman-3.0.3
Signed-off-by: Aisha Tammy <[email protected]>
Closes: gentoo#21175
Signed-off-by: Joonas Niilola <[email protected]>
  • Loading branch information
epsilon-0 authored and juippis committed Jul 3, 2021
1 parent 7dae620 commit ae36192
Show file tree
Hide file tree
Showing 3 changed files with 73 additions and 4 deletions.
1 change: 1 addition & 0 deletions dev-lang/zig/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST zig-0.7.1.tar.gz 16082917 BLAKE2B 401bb079f2d0e2ad26837940e3b79c14237a492bd0b4df616f91b8b454ebd4ac3de36b2c988369c9eaaf7c2df4f95d4b1bb97760629f813ac8c7220e9542e12b SHA512 ad0b36f7b40481aca03940adfd42d34a724922993fc29a23a80412dc087ca6ce4876a400dc9bb7da455564521a88ea205c218988759ff6c56251a08232bfa41a
DIST zig-0.8.0.tar.gz 19596459 BLAKE2B 7b688fdd201ce7b0b1e12127c4b1bf898699de18f410021e09bb056a56666aa8de512688a0048d6ac0ea8d6b7dfdb86e1a5416d2fab0a4911e16269d7b6be2a4 SHA512 2082810d5ab0560167766e80f0853e5ff99e32b1935836a6a0029b8e1c88061c55dd0c285cbcc506f4c38aac8477ec7162b771537699be9b3d387de94e3baa57
60 changes: 60 additions & 0 deletions dev-lang/zig/zig-0.8.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,60 @@
# Copyright 2019-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit cmake llvm

DESCRIPTION="A robust, optimal, and maintainable programming language"
HOMEPAGE="https://ziglang.org/"
LICENSE="MIT"
SLOT="0"
IUSE="+experimental test"
RESTRICT="!test? ( test )"

if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://github.com/ziglang/zig.git"
inherit git-r3
else
SRC_URI="https://github.com/ziglang/zig/archive/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"
fi

BUILD_DIR="${S}/build"

# According to zig's author, zig builds that do not support all targets are not
# supported by the upstream project.
ALL_LLVM_TARGETS=(
AArch64 AMDGPU ARM AVR BPF Hexagon Lanai Mips MSP430 NVPTX
PowerPC RISCV Sparc SystemZ WebAssembly X86 XCore
)
ALL_LLVM_TARGETS=( "${ALL_LLVM_TARGETS[@]/#/llvm_targets_}" )
LLVM_TARGET_USEDEPS="${ALL_LLVM_TARGETS[@]}"

LLVM_MAX_SLOT=12

RDEPEND="
sys-devel/clang:${LLVM_MAX_SLOT}
>=sys-devel/lld-12.0.0
<sys-devel/lld-13.0.0
sys-devel/llvm:${LLVM_MAX_SLOT}
!experimental? ( sys-devel/llvm:${LLVM_MAX_SLOT}[${LLVM_TARGET_USEDEPS// /,}] )
"
DEPEND="${RDEPEND}"

llvm_check_deps() {
has_version "sys-devel/clang:${LLVM_SLOT}"
}

src_configure() {
local mycmakeargs=(
-DZIG_USE_CCACHE=OFF
-DZIG_PREFER_CLANG_CPP_DYLIB=ON
)
cmake_src_configure
}

src_test() {
cd "${BUILD_DIR}"
./zig build test || die
}
16 changes: 12 additions & 4 deletions dev-lang/zig/zig-9999.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -9,7 +9,8 @@ DESCRIPTION="A robust, optimal, and maintainable programming language"
HOMEPAGE="https://ziglang.org/"
LICENSE="MIT"
SLOT="0"
IUSE="+experimental"
IUSE="+experimental test"
RESTRICT="!test? ( test )"

if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://github.com/ziglang/zig.git"
Expand All @@ -19,6 +20,8 @@ else
KEYWORDS="~amd64"
fi

BUILD_DIR="${S}/build"

# According to zig's author, zig builds that do not support all targets are not
# supported by the upstream project.
ALL_LLVM_TARGETS=(
Expand All @@ -28,12 +31,12 @@ ALL_LLVM_TARGETS=(
ALL_LLVM_TARGETS=( "${ALL_LLVM_TARGETS[@]/#/llvm_targets_}" )
LLVM_TARGET_USEDEPS="${ALL_LLVM_TARGETS[@]}"

LLVM_MAX_SLOT=11
LLVM_MAX_SLOT=12

RDEPEND="
sys-devel/clang:${LLVM_MAX_SLOT}
>=sys-devel/lld-11.0.0
<sys-devel/lld-12.0.0
>=sys-devel/lld-12.0.0
<sys-devel/lld-13.0.0
sys-devel/llvm:${LLVM_MAX_SLOT}
!experimental? ( sys-devel/llvm:${LLVM_MAX_SLOT}[${LLVM_TARGET_USEDEPS// /,}] )
"
Expand All @@ -50,3 +53,8 @@ src_configure() {
)
cmake_src_configure
}

src_test() {
cd "${BUILD_DIR}"
./zig build test || die
}

0 comments on commit ae36192

Please sign in to comment.