Skip to content

Commit

Permalink
app-forensics/chkrootkit: Version bump (bug 529308, thanks Paolo Pedr…
Browse files Browse the repository at this point in the history
…oni).

Package-Manager: portage-2.2.28
  • Loading branch information
xmw committed Mar 21, 2016
1 parent bf2acdc commit ae6d6ff
Show file tree
Hide file tree
Showing 2 changed files with 55 additions and 0 deletions.
2 changes: 2 additions & 0 deletions app-forensics/chkrootkit/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,4 @@
DIST chkrootkit-0.49-gentoo.diff.bz2 5472 SHA256 85a01c8bb159420fc7681b5f3ec6529bc69cf10b3484daee0a5c126ef4a7b5d8 SHA512 4121d09f7bb6ad7d3f2ed42c914087f4724877def3c591fd6b7fa8e2b2b23a1b32b1bb1ba94dc079914c967d2483ebd614582b13afb4c1c801701a58ada89b62 WHIRLPOOL 25df5424700c72d19201faf6555790b04b878af3ef185f52f44807e018701926cd9e8d112343b86168ad6688df8fffcc2829c11886d8f628b03ff7f63f1ac7d0
DIST chkrootkit-0.49.tar.gz 39421 SHA256 ccb87be09e8923d51f450a167f484414f70c36c942f8ef5b9e5e4a69b7baa17f SHA512 b796547fc483635ff6ee4e953f7dda34913189459de05b547522b79f8edeef5adae72cc05515b8ff9382cbabffd93cae7d114a40636e14c55da513bb42b05909 WHIRLPOOL c94f96f185ae5f5dd038a7b2ffd9603ee8c0f2fcbaeb3eb73d20260898f1677a2c1aad5cd6a257b29ca540d02916dca59434ff10b807567447889cf23f65b25e
DIST chkrootkit-0.50-gentoo.diff.bz2 5010 SHA256 0b29ad086d0c75df6a0826bc8fd9046d5b1086173652af77f01991f367032779 SHA512 067a0a33fad2389a7ef942f76a63bed6c206d08576a77fd758ae171960804fb74d3164bc6eb582f5d8b722e9e863dc4380f5632940bc9a8c1821b46ed1062a50 WHIRLPOOL 4bc08be7be6d566bb2f52ece6c9010967c107696ce924461a4032947f66e848183921232f3f1a971cf6f932cbaad7ac9ce18af765837e3e69f7c0a57b39ceaed
DIST chkrootkit-0.50.tar.gz 38616 SHA256 9548fc922b0cb8ddf055faff4a4887f140a31c45f2f5e3aa64aad91ecfa56cc7 SHA512 9f26fd34e85b58b13dedc5f38a889ae258bb2c0f1ff40e99c149e23f93890e956f94204b1bb2241584454e99168c53b583f52777083454237f3ba343424dba1c WHIRLPOOL d6c6afe6a14e5a9a0331202b894ed5c3e43855e15605cc9a6cbf69dbd09f180754ee587cf4eba88cb0ceb4d7fcd9924f4f02110154450fd06e992fc1710b91d8
53 changes: 53 additions & 0 deletions app-forensics/chkrootkit/chkrootkit-0.50.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,53 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI="5"

inherit eutils toolchain-funcs

DESCRIPTION="Tool to locally check for signs of a rootkit"
HOMEPAGE="http://www.chkrootkit.org/"
SRC_URI="ftp://ftp.pangeia.com.br/pub/seg/pac/${P}.tar.gz
https://dev.gentoo.org/~xmw/${P}-gentoo.diff.bz2"

LICENSE="BSD-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
IUSE="+cron"

RDEPEND="cron? ( virtual/cron )"

src_prepare() {
epatch "${WORKDIR}"/${P}-gentoo.diff
sed -e 's:/var/adm/:/var/log/:g' \
-i chklastlog.c || die
}

src_compile() {
emake CC="$(tc-getCC)" STRIP=true sense
}

src_install() {
dosbin chkdirs chklastlog chkproc chkrootkit chkwtmp chkutmp ifpromisc strings-static
dodoc ACKNOWLEDGMENTS README*

if use cron ; then
exeinto /etc/cron.weekly
newexe "${FILESDIR}"/${PN}.cron ${PN}
fi
}

pkg_postinst() {
if use cron ; then
elog
elog "Edit /etc/cron.weekly/chkrootkit to activate chkrootkit!"
elog
fi

elog
elog "Some applications, such as portsentry, will cause chkrootkit"
elog "to produce false positives. Read the chkrootkit FAQ at"
elog "http://www.chkrootkit.org/ for more information."
elog
}

0 comments on commit ae6d6ff

Please sign in to comment.