forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-emacs/lyskom-elisp-client: New snapshot.
Prevent the Makefile from trying to access git. Bug: 595206 Package-Manager: Portage-2.3.6, Repoman-2.3.2
- Loading branch information
Showing
3 changed files
with
65 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST lyskom-elisp-client-0.48_p20131231.tar.xz 888212 SHA256 d34ebefc299942ae3990f4d309ae17bef847b5e546482bbfe6b5cdd78a0c55b7 SHA512 124dc45194d68588535e134acae9de9b19484b568c43d2eb49d3c4e8ee923e0baf64a634181a3238f34cf59a98a5a1e92e988519d26e8f3c3a0e867f500d53e9 WHIRLPOOL f13addd5561a86f257def968b5a7d73433e1d53bde0452dcc6bbfe41381eb977fa1da398eac05da1c113c8c82c59a4db2c62ba4825fb83db1f548bdb54dc6f04 | ||
DIST lyskom-elisp-client-0.48_p20161231.tar.xz 889464 SHA256 5c8c932dcb7d8068b574dc5812dd71f1ce277c00ce3b891bbec210245ad148b7 SHA512 f412a0b1b9f71be26ac511f66ba5215e757287baa668ce71802802eb13f907137fe27a96614c58abac510104c1d9558cf9b62b3bf8e598c11b4fa3bc33269f81 WHIRLPOOL 0fcf0ebc581a7d0a973905c4ba5c4b3a6f904fdd7a3ffc553fce8fe0edf76d3ab985e83245b11f260d0ece7af03f762cb4e568c9e87d954e8037283d3c42017c |
20 changes: 20 additions & 0 deletions
20
app-emacs/lyskom-elisp-client/files/lyskom-elisp-client-0.48_p20161231-no-git.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,20 @@ | ||
--- lyskom-elisp-client-orig/src/Makefile | ||
+++ lyskom-elisp-client/src/Makefile | ||
@@ -41,7 +41,7 @@ | ||
# Also remember to change version number in ../doc/Makefile! | ||
LASTRELEASE = 0.48 | ||
NEXTRELEASE = 0.49 | ||
-CLIENTVERSION = $(shell (git describe --exact-match --tags HEAD 2>/dev/null || git describe --tags --match 'v*' --dirty) | sed -e 's/^v//' -e 's/-/-devbuild-/') | ||
+CLIENTVERSION = unknown | ||
|
||
###################################################################### | ||
|
||
@@ -155,7 +155,7 @@ | ||
|
||
version.el: version.el.in Makefile $(HEADER1) $(HEADER2) $(LANGUAGE-EL) $(SOURCES) | ||
rm -f $@ | ||
- sed "s/@@CLIENTVERSION@@/$(LASTRELEASE) (`date +%Y-%m-%d`; Git `git rev-parse --short HEAD``git diff --quiet HEAD||echo '*'`)/g" <$< >$@ | ||
+ sed "s/@@CLIENTVERSION@@/$(LASTRELEASE) (@@DATE@@; Git *)/g" <$< >$@ | ||
chmod 444 $@ | ||
|
||
version.el-release: version.el.in Makefile $(HEADER1) $(HEADER2) $(LANGUAGE-EL) $(SOURCES) |
44 changes: 44 additions & 0 deletions
44
app-emacs/lyskom-elisp-client/lyskom-elisp-client-0.48_p20161231.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,44 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
|
||
inherit elisp readme.gentoo-r1 | ||
|
||
DESCRIPTION="Elisp client for the LysKOM conference system" | ||
HOMEPAGE="http://www.lysator.liu.se/lyskom/klienter/emacslisp/index.en.html" | ||
# snapshot of git://git.lysator.liu.se/${PN}/${PN}.git | ||
SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.tar.xz" | ||
|
||
LICENSE="GPL-2+" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~sparc ~x86" | ||
IUSE="l10n_sv" | ||
|
||
S="${WORKDIR}/${PN}" | ||
ELISP_PATCHES="${P}-no-git.patch" | ||
SITEFILE="50${PN}-gentoo.el" | ||
|
||
src_prepare() { | ||
elisp_src_prepare | ||
local d=${PV#*_p} | ||
sed -i "s/@@DATE@@/${d:0:4}-${d:4:2}-${d:6:2}/" src/Makefile || die | ||
} | ||
|
||
src_compile() { | ||
emake -C src EMACS=emacs | ||
# Info page is in Swedish only | ||
use l10n_sv && emake -C doc elisp-client | ||
} | ||
|
||
src_install() { | ||
elisp-install ${PN} src/lyskom.{el,elc} | ||
elisp-site-file-install "${FILESDIR}/${SITEFILE}" | ||
dodoc src/{ChangeLog*,README,TODO} doc/NEWS* | ||
use l10n_sv && doinfo doc/elisp-client | ||
|
||
DOC_CONTENTS="If you prefer an English language environment, add the | ||
following line to your ~/.emacs file: | ||
\n\t(setq-default kom-default-language 'en)" | ||
readme.gentoo_create_doc | ||
} |