Skip to content

Commit

Permalink
app-emulation/qt-virt-manager: Introduce qt-virt-manager, bug #598932
Browse files Browse the repository at this point in the history
Initial ebuild based on work by Michal Privoznik. Thanks a lot!

Package-Manager: Portage-2.3.3, Repoman-2.3.2
  • Loading branch information
tamiko committed Mar 14, 2017
1 parent c3c34a4 commit ae70d5e
Show file tree
Hide file tree
Showing 2 changed files with 60 additions and 0 deletions.
11 changes: 11 additions & 0 deletions app-emulation/qt-virt-manager/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>[email protected]</email>
<name>Gentoo Virtualization Project</name>
</maintainer>
<use>
<flag name="smartcard">Enable smartcard remoting using <pkg>app-emulation/libcacard</pkg></flag>
</use>
</pkgmetadata>
49 changes: 49 additions & 0 deletions app-emulation/qt-virt-manager/qt-virt-manager-9999.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,49 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit cmake-utils

if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/F1ash/qt-virt-manager.git"
EGIT_BRANCH="master"
inherit git-r3
SRC_URI=""
KEYWORDS=""
else
SRC_URI="https://github.com/F1ash/qt-virt-manager/archive/${P}.tar.gz"
KEYWORDS=""
fi

DESCRIPTION="A GUI application for managing virtual machines"
HOMEPAGE="https://github.com/F1ash/qt-virt-manager"

LICENSE="GPL-2"
SLOT="0"
IUSE="smartcard"

DEPEND="
dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtmultimedia:5
dev-qt/qtsvg:5
dev-qt/qtwidgets:5
dev-qt/qtxml:5
dev-qt/qtnetwork:5
>=x11-libs/qtermwidget-0.7.0
smartcard? ( >=app-emulation/libcacard-2.5.0 )
dev-libs/glib
net-misc/spice-gtk
net-libs/libvncserver
app-emulation/libvirt
"
RDEPEND="${DEPEND}"

src_configure() {
local mycmakeargs=(
-DBUILD_QT_VERSION=5
-DWITH_LIBCACARD="$(usex smartcard ON OFF)"
)
cmake-utils_src_configure
}

0 comments on commit ae70d5e

Please sign in to comment.